Poor ARC connectivity outside home WiFi

I’ve successfully setup the new upgrade and installed ARC. All the upgraded remotes on my home setup work fine now (after restarting the core about 5 times). The ARC app on my iPhone works fine when I’m on my home network but outside the house I get “poor connectivity” messages and it won’t get going. Other services (e.g. Tidal) are streaming fine outside. What could the problem be?

CORRECTION: I was just able to play from ARC after turning off iPhone WiFi connection because the track had already buffered. So, without WiFi, I’m unable to connect to the core even when I’m right next to it. With WiFi it works fine.

Your internet connection needs to support enough data bandwidth speed (upload) to use ARC. other things going on at the same time like video calls etc might impact this.

Proximity to your core makes no difference, even when using WIFI. With WIFI, proximity to your router might make a difference. With WIFI turned off, proximity to your cell tower would make a difference.

I was kidding about the proximity. Obviously, not relevant. My internet connection is streaming cellular data when I’m outside my home WiFi and not sitting in some other WiFi zone. If all my other apps stream easily in a particular location what’s the problem with Roon? The assumption is that you don’t need to be somewhere with high bandwidth access (e.g. other WiFi network). It should work with 5G cellular. No?

It should work on most 3/4/5G networks and even if you others wifi like friends house or office or cafe etc

And if it’s relevant or useful to anyone here is the diagnostics data:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Well, it is not working because the port forwarding is not working as indicated by the error message. Do you have ATT mobile internet or Fiber internet? And do you have multiple routers in place in case there is a multiple NAT issue going on?

I have one ATT BGW210 router (with fiber to the node, unfortunately).

I have the router configuration site open but cannot find the various things that others have suggested. I wasn’t a CS major and never took networking classes so this is a little taxing.

1 Like

Try reviewing the steps here which solved it for that router.

I’m at the NAT/Gaming page and tried to do it but I must not have done it correctly.

Rugby: I appreciate the reference but it’s kind of incomprehensible to me.

But the firewall on my core (MacBook air, not windows) was already off.

And I’ve looked through pretty much every page of the router configuration site and cannot find any switch for UPnP.

Hi Michael,

I’m going to move your post to the Support section, so that Roon’s official support will see it. I am also appending the information they are requesting, some of which you have already provided, but, if you could repeat it so it is all in one post that would be great.


Can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?


Thanks for your help.

  1. ATT service provider with fiber to the node.
  2. ATT BGW210
  3. No additional routers and I have no idea what a “managed switch” is so probably not
  4. No VPNs, proxy servers, or enterprise grade security (whatever that would be)
  5. Core is on a MacBook Air 1.7 Dual Core i7 with 8 gb memory running Big Sur 11.7
    and the only thing it does is house the core.

Download speed is typically ~45 mbs and upload around 12 mbs.

Sorry. Core machine is connected to the router with an ethernet cable.

Michael, I have AT&T Fiber and a different older gateway, but have been testing ARC for a few months now. I have an additional router (ASUS) behind my AT&T Pace gateway, and my first error message was similar to what you have, which is indicative of two routers in your network, one connected to the AT&T BGW210.

You mentioned that you have an FTTN solution. Is there anything connected between your BGW210 and the connection to AT&T’s network (usually a wall-mounted modem or network terminator)? Do you have any other networking devices connected to the BGW210, such as WiFi extenders?

Thanks very much for responding. In the morning I’ll try and trace back from the router. I don’t recall any substantial devices. Would passive terminators be a problem? Don’t they serve a function? If I find one we can talk about what to do. No point in belaboring a hypothetical.

I do have ATT FTTN with wire for the last few blocks. I have an Orbi mesh system in the house not extenders. But I don’t get why that would be an issue anyway since it’s, essentially, downstream.