Problem running convolution on ROCK

Hello to all,
I have a problem with the convolution to be applied on ROCK, HAF files with Win10 are perfect, I followed these topics but I can’t.

Can anyone guide me step by step like you would for a 5 year old? :frowning:

Thank you all

No expert here but pretty sure it means you need a windows pc or Mac to first set up the convolution filters.
Then it should be available to Rock afterwards.

If this is incorrect I am sure someone will say so!


@AceRimmer is correct.

Use your PC to connect to ROCK as a remote. You will then see the Browse option in the convolution part of the DSP settings for your endpoint. See this Roon KB article. Once added, you don’t need the PC as remote anymore.

1 Like


I try to explain myself better.

it is the remote from Win 10 that does not connect with Rock, even if in my network they are visible.
I tried Win10 remote → Rock Core with Eth cable and Wi-Fi
I waited thirty minutes and tried several times


Ping on Pc Win10 To Ip Core Rock ( OK)

Connect to Roon Core

Click “Connect” after 30 minutes of waiting, several attempts

How remote is it better to use Win 10 to Rock Core with ETH or Wi-FI?


W10 firewall? Switch it off to see if anything changes.

Firewall is disabled

I’d try uninstalling Roon from your Windows PC and then reinstalling.

Already done but I haven’t solved it .

Is this a new install or one thats been running for a while? Can you connect to Roon on the Rock core from a phone or tablet and use it ok? Can you connect to ROCKs webui from the laptop? Just type it’s up address in your browser and the web admin page should pop up. Post a screen grab of this so we can see if anything is off here.

Try turning off any firewall and Antivirus software temporarily on Windows machine to see if it helps.

Restart you network gear, rock and Windows machine.

What is your network setup, using any switches? what router are you using, any mesh systems.

probably with Rock the problem is caused by my Powerline TpLink Eth. that with Win10 and Roon did not give problems, today I’m trying a set of a friend and I managed to do the convolution from remote PC to Rock.
I find no other explanation, for now …

1 Like

Ah .
If you had said you were using a EoP connection at the beginning I would have suggested trying without.
Roon occasionally has “issues” with EoP connections.

It would not work for me either for Roon but did work just fine to connect a 4k TV with.

1 Like

Kev, it’s not PoE, it EoP they are very different kettles.of fish. PoE provides power to devices over Ethernet. The latter ethernet of powerlines. The latter is horrible in general radiates RF every where and often causes audible interference with hifi equipment.

1 Like

Doh, my bad I meant EoP.
God knows why I put PoE!

Yes I use a TP-Link EoP for a TV that would be very difficult to run an Ethernet line to.
I could but a lot of work and the EoP works fine for it.

Hi Simon,
I agree with you, Hi-Fi and Powerlines are to be avoided …
I had to use them because Rock doesn’t have the Wi-Fi option and I didn’t know that :frowning:
otherwise I was left with Wi-Fi.
Previous configuration: Qobuz → Router → wi-fi → Win10 laptop with Roon → Switch → Eth cable → Devialet and lots of good music !!

1 Like

Rock may work with some USB WiFi dongles but for wireless cards it’s not really supported much at all. Seems to work ok with certain USB chipsets. I got mine to work with one dongle I had but not another.

1 Like

Thank you,
Can you tell me which Dongle model I can try?

I can’t I don’t have it any more. There was a thread somewhere on here that someone started listing ones that worked. Perhaps search the forum for that. Or its just try it and see. If you have some lying a round just plug it in. If it recognises it , it will show in Rocks WebUi in the network section.

I found my one was this

Tontec 2ghz N (Realtek RTL8188CU)
You could also use a wireless bridge not as elegant but will work with anyone as you plugging it into the lan port.

1 Like

I found no Brand on Ebay of Realtek RTL8188CU, it looks the same.


Realtek RTL8188CU

It is only 2.4ghz so you may have some bandwidth issues with it, I only used to use it for a an older pi as an endpoint and just wanted to see if it worked with Rock and it did. I do think you would be better served by a wireless bridge or mesh device if you can’t wire it in.