Problems connecting to Remote and Remote drops out

Core Machine (Operating system/System info/Roon build number)

Lenovo Ideapad C340 Win10, Roon per august 6 2020 ( cant find build number), Lifetime subscription/trial 48 day left of 60 days trial by invitation from Roon after Trinnov -Roon demo

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Wifi from PC, players cabled to router, Toshiba USB hardisk DT 8440 4TB 62 000 tracks connected to Router Technicolor EPC3940L. Wifi quality 100 of 100 points by InSSIDERr Home, wifi speed 433 MBs, siting 8feet from an in direct sight of the Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
audio devices(by network cable: Trinnov Amethyst, Lindemann Network, Sonos Connecttbridge.
By Wifi: Chromcast audio i)

Description Of Issue

I cannot get the Remote app on Iphone 8 to work in a stable manner with Core in Lenovo Ideapad C340. In 9 of 10 attempts I find no connection, and if it connects but drops out and reconnect with few seconds interval. Network looks good. 99-100 of 100 score. Router EPC3940L

I notice that when the USB disk is inactive( Roon not doing anything in the background?- analysing scanning- I can connect better.
Today when I have not yet clicked in the USB drive from file explorer( drive sleeping/inactive, and ROON Storage “tab” says “drive is unavailable” ), then I could connect with the remote in Iphone 8, after starting the Remote 2 times, fisrt time it says "No connection#

I also note that Tidal never logs in at start up ,but log inn ok after a retry .

BUT, when I activate the USB disk connected to the Router ( by clicking on Z: drive ( Network disk)in File explorer the drive start up and Roos finds it and start to scan files, THEN the Remote connection is immediately lost, and trying to connection fails “lost connection”
It takes about 10.or 15 minutes to scan the USB drive, after that I am able to connect again, TODAY but not always. I closes the Remota and restarte aoptle of times i worked 4 times but not the 5th, I onlye got a white screen with black Roon Icion. 2 mor restarts ant i work adin.

Suspect ROON is not responding in time in on request from the Remote when it is busy with something, it is quite annoying to have to wait 15 minutes to play music, and I do not know it I am successful the next time.


Roon will rescan the entire drive when it comes back “online” from the Servers pov.

Here are a couple of my suggestions.

  1. Leave the RoonServer and attached music sources on. (This will eliminate the startup delay).

  2. Keep the music files local to the RoonServer (reduces network traffic as all music played is sent to the server first, processed, and then back out to the endpoint. reduces track starup times.)

Hi @Erik_Solheim,

Welcome to the forum.

WiFi, even in direct sight can be prone to interference, before we go into investigating the router settings too much, the simplest test would be to connect the Core PC via Ethernet and see if the situation improves.

We’ve seen a few issues with IPv6 on Technicolor routers in the past and this could be the issue you are experiencing.

Also, we have found that ISP-provided routers often don’t have their multicast implementation quite right and sometimes need tweaking. Our Networking Best Practices Guide provides further info on this.

Thanks, Router does not use IPV6 only IPV4.
No Etherne plugin on PC

I also noticed that I for the firtsttime got a Windows Defender message, RAAT Server wants to make changes to this PC “allow or deny” or something like that, I replied Yes allow.

Another message I did not think was from Roon I said NO to, maybe that was wrong of me.

Tried to connect again today. Same ay described above, as long as ROON on not scanning the USB drive connected to router the Remote App on Iphone8 can connect. While scanning USB drive Remote only occasionally connects and drop out. maybe I just have to accept the Remote will not work while scanning takes place, but it is a concern when I gat a larger library and scanning will take longer. Maybe a NUC/Rock would perform without this inconvenience?

Hi @Erik_Solheim,

Thanks for those additional details!

If you said No to one of the Roon firewall exceptions, it is possible that this is causing a conflict. Here’s what I would do to test this theory, I would remove the current ones and then manually re-add both:

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Did you try reinstalling the Roon app on the iPhone yet? Does that change anything?

Firewall settinge looked like this
RAAT server and Roon.exe one line ticked for Private and one line for Public

I did reinstall Remote app on Iphone.
. Remote on Iphone works when USB disk connected to Router is NOT active, When I started backup of disk to cloud storage I again got problems to connect with remote… “Error loading page” connection comes and goes . When pusing clod backup of disk Remote connection is stable again.
Seems like Roon checks or monitors the disk and get too busy with that to respond to the Remote.

  1. NO Roon scanning or NO cloud backup of disk=Remote works fine
  2. Roon scanning or other process access disk=Remote connection is lost/unstable

Hi @Erik_Solheim,

I would remove both RAATServer.exe and Roon.exe from that list and manually re-add them from the %localappdata%/Roon path.

Done. Closed Roon before I did it

No change, the remote cannot connect while Roon is scanning the USB disk files. (takes 10 minutes fo complete scan). After that is seems OK as long as I dot lot acess the USB disk. If A start disk backup to cloud connection to Remote is lost. So anything that makes the disk active causess communication problems for Roon

her e

is the PC load

Hi @Erik_Solheim,

It does sound like you are pushing this router past it’s limit. I would look into getting a proper network attached storage device like a QNAP or a Synology so that IO operations don’t tax the router so much.

I also suspect that the multicast implementation on this router might not be the best, would you have another, consumer-grade one to try, as a temporary test to confirm at least?

After updating from version 571 to 610, Roon remote to Ipad Iphone drops out all the time, and cannot connect. How can I roll back to 571 where thing workked much better. ?With 610 I also have to log in at every start of Roon Very annoying

seems like using PC wired to router works better regarding wireless Remote- Still bugged by that I have to login to Roon every time I start the app. Pleeezze make login automatic again

After the latest Roon iudate this happens to mee also. I am asked to login in everytime I start Roon. very annoying,please fix this

Nothing was changed from the set up above. Only change was Roon update, after utdate I am forced to logIn every time I start Roon, please advice what to get back to automatic login. It takes 2 minutes waiting to get logged in

Hi @Erik_Solheim,

Can you please let me know the exact local time + date you are asked to re-login again? Once I have this info I’d like to enable diagnostics mode for your account, thanks!

I opened Roon agian at sep 2 06:49 local time Osloo Norway, and was again asked to log in with email and password, also happened yesterday between 18:00 and 23 :00 do not have excact time then

1 Like

Thanks for that timestamps @Erik_Solheim!

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once this report reaches our servers, I’ll ask QA to review for further clues.

What does the analysis say? Most of the time I have to sign in at start of Roon , but not always , strange
Remote app worked much better / less drop out when laptop pc with Roon is connected to router by cable

Hi @Erik_Solheim,

I can confirm that logs from your Core have been received and passed to QA for further investigation into this issue. We have a few similar reports so we are investigating the common factors, thanks for your patience while we look into this further!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.