Pulling Hair Out! Can't Connect to NAS after new STi5

I’ve had Roon running from a Synology NAS (Core running from SSD connected to NAS via USB). It performed very well, albeit slow at times. I’ve spend the past several years saving for a “dream” system, that included a McIntosh 8900, which I just purchased and set up Friday. The Mac is currently being fed by a Node 2i. My last piece was to upgrade my core from the Synology to a STi5. I restored a backup to the STi5 and all seemed well.
BUT…I’ve spent the last 2.5 days trying to get Roon to see my network share and I don’t know what else to do. I’ve read every post on this forum and nothing is helping. SMB is enabled, I’ve tried every version of my network path I can think of…yes, I can get to the files via my windows 10 PC. IT WAS WORKING!

I’ve even added the “local” term into the path. Roon is loading and connecting to my QoBuz account.

Question: Do I have to mount the network folder within SonicOrbiter first and then add it to Roon? I’ve tried that too to no avail. Some of these screen shots may show the music file as All Music. In an act of desperation, I ultimately changed it to All_Music in order to eliminate the space, thinking that may be causing a problem. Please someone, for the love of God, help me!! Not being able to listen to the system as I intended is killing me! Although the turntable hooked up to it never sounded better.

You can try this solution, found by another user:

Thanks BlackJack…giving it a try now…

Is there a way to verify that it’s been mounted within SonicTransporter?

It’s not adding it. I’ve tried several different paths. You can see where I was successful in mounting the USB I used to restore from back up. But no network share.

You could try mounting the connected drive on your Mac/Windows desktop. Then, within the mounted drive, navigate to /storage/nas (the mount point for your SMB server drive).

But don’t you get some feedback within the sonicTransporter Settings/Drive Mounter window on your browser? I don’t remember if I did or not. My Drive Mounter settings look like this:

By the way, I had problems like yours, but then yesterday the share drive mysteriously became accessible again (without going through the procedure I described in the link above.)

sonincTransporter only says “Drive Mounter reconfigured successfully.” But it doesn’t give an visual confirmation that’s occurred. So although I get that message, it doesn’t seem to actually mount the drive.

FWIW…when I add “local” into the path, it seems to be “adding” for a few seconds before it finally fails.

//Ev_Media.local/All_Music or //

Is this something SGC need to assist with?

That’s what I thought and I started there first. This was the reply I received.

I’ve successfully reinstalled my old NAS/USB/SSD version. I notice that this is the address Roon sees:

Perhaps I need to add the “Synology DS218+” into it? But maybe that’s why you need to type in “local” into the address. I’m more confused than ever and very disappointed that I can’t get the STi5 to run as intended.

As of your description, your old core was running on the NAS where the files where stored too. You were just pointing to the local folder. Adding a network share wasn’t needed there.

Technically that’s correct…I think…I had the Core running on a separate USB attached SSD though.

Are you saying that I actually may have never had this running over network share?

Yes. As it seems that there is no (smb) share at all at //Ev_Media/All_Music, you might want to check your sharing settings on the NAS. You should also try to connect to the share form your PC/Mac.

FAQ: I’m having trouble setting up my NAS

Hi @Thomas_Eviston,

When you were mounting the share before it sounds like you were doing it through local attached storage, not through the network.

According to this screenshot, I’m not seeing any Username + Password + Workgroup listed here. I would try adding the Workgroup of WORKGROUP as per the QNAP Workgroup name you set.

You could also try using \\Ev_Media\All_Music as the Network Share location, that might help.

Thank you Noris. I did enter the name/password combo.

I’m even more at a loss now. I’ve reinstalled my original Core (running an SSD attached via USB to the Synology NAS. As an earlier user suggested, I was accessing locally. So I created a “test” folder on my Nas. Tried to point to it and filled it with a test files.

Roon is working as expected. If I shut down this core, launch sonicorbiter and try accessing it, I get these errors

SOLVED…OK for anyone following this, having similar issues, I replaced the network share name (in my case Ev_Media) with the IP and it worked. FINALLY.


I tried that too. It did not work, until it did.

Hi @Thomas_Eviston,

Glad to hear that the issue is resolved with mounting via IP address! If you have any further issues feel free to let us know, take care!