QNAP 1282t 4.3.3 server setup not found "Looking For Remote Libraries"

I never heard back from you after I replied to your email response and asked you some more questions do you not reply to emails?

The burning question right now is QNAP setup?
I have a QNAP 1282t with 8x 8tb drives in a raid 6,
I am running 4.3.3 on the qnap
I have installed the roon server 2017-02-02 it is running.

When I launch Roon it can not find it. I tried entering the IP address ( do I need any other info for the address?
I have spent over 10 hours reading forums and following bread crumbs to get this up and running with no luck. just a “Looking For Remote Libraries”

PLEASE HELP!!! How hard can it be to make a step by step guide setting this up on a QNAP with possible issues and solution to try?

My only success has been to get it running on the HP z840 but that’s not desired.

Hi Peter,
can you check if all devices are in the same subnet (10.10.10.x)?
Have you checked if there are any firewall involved on any of your Roon devices?

Were you writing with me before, or someone from the Roon Labs support staff?

The volumes on QNAP are mounted on the computer through a direct connect to the z840 (Windows 10 Pro) on a 10gig E.
There is a 1gig E that is connected through a switch for internet for both the Qnap and the z840.

I had replied to Kevin from Roon’s email on July 10th and never heard back.

Hi @Peter_McCabe, apologies for any confusion over email! My last email to you was a recommendation to submit a support request here, but I hadn’t heard from you after that. Not to worry though, we’ve got you in the right place now :slight_smile:

Are you able to confirm that none of your devices running Roon have an active firewall? And that they’re on the same subnet like @crieke mentioned? We’ve got some more information on troubleshooting this at the following link: https://kb.roonlabs.com/Why_can’t_Roon_Remote_Connect%3F

Failing that, we can involve @support to troubleshoot further.

Thank you for your patience! Hope to get this resolved shortly.

I have confirmed all network setting are correct firewall is not involved @support

Hi @Peter_McCabe ----- Thank you for the report and sharing your feedback with us. Both are appreciated and sorry to hear of the troubles here.

Moving forward, may I very kindly ask you to please provide me with the following:

  1. An expanded description of your current setup as seen here

  2. Following the instructions found here, please provide us with a copy of your RoonServer logs from the QNAP NAS.


Hello Eric,
I never got Roon running on the NAS just the z840 workstation the Roon folder is empty on the NAS

I want to run it on a QNAP 1282t 32gb ram i7 processor running at 3.4ghz the latest QNAP operating system
I have installed the Roon server 2017-02-02 it is running.
I have a folder on the QNAP called RoonServer (where does this actually need to be ? root level? the path is “/RoonServer”

The Windows machine is running v10 pro v1607 64gb ram 2x 6core 3.4ghz
A Sonnet 10gigE card, 5x 12tb hard drives (4x raided ) HP zTurbo Quad card that has the boot drive on it.

They are both on the same network (Qnap) and for Sonnet 10gigE both are on subnet

The QNAP folders all show up

What would really be helpful at this point would be someone to Teamview in. I have spent over 12 hours reading forum posts, deleting, reinstalling, rebooting turning on and off all kinds of things…

When creating the RoonServer shared folder you can leave the “Path” setting at “Specify Path automatically” and it should work.

Can you check if there are any folders on your RoonServer shared folder. When RoonServer is started 2 folders should appear there: RoonServer and RAATServer.
If they are not there, something is preventing RoonServer from starting.

It should look like this:

(Please note, that in my case the RoonServer shared folder is an external USB drive. Because of that it is not listed in the DataVol1 section.)

Hello Christopher,

The folder is empty on the QNAP NAS.(just a recycle folder)

I have ONLY been able to get it running on the z840.

Lets pretender I was someones grand parent and layout the steps.
This is what I did.

  1. I downloaded RoonServer_QNAP_x86_64_2017-02-02.qpkg
  2. Fired up Hybrid Desk Station on QNAP to install the above package
    3.Choose to install manually and located it with browser and installed
  3. After install I confirmed it was installed in “QNAP App Center” it was and the option to open it only takes you to an empty window that allows you to “stop or remove”. I left it running
  4. Fired up Roon on HP z840 where I was greeted by 3 options.
    a. “I want to use PC to Manage my Music Library”
    b. “I want to use this PC as a remote control”
    c. “Configure Roon OS devices on your Network”
  5. I picked “b” and was greeted by “Looking For Remote Libraries” I let it run for a very long time. I clicked on “Why cant I see remote Library” and enter IP address many times over. I rebooted computer and QNAP a few times after uninstalling and reinstalling the .qpkg and the Roon installer app
    8.After scouring the forum and finding some breadcrumbs and trying to apply newly found info I ended up trying “a” to see if Roon was completely broken but having it run locally worked immediately.

It really would be awesome if someone had instructions with screen shots to follow.
I am still not sure what the .qpkg install should do and look like after install. Should there be no options other than “stop and remove”? and what does it create a folder? Your screen shot with the folders was that created by .qpkg install or the Roon app? My Roon app launch never connected so is that why I do not have the RAATServer and RoonServer ( I manual created a RoonServer folder on QNAP).

Did I miss something in the above steps?


I never installed the qpkg with HybridDesk Station, so I just tried to do it as you did. It was working as well. Can you check the QNAP System Log? Just click on the Icon on the top bar (see picture below) and click “more”.

A new window appears. Use the “Search” text field and search for “RoonServer”:

What entries can you see in that window? (Can you post a screenshot?)

So flailing in the dark I copied the Roon folder from the z840 (appdata) to the RoonServer folder on the QNAP.That was done on the 19th

That looks good so far.
When you are opening FileStation and select the RoonServer share at the left sidebar, what contents do you see? Are 2 folder (RoonServer & RAATServer) in there? These folders are created by the RoonServer app when it is launching properly for the first time.

It was never able to launch when I choose
b. “I want to use this PC as a remote control” option Roon never could find the server. So flailing in the dark I copied the Roon folder from the z840 (appdata) to the RoonServer folder on the QNAP.That was done on the 19th So those extra folders were an attempt to migrate what was working on the PC. But they were empty and never populated with any folders.

Just to be clear when you say “These folders are created by the RoonServer app when it is launching properly for the first time.” is it the qpkg server app? or the Roon app on the PC that creates them?

It should be created by RoonServer on the QNAP. If these folders were copied there by you to migrate your working database, I’d suggest to delete them again, as it seems there is something else wrong.

When your RoonServer directory on the qnap is empty again, please download this empty dummy-file (ROON_DEBUG_EXTERNAL_LOG.txt) and place it in the RoonServer shared folder on the QNAP.
Then restart (= stop and start) RoonServer again in the QNAP AppCenter. Can you check if any text has been written to that file and if there is text in there can you copy the content and post it here?

Short explanation of this process: When RoonServer is starting on QNAP it will check, if this file is present in the RoonServer shared folder. If it is there, it will be used to write debugging information into it. If RoonServer is outputting an error message, it will also show up in this textfile.

EDIT: To be more precise and sum up the above:

  • Delete RoonServer and RAATServer folders in the RoonServer shared folder (You still have the database on your other machine, right?)
  • Download and move the linked empty file into the RoonServer shared folder.
  • Restart RoonServer in the App Center
  • Check the content of the file and post it.
20.07.17-10:45:31 --- Starting RoonServer ...
20.07.17-10:45:31 --- ROON_DATABASE_DIR: /share/CACHEDEV1_DATA/RoonServer
20.07.17-10:45:31 --- ROON_DIR: /share/CACHEDEV1_DATA/.qpkg/RoonServer
20.07.17-10:45:31 --- Model: TVS-1282T
20.07.17-10:45:31 --- QNAP Serial: Q167I07324
20.07.17-10:45:31 --- Architecture: x86_64
20.07.17-10:45:31 --- QTS Version: 4.3.3
20.07.17-10:45:31 --- PKG Version: 2017-02-02
20.07.17-10:45:31 --- Hostname: Jumbo
20.07.17-10:45:31 --- MTU: 1500 1500 9000 9000
20.07.17-10:45:31 --- Loading additional 64-bit libs: false
20.07.17-10:45:31 --- ROON_DEBUG_ARGS: 
/share/CACHEDEV1_DATA/.qpkg/RoonServer/RoonServer.sh: line 94: /share/CACHEDEV1_DATA/.qpkg/RoonServer/RoonServer/start.sh: No such file or directory
20.07.17-10:45:31 --- RoonServer PID: 19134

########## Installed RoonServer Version ##########


Ok. This textfile is quite helpful.
Has your QNAP normally access to the internet?
It seems that all files that the installation process should download from the roonlabs website are not available.

It updates all the apps and firmware all the time

Have you at any point uninstalled the qpkg and tried to reinstall it?

I have done it 3 times

Is there a manual way to install the files?