QNAP authorization issue

I had the same issue running Roon on QNAP. I have to login On my iPad what takes a Very long time. Then I was asked to deauthorize my QNAP Roon server. Very strange cause this is my only server for Roon. After I deauthorize my only roonserver everything was Back to normal again. Strange behaviour.

Hello @Summerbreeze,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Same issue here,
Clients can not access the core unless unauthorization of the core.
Qnap TVS-882 reboot - Roon Server running, does not solve the problem.

Roon Server

Status : Running
Version : 1.7 (build 571) stable
QPKG-Version : 2019-06-09
Process ID : 28810

Very annoying and blocking the system completely.
Reverting to my older system not to leave the entire system in silence.

Hello nuwriy, my issue is already solved by deauthorize the roonserver on my QNAP nas. However, this was the first time I have to login after a new update from Roon. I use a IPad Pro as control. The login process takes a long time and I wasn’t sure I typed the correct password. But after a long while the deautorize message appeared and after I clicked on that everything is back to normal. Roon is working fine now.

Hey @Summerbreeze, that’s great! Please let me know if you require further assistance in the future.

Hello @Johan_Saenen, are you still seeing issues after deauthorizing? It looks like most reports of this issue have been resolved, but let me know!

I have the same issue with my QNAP / Roon build 571. I use roon since about one year on my QNAP. It all worked without any issue. Since I have updated to build 571 I have exactly the same issue.
I power down my NAS over night. So in effect I restart the core every day.

Have you the latest firmware on your QNAP, and the latest version of Roon for QNAP?

I had/have the same issue.
i have to unauthorize in order to get my server back online.

1 Like

Hello @Mark_Minnoye, as Geoff said, are you on the latest update?

I have the same problem.
Every time I restart my qnap 251+, I have to re-authorize myself and wait a few minutes to play a song. latest software on all devices.

Hi @Max_Siefer, hi @Mark_Minnoye,
this should be fixed with an update to the Roon Server QNAP app. The app update is still in the approval process of the QNAP App Center. But it can already be installed manually by downloading it from roononnas.org website (as Goeff_Coupe pointed out in a post above).


The update, available on July 10th in QNAP App Center, had been installed successfully on my HS 435 DX, however the authorization problem as described above still occurs after each restart of the NAS

Hi @Michael_Nosbuesch,
please check your private messages inbox. :wink:

I have been having this problem (asked to sign in and then deauthorize NAS) ever since updating to the new Roon version. I have the new Roon Server (2020-06-22) from the App Center on my QNAP TS-253A, and I’ve restarted Roon and rebooted the QNAP a couple of times. Each time it initially seems to work but then the next day (NOT restarting the NAS) I again have to log in and deauthorize the QNAP. This happens whether I’m using my iMac, iPad, or iPhone to control Roon. What else should I be doing?


I do have the same issue with my Synology NAS which I recently did set up. The setup-up was done as recommended.

  1. I downloaded Roon for NAS from the Christopher Rieke Homepage.
  2. Used a Back-up from the old Roon core system (MacMini) and used this back-up during the installation the new Core on NAS.

DSM: 6.2.3 update 3
Core: Roon version 1.7 build 710


  1. After NAS restart I have to re-authorize Roon. To do so i have to choose the unauthorize option…

  2. Another problem: Core is not seeing my Libratone Zipp Mini on the Zones. This worked always fine when I had the Core running on my headless MacMini.

Any recommendations?


Hi Knud,

  1. Yes, just click the unauthorize option and a new authorisation will be saved on the Synology core. Don’t worry, authorisations can’t be lost and you can reauthorise any device as often as you want. But only one device can be authorized. As the authorisation is not stored in the database, it is normal you need to press the deauthorize button.

  2. I am guessing, you have openvswitch turned on. This is a known issue on Synology and fortunately it looks like this will be fixed with DSM7 (which will be available in summer according to my last google search). If you don’t need openvswitch and it is turned on, please try to disable it and restart Roon Server.

PS: Sorry for the late reply.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.