QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

hi again all

Does anyone knows how long does it to Roon to respons to the Beta request? its been a few days (and a week without a music player… :)), i just want to make sure i didn’t miss anything…

thx all

Z

1 Like

I did another test that sounds crazy to me. my TVS-H1688x is running QuTS Hero 5.0. As I already explained before, eveytime I reboot, the Roon music library is empty (except for the Tidal albums). But I noticed that when I change acessi privileges to another user (that is not the guest, that remains as it is - in my case access in currently denied), I created for my purposes (so it is not one of the standard ones, e.g. admin or guest), then when I apply for the change of the privileges, than Roon start immediately to scan the folders and magically all the albums come back into the library.
This si very strange, so the privileges related to the guest users have nothing to do with this issue!!!
I confirm the latest beta installed yesterday (build 864) does not change anything. Now all my albums are there until I will reboot th QNAP. At that point, I’ve to change again access privileges to one of the users to forse the Roon library rescan (that is crazy to get Roon working …).

It was immediate in my case - a few hours.
Anyway, none of the beta versions solved the problem…

sooo its been a week without being able to use roon, no response to both threads (this and another one) from the support team…really surprising TBH. is there a direct way to contact the support team?

Write to them directly. Use @support.

Hello Everyone,

We have just released a new build of Roon which contains some changes for QNAP:

In our Beta testing, we discovered that we have been able to resolve the issue with RoonServer on QNAP hanging at startup, but haven’t been able to quite nail the local folder issue yet, and are continuing the investigation.

If you are impacted by this issue, users have mentioned that they are able to temporarily resolve this behavior (until the next reboot) by changing the Guest Access Rights on their QNAP Shared Folder Permissions from Deny to Read or Read/Write.

Hopefully, this setting change helps anyone else still affected by this issue until a more permeant fix is found.

Thanks All!

Confirmed on no changes to the 880 build on this problem. Without Guest Access, Roon Core can’t see anything in my “Music” shared folder. Turn Guest Access on (I used R/O), now it’s importing the files again. Given the amount of files in front of it, I’ll check on it in the morning.

I’m running QuTS Hero 5.0.0.1856 on a TVS-h1688x.

I’ve the same configuration and I’m having the same issue. The problem is that this fix is only temporary, since when you reboot files are not read again and you have to force the library rescan by changing any of the existing users access rights (does not mind if it is the guest user or another one, in my case).

Not sure this has been said here before, but it’s well established that working around this bug involves changing the folder you store your music in to “Guess Access Read/Write” or “Read Only”. And if you reboot the machine, then Roon Core forgets the local files requiring you to rest the Guest Access privs. What I didn’t realize until now is that the privilege setting for Guest Access doesn’t really matter. Just changing it to something else is enough for Roon Core to rediscover the library.

For example, my QNAP TVS-h1688x (Quts Hero 5.0.0.1856) was originally set up as Guest Access Read Only on my music shared folder so Roon could see it. Then I had to reboot the machine and Roon Core forgot about the music share. But this time I changed the Guest Access privileges to “Deny” and lo and behold, Roon rediscovers the music shared folder. So it doesn’t matter what you change the Guest Access privs to, the point it that it has to be changed from something to something else…anything else. Weird.

I wonder if the problem persists on QuTS Hero users or also QTS users? I’m at QTS (TS-253D) and haven’t had problems since the last few beta versions. Even after reboot things have worked normally. I’ve left the guest access at Read only on Roon database folder and Media folder.

One thing I’ve learned is that the QuTS Hero release usually trails the latest QTS release by anywhere from 1-3 months. So it’s possible there are changes in the current QTS release that haven’t filtered down to QuTS Hero. But right now, I’m in the weird position where any change in the Guest Access privs restores the ability to see the music shared folder, (R/W, R/O and yes, even Deny).

I have to take my unit off line today for a memory upgrade and when I restore power to it, i’m sure I’ll have to change the Guest Access privs yet again.

No doubt you’ve all thought about this idea: if you need to reboot your QNAP, just stop Roon on the NAS first.

When you’ve rebooted, start Roon on the NAS,

This avoids having to reload your Local Folders.

Hadn’t thought of that. Thanks for the tip!

And it didn’t work after all. Still had to modify privs after a reboot, regardless of whether Roon was shutdown first.

What I did was

  1. stop Roon
  2. reboot QNAP
  3. change Guest privs
  4. restart Roon

all the Local Files were still there.

Perhaps I just got lucky.

Well there’s no difference if you switch steps 3 and 4 except that Roon never gets a chance of beginning to purge the library before local files begin the disappear.

All this reminds me of the old Unix/Linux “touch” command where years ago sometimes we would have to use the touch command on certain commands or files in order to update their modified dates so that software would run properly. Changing the privs is basically doing the same thing…updating the modified dates which somehow gets past the bug in Roon Core. Might be interesting to try seeing if the touch command via SSL makes any difference on a shared folder holding the music library vs doing a Guest privs change.

1 Like

@support. Yesterday i was on a tech support call with Plex about an issue with my QNAP NAS and since the engineer was responsible for putting together the Plex package for QNAP QTS and QuTS Hero, we both decided to look at how Roon was setup and see if there was anything obvious that might be accounting for the local folders not showing bug. Sadly, the idea that he had (activating the Multimedia console and importing the music folders) didn’t turn out to bear fruit, but we did find one minor bug that needs attention.

If you create a shared folder (I’m using QuTS Hero 5.0), Roon Core will see the shared folder in Settings->Storage. But if you delete a shared folder, Roon Core never updates itself for the deletion. it was suggested that the code is missing having inotify look for IN_DELETE and IN_DELETE_SELF for changes.

I’m including this bug here and not in a separate thread since it may lead to something interesting in the search for the bug regarding the folders disappearing problem.

3 Likes

Hi @noris,

Is there any news from Roon team about this issue? Roon running on QNAP server is still not working.
Thank you.

2 Likes

I went to a new NAS and now unfortunately suffering the same. Hopefully the team can finally find a permanent fix for this.

Has anyone ever played around with the access rights in the console of the QNAP? E.g. create a new share and login via ssh. Now change rights and ownership of this share with chown/chmod (guest.guest, 666/777 to give full access) and then test whether something has changed. But that’s more for someone who knows a bit about Linux.