QNAP - Not Showing Local Folders Anymore [See Staff Post - Fix is released]

:mega: See staff post


Original post

I’m sorry I can’t provide logs anymore since things work normally now after re-installing the core few times through QNAP appstore. The problem of local folders missing is still valid though. Meaning that only way to add music location to Roon now is network share. For some reason Roon can’t find my folders locally on NAS anymore. Before the update it could. Now it just says empty folder while trying to access locally.

Using network share is ok otherwise but it won’t automatically update changes in library. I need manual rescan every time when adding music. Local folders updated automatically.

Reinstalled Roon server manually to get it going.

Tried to restore from a DB backup, but shared folders have changed / not accessible so all my manual library changed are hosed.


I edited my music folders and pointed them to the new locations and it sorted the issues out.

Workaround is to add your music folders as network share.

Here’s some info:

Thanks - trying but not getting right network path to my music folder on QNap - I can browse to it in FileStation on QNap but not finding how to spell it out.

This worked for me:

Just replace TYKKI-SERVER with the name of your NAS server. Then just use the folder path to the folder which contains your music folder. Just don’t storage your music in the root of NAS, it causes problems. Have one folder inbetween like I have Media and under there Music.

Thanks for the help! Tried the below (and some other variations) but not working -

Add images

Try that path but without the \Music in the end.

Thank you Carl. My setup is as follows:
Roon database on solid state HD, as per requirements
Music files on other data disks
QNAP firmware version
Roon version 1.8 (build 846)

Please note I have experienced the same issue with QNAP firmware version 4.3.x as I upgraded hoping to solve the problem.

Roon doesn’t seem to be able to access the local folder where I have my music stored and hence all tracks stored there just vanished and I can see only some TIDAL tracks I have added in my library. There is no error reported, the behaviour is as if the folder is empty.
Force scan does not solve the issue without reporting any error

I have created a shared folder with this folder and room scans the files and imports them in the library. I do not want to use a share folder though because it doesn’t scan in real time when I upload some new tracks in the folder. Other than that NAS name and/or IP may change in the future, so shared folders is not really the optimum solution.

Music streaming and track import seems to work “normally” with the shared folder. Been using this NAS and the setup with Roon for almost two years now without any problems.

@support, @crieke, @noris ,
Same issue on my side (complete local library disappeared)

My setup is as follows:
Roon core on QNAP NAS TS-473A
Roon database and core on SSD, as per requirements
Music files on other data disks (HDD) within the NAS
QNAP firmware version
Roon version 1.8 (build 846)
QPKG-Version 2021-10-03
Library with about 22k titles

As far as I can remember this happened with build 846.
No network changes, no rights change, no addition titles,…

No issues with access from other Music Apps (Bluesound, Windows…)
No changes with delete and reactivation of folders, rebooting, new version installation.
Tidal connection okay (if Tidal server doesn’t fail)

Please help!

Same issue on my side:

  • Environment
    • NAS
      • QNAP TS-453B
      • QTS
    • Roon Server
      • 1.8 (build 846)
      • QPKG: V2021-10-03,
    • OpenSSL 1.0.2za 24 Aug 2021

Using network share is ok, but this makes my previous ratings, lists, tags useless…

The same problem for me. Qnap TS-453 BE. After the last update to version 846 and the Qnap system software update, I do not have the option to add local folders, from the three connected USB drives I can only see the content on one. On the other two, it’s empty even though the files are. Attempted to plug in a flash drive for a test without success. He cannot see it and has no option to add anything. Tidal and Qobuz are working. There is a problem and help is needed to solve it.

Hi @noris ,
I submitted my info as well.
I have no crashes, can put in my local path in Roon, but Roon doesn’t see my library (looks like empty folders),
Everything is on latest software level.
Thanks and good luck.
PS: Tidal via Roon is still sometimes a pain in the ass (server outages from Tidal).

1 Like

Same issue here. Local library vanished.
Filled out report but could not upload my roon logs. Website only allowed for up to 100MB but my log was larger than that.

I think the root of this is that cifs-mount commandline is failing but not logging this fact in Roon logs. -13 error code.

Thank you @Burkhardt_Petermann. I had the problem of lost connection to the Roon core on QNAP after updating the client and no update was available via Qnap App Centre for the core. I manually downloaded and installed the .qpkg for 1.8(build 846) and it’s working again.

[Edit] spoke to soon. Connected but local libraries have disappeared.

Hello @support,
hello @noris,
Thanks, but is there something special to do to have access to the local library again (I haven’t made changes)?
I installed the new version (B850), rebooted, deleted and reinstalled the music folders, switched to “force to read again” but nothing helped - still no local library.
Now I’m running to reinstall a backup from the time before B846.

Update - reinstalling the backup also doesn’t work out.
At the end of the backup process I got my tracks back (22k) and then started a countdown back to all numbers (artists, tracks, albums,…) without my local library (just Tidal favorites are shown).
At least Roon is running without any errors so far.

Update II - the access to the local library via Roon file browser was possible but no scan happened. When I pushed “add network share” and put in smb://IP/Musicfolders AND put in the Access rights again it worked. Of course everything is mixed up now - not nice.


Hello everyone,
As i’m experiencing same issues here are my stats

no way to connect to roon until I upgraded to B850. I can access to roon control homepage, but can’t log in to my tidal account and have no access to ibrary (rescanning doesn’t work, neither unistalling, reinstalling, rebooting).

Thanks in advance

1 Like

Hey @patouskii, I wonder, did the reinstall help?

If you still experience the same issue, could you please share the QTS version too? Also, where is your library stored, and how is it connected to the Core?


Thanks for the info, @Peter_Kuehnel. When you say “everything is mixed up now”, could you please expand on what that means?

Also, how did you access your library via “file browser”? Could you please explain the steps you took? What scan didn’t happen?

Finally, what is your storage location and how is it connected to the Core?

1 Like