Qobuz Streaming Not Working

Same problem here: No Qobuz streaming via Roonserver possible - whether it is CD or HiRes. In Qobuz own App everything works fine. Very annoying!

1 Like

Hi @Martin_Simon,

Can you please provide some more information regarding your setup here by using this thread as a guide?

Have you tried logging out and back into Qobuz? You can do this in Roon Settings -> Services Tab.
Are you able to play tracks all the way until the end when using the Qobuz web player (play.qobuz.com)? Please try playing a track until the very end and not just the first few seconds.


last night, I found the cause of the problem: As you asked I tried logging in and out Qobuz (in Roon) several times. Somehow that caused Qobuz to think, that I want to use my account on more than 3 devices/clients. I found this in my account under www.qobuz.com. After clearing all these active logins Qobuz worked as designed in Roon. Maybe lots of other Qobuz customers (with a real and active account) run into the same problem: Frequent logout/login in Roon causes Qobuz to stop streaming because of to many active logins…
Happy Easter


Hi @Martin_Simon,

Thanks for letting me know the root cause of the issue. I have brought this up with the team to see if this is expected behavior here, I would assume not. Either way, glad to hear that you have managed to resolve this issue by logging out of Qobuz on the other accounts.

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.