Qobuz tracks skipping sometimes [resolved: dns issues]

I have a similar problem with Qobuz tracks skipping that began the day that Build 790 was released and continues even today. Nothing else has changed in the listening chain.
I have Verizon gigabit internet connected via ethernet. Like Francois rebooting the core will allow skipped songs to play at least for a few minutes before the skipping begins again. Are you saying that adding a VPN is a cure? Thanks.

I am saying nothing of the sort. That advice couldn’t be further from what I’m saying.

@support, can you please pull @Ben_Bennett’s logs and see what the issue is? I’m positive it has nothing to do with build 790, but we should be able to find out what the problem is.

1 Like

Qobuz has been unreliable for me as well recently. Lots of dropouts and skipping.

I switched over to Tidal - problem solved.

Might be a Qobuz issue.

That issue applies using Roon and Aurender Conductor (not using Roon).

A post was split to a new topic: Qobuz starts to play then skips to next track

Hello Dylan,
2 - Seagate 8 tb hard drives
Steiger Dynamics Computer Windows 10 64 bit; Verizon gigabit internet via ethernet
IFI Pro idsd dac
Luxman cl 38uc pre amp
2 Rogue Audio Dragon power amps
2 Von Schweikert VR 5 Anniversary II

This configuration is the same as before the Qobuz skipping. Roon 1.8 worked perfectly until Build 790 was released. The skipping issue started the day that build was installed. On Sunday Qobuz would not play at all until Roon was restarted. Music still skipped after about 30 minutes.

Do not have the problem with local hard drive tracks.

Thanks for your help with this,


Where are you? I ask because Escondido - Bennie Maupin Quartet / Bennie Maupin failed due to the SSL network stream to Qobuz failed 35s into the track, and then later in the track, it tried to recover the stream and couldn’t actually establish a connection with Qobuz’s CDN.

Also, try to keep your information in this thread, so we can keep the different situations organized. Different setups have different reasons for failure, even if the symptoms are the same.

I am in Richmond Virginia.

Whenever the skipping gets serious, I try connecting to Qobuz directly and that always works perfectly, but obviously I lose all the benefits of sound quality and ease of use that Roon provides.

What does this mean?

When it skips, when does it skip? Like in the start or in the middle? You can see in the history of your plays.

Also, if you play the skipped track in Roon again, does it skip again?

I turn Roon off and listen from the qobuz website. No skips but sound quality is not up to Roon level and obviously notable to design Playlists that also include music from your hard drives.

The skips usually happen between 20 and 70 percent of into the track. The only way to get the track to play is close and then restart Roon. There is no pattern discernible whether it skips on the second play.

I have been using and loving Roon for over 2 years without a single issue of any kind. Version 1.8 for me was great advance in ease of use and playability. While build 790 may not be the culprit and I suppose the problem may not originate with Roon, it seems to me coincidental that the issue started on the day build 790 was installed.

Thanks for your help and patience.

FYI. I played an album this morning of George Anthiel’s music. 5 tracks that played for this amount of time before skipping - 100%, 95%, 100%, 75%, 25%. Hope that helps.

Tried listening to the new 50th Anniversaey Deja Vu, These are the tracks that skipped:

Almost Cut My Hair played 15%
Helpless 55%
4+20 95%
Country Girl 10%
Everybody I Love You - skipped completely

Hi @Ben_Bennett — Thanks for letting us know. We enabled diagnostics so we can look at those instances you mentioned above. The technical team isn’t around on the weekend, but I’ll follow up with them early next week and we’ll get back to you once we’ve been able to review.

It is Saturday afternoon and I decided to listen to a playlist that contained a majority of music from my local hard drive. All of the local music played with no problem. For the first hour and a half most of the Qobuz music played all the way through but there was some skipping and some songs would not play at all. I just shut down and restarted Roon and 2 tracks that would not play now played all the way through.

I hope these observations help. I will post some more that I feel might be relevant to the skipping problems with Qobuz.

It is Monday morning and I have been listening to a playlist that contains a majority of Qobuz tracks. The first 8 songs played 100% with the 9th playing 95% before skipping to the next track. When the Blues Leaves and the next track did not play at all until I shut down and restarted Roon. They both and every cut after that played all the way through.
Again, hopefully that helps in figuring out the cause of these issues.

@Ben_Bennett – your logs all point to you having connectivity issues with Qobuz, but that doesn’t align with your statement about your location and bandwidth and isp.

I’m concerned about the fact that rebooting/restarting Roon fixes things temporarily. Also, your messages about what happened and when and how are confusing and inconsistent in the information they provide. For example, “Blues Leaves” is something you never played according to the logs.

Can you please conduct this test and give the following information to us:

  1. play qobuz tracks until something wont play at all.
  2. make note of the time and date and what the track title / artist was. we want this info.
  3. play something else on qobuz. If it plays, great. we want to know what it was. If doesn’t, we want to know that too.
  4. try playing the same thing on qobuz that failed previously in step 2. Does it work?
    4a) if it doesnt work, play a local track, and then try again to play the step 2 track. Does it work?
  5. restart Roon and immediately play track from step 2. Does it work?

It is Saturday May 22 2021 4:15 am Eastern Daylight Time
I have started playing “A Little Driving Music” an album by Brian Bromberg - a new Qobuz release. Let’s see how it goes.

I restarted my computer before beginning.

Track 1 “Froggy’s” played 100% 4:21 am edt
Track 2 “Quarantine” plated 30% 4:23 am edt skipping to
Track 3 “That Cool Groovy Beatnik Jazz” played 25% 4:25 am edt skipping to
Track 4 “Bado Boy!” played 100%
Track 5 “Walking on Sunshine” played 20% 4:31 am edt Roon stopped playing
Track 6 "Sag 5 " will not play
Track 7 “A Rainy Day in Paris” will not play
Track 8 "A Little Driving Music will not play 4:36 am

Shut down Roon 4:38 am

Started playing the same album on Qobuz with Roon turned off 4:40 am

I will come back when the album is finished or something eventful happens.


5:54 am Qobuz played the entire album with no problems

Opened Roon and inserted the tracks that failed to play using add next

Track 5 “Walking on Sunshine” played 100% 5:59 am
Track 6 “Sag 5” played 100% 6:04 am
Track 7 “A Rainy Day in Paris” played 100% 6:10 am
Track 8 “A Little Driving Music” played 100% 6:16 am
Track 9 “Peace” played 60% 6:20 am and skipped to
Track 10 “Jedidiah’s Gold!” played 95% 6:26 am and skipped to
Track 11 “The Sitting Room” played 100%
Track 12 “Baton Rouge” played 100%
Track 13 “Lullaby for Bado” played 100%
Album ended 6:40 am

This exercise is a perfect example of the issues experienced. I hope there is enough detail and accuracy to figure out the problem.

Just a reminder that Roon worked perfectly for me for over 2 years including the update to Roon 1.8. The problems began the day that Build 790 was installed. Build 795 was installed the day it was available but with no positive effects.

If you need any other information just ask and I will do my best to provide it.


I have the same problem here with Qobuz skipping tracks.

Today I have installed the Linux 64 bit Roon Core on an Intel NUC7i3BNH of the following spec.
Operating system: Linux Mint 20.1 Cinnamon Desktop.
RAM: 8Gb
Boot & system disc Kingston 120GB SSD.
Data storage disc: Western Digital Blue SN550 1TB M.2 NVMe SSD.

The Core server is connected via hard wired Ethernet network via a TPLINK Gigabit switch, a TALK TALK ADSL broadband router and a Cisco 2940 unmanaged switch to both my Devialet 440 Pro Ci and to a Roon bridge running RoPieee on a Rasberry Pi4 serving a Soncoz SGD1 ALSA DAC via USB.

The DNS server in the TALK TALK router is set to Primary DNS and Secondary DNS

After I connected to the new core Roon started the background audio analysis scanning my library of 935 albums, 10,124 tracks. I set the scanner to ‘Fast 1 core’ scanning.

I started a Qobuz album to play on the Devialet 440 Pro. After less than two minutes Roon skipped to the second track.

I tried another album via the second endpoint on the Rasberry Pi and Soncoz DAC and the same skipping problem occurs.

I then disabled the library scan and started to play a Qobuz album and the skipping stopped. I played 13 tracks through the album and no skipping occurred.

I then started the Library scan to fast 1 core and almost immediately the current tracked skipped to the next.

This leads me to assume that the background analysis scanning of the local album library is causing the track skipping to occur. Is there any basis to this theory?

It has been a full week since my last posting but the problems with Qobuz only persist.

This morning, May 30 at 4:00 am edt, I started Roon and nothing from Qobuz would play at all. The 3 albums were:

John Barbirolli “The Complete RCA and Columbia Album Collection”
Jean Bavouzet “Bartok the Piano Concertos”
Andre Previn “Andre Previn Conducts Vaughan Williams”

At 4;15 I restarted Roon and the Andre Previn did start playing.
The first track “Symphony 1” played 90% before skipping to the next track.
The second track “Portraits” played 100%.
The third track Symphony 7 the “Prelude” skipped to the next part at 5:38 am edt.

I hope the support department at Roon is making some progress on this issue.

Hi @Ben_Bennett,
Hi @Disarmamant
I guess they also need your related log-files.
And it’s better to address that to someone with @“name” (i.e. Danny was your last buddy (Ben)).
Do you have Webpage for Qobuz server outages at your location?