QoS DSCP Tagging/Marking?

I am very occasionally experiencing dropouts, particularly with 24/192 tracks, and since I am using a managed switch I was wondering if Roon uses QoS DSCP tags so that I can prioritize those on my network. If so, can someone share the relevant values for the tags?

In the meantime, I will continue to troubleshoot my devices.

Many thanks.

They do not apply any DSCP tags today. So you’d need to use some other tool to mark them yourself.

But don’t bother. It’s extremely unlikely this is your problem. 192k audio is only ~12.5Mbit/s, which is basically nothing (unless you have a craptacular Wi-Fi link somewhere in the path).

Thanks for the quick and helpful reply!

Roon quite often has problems with managed switches, though most often in remote to core discovery.

I do sometimes have issues with remote to core discovery. Any settings I can change to avoid this happening?


Toggle igmp snooping is the recommendation. So on if it is currently off and vice versa.
More on general networks here

Thanks. I had seen the networking best practices, but had not focused on the igmp snooping setting since that was in the router specific section.

Here is a link to the Multicast support for my gear: https://documentation.meraki.com/zGeneral_Administration/Other_Topics/Multicast_support.

And here is a screenshot of my current settings in case you can make some specific suggestions for me to discuss with my network guru:


Set IGMP snooping to disabled unless you have a Layer 3 IGMP querier.

Hello @Kurvenal, and thanks for your report! Looks like you’ve got some help here already. If you have any specific questions, please let me know!


I am still experiencing problems with iOS remotes discovering my Nucleus core even though I have disabled IGMP snooping on my switch. Any other suggestions?

Many thanks.

Thanks for giving that a try, @Kurvenal!

Just to confirm, do you have connection problems from any other remote devices, or just iOS?

During this time are you able to reach the Nucleus Web Administration Interface?

Hi Dylan,

Thanks for your reply.

Mac OS X devices seem to connect very reliably, via both wired and wireless connections.

No problems connecting to the Nucleus browser interface via an iOS device.

Remote connection to the Core is still a real problem.

Many thanks.

One more observation: When an iOS remote device is struggling to connect to the Nucleus, if I reboot the Nucleus then once it comes back up I am able to connect within seconds. This is obviously not a practical solution, but I am hopeful that it will provide you with information that might help with troubleshooting.

Many thanks.

Hello @Kurvenal, could you reinstall the Roon remote app for your iPhone and let me know if you notice a difference? Afterwards, I’d like to enable diagnostics for your account so we can take a look. Could you also please provide the following details? Thanks!

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.


I just reinstalled the remote app on my iPad and my iPhone, and in both cases the initial setup did not work because my Nucleus was not discoverable. I also tried configuring my Core through the Remote app, but could not access the Nucleus although I used to be able to do that before I reinstalled. I rebooted through the remote on my MacBook Pro, and the Nucleus was still not discoverable from either iOS device.

See below for details on my setup that I provided in a different support thread.

Let me know what is required to enable diagnostics. I am hopeful that this will help to resolve these problems that I am having.

Many thanks!

Core: Nucleus Plus, latest Roon build
Remotes: iOS and Mac OS X devices, all with latest Roon build

  • 1Gbps up/down internet service, minimal latency (~1ms)
  • Cisco Meraki MX100 firewall, Cisco Meraki MS250-48LP and MS125-24P switches
  • Cisco Meraki MR45 WiFi 6 access points
    Note: Nucleus Plus and all Roon endpoints are connected via wired ethernet connections on separate AV vlan
  • Layer 3 firewall rules - Policy set to Allow on both switch and WAPs
  • Bonjour Gateway enabled on wifi network to the AV vlan

Audio Devices/Roon endpoints:

  • Trinnov Altitude 32 (24) x 1 (working well)
  • Trinnov Amethyst x 1 (working well)
  • NAD CI-580 x 3 (total 12 zones) – (Having problems - known issue)


  • Primarily streaming through Qobuz and Tidal, not an extensive library yet since I am still fairly new to Roon
  • Some downloaded media files, primarily FLAC files purchased through Qobuz, are stored on a NAS

Quick update:

Was finally able to discover Nucleus from both iOS devices onto which I had reinstalled the Roon remote app, but only after manually entering the IP address. Even then it took a long time for the remote to scan and find the Nucleus (I actually gave up and left the device and it was only when I came back that I noticed it had finally discovered the Nucleus). I was not able to access the Nucleus using the Configure Roon OS devices option. Even when the Nucleus was not discoverable through the Roon Remote app I could, however, access the Nucleus configuration menu on the same device by typing the IP address directly into the browser.

Once I close the Roon Remote app and try to reconnect, then am still getting the “Waiting for Remote Core…” error and I am only able to connect intermittently.

One thing that is interesting is that on another iOS device that I keep in one location (so always on the same WAP) as a room controller, I have fewer difficulties connecting the Roon Remote app to the Core. I have not reinstalled the Roon Remote app on this device, so I do not know what the effect would be of doing that.

Please let me know how to start the diagnostics process.

Many thanks.

Hello @Kurvenal, and thanks for the detailed description of your setup, I’ll enable diagnostics for your account from my side. While I’m working on that, I’d like to ask you to perform a test for me since your network setup is pretty complex. I also wanted to mention that we recommend against managed switches in our networking guide, which you can view here.

I’d like to test the issue by temporarily bypassing your managed switches and wireless access points if possible. We could do this by Connecting the Nucleus directly to the main router, and doing the same with one of your remotes. Please give this is a try and let me know if the issue is reproducible!

Hi Nuwriy,

I have reviewed your networking guide. It is actually not very helpful in my situation.

As more and more people work from home, I have no doubt that you are going to see more managed switches in your customer base. One big advantage of managed switches is that it is possible to configure the network to match very customized requirements.

I do not think that we will learn anything of value by bypassing the managed switch, particularly since even if I connect the Nucleus directly to the main router I will not be able to connect a mobile device easily to the router to try to use it as a remote.

I would be more interested in understanding what changes I can make to my network configuration to make it easier to use Roon. Hopefully your diagnostics process will be able to shed some light on this?


Hello @Kurvenal, next time you have a dropout, could you please reply here with a timestamp, the device you were playing to, and the name of the track that was playing at the time? I have enabled diagnostics for your account but want to make sure we can capture a good example of the issue for the team.

Hi Nuwriy,

Thanks for confirming that you have enabled diagnostics on my account.

Actually dropouts are not such a frequent issue for me, at least with the Trinnov devices.

You may recall that we were focusing on is iOS Remote Connection to the Nucleus Core.

When I reinstalled the iOS App on my remote devices as you suggested it actually made the issue worse until I scanned for the Nucleus IP Address. I frequently see the “Waiting for Remote Core…” error, and it often takes a lot of closing and reopening the iOS remote app or else rebooting the Nucleus before I can successfully connect.

I am hopeful that from your diagnostics you might be able to tell what the bottleneck is and maybe recommend some network settings that I can implement so that I no longer have this issue.

Many thanks.