Remote won't connect to QNAP after update to Roon 1.7 (Build 511)

Everything was working fine with Roon 1.7 before the upgrade to Build 511. After update the remote couldn’t connect to the Roon Server on QNAP. After searching around I deleted under /share/CACHE…/RoonDB/RAATServer, RoonGoer and RoonServer. And after restart I get this in the ROONSERVER_QNAP_LOG.txt:

05.01.20-13:27:34 --- Starting RoonServer ...
05.01.20-13:27:34 --- ROON_DATABASE_DIR: /share/RoonDB
05.01.20-13:27:34 --- ROON_DATABASE_DIR_FS: 
05.01.20-13:27:34 --- ROON_DIR: /share/CACHEDEV2_DATA/.qpkg/RoonServer
05.01.20-13:27:34 --- Model: TVS-871
05.01.20-13:27:34 --- QNAP Serial: Q176I02108
05.01.20-13:27:34 --- Architecture: x86_64
05.01.20-13:27:34 --- Total Memory: 16353184
05.01.20-13:27:34 --- Available Memory: 363152
05.01.20-13:27:34 --- QTS Version: 4.4.1 - Build: 20191206
05.01.20-13:27:34 --- PKG Version: 2019-06-09
05.01.20-13:27:34 --- Installed QTS Apps: netmgr,helpdesk,ResourceMonitor,Entware-ng,CloudDriveSync,
05.01.20-13:27:34 --- Hostname: DasMeer
05.01.20-13:27:34 --- MTU: 1500 1500
05.01.20-13:27:34 --- Loading additional 64-bit libs: false
05.01.20-13:27:34 --- ROON_DEBUG_ARGS: 
05.01.20-13:27:34 --- RoonServer PID: 10000

########## Installed RoonServer Version ##########
1.7 (build 511) stable

05.01.20-13:27:34  --- [[0;37;1m[[0;0m00:00:00.001 [[0;31mWarn:  get lock file path: /tmp/.rnsgem0-[
05.01.20-13:27:34  --- [[0;37;1m[[0;0m00:00:00.034 [[0;36mTrace: [childprocess] using unix child pro
05.01.20-13:27:34  --- Initializing
05.01.20-13:27:34  --- Started
05.01.20-13:27:39  --- Running

Then I try to connect with my IPAD and after login I get  "Network error: Please check your internet connection" and the log file looks like this:

05.01.20-13:40:52  --- Error
05.01.20-13:40:54  --- Initializing
05.01.20-13:40:54  --- Started
05.01.20-13:40:55  --- Error
05.01.20-13:40:57  --- Initializing
05.01.20-13:40:57  --- Started
05.01.20-13:40:59  --- Error
05.01.20-13:41:01  --- Initializing
05.01.20-13:41:01  --- Started
05.01.20-13:41:02  --- Error
05.01.20-13:41:04  --- Initializing
05.01.20-13:41:04  --- Started
05.01.20-13:41:06  --- Running
05.01.20-13:41:06  --- Cannot transition thread 0x7fc4e6bcc700 from STATE_BLOCKING with DO_BLOCKING
05.01.20-13:41:06  --- Error
05.01.20-13:41:08  --- Initializing
05.01.20-13:41:08  --- Started
05.01.20-13:41:09  --- Error
05.01.20-13:41:11  --- Initializing
05.01.20-13:41:11  --- Started
05.01.20-13:41:13  --- Error

It looks like that the RoonServer ends up in an endless loop, although the message on the QNAP App Center looks normal (Roon Server Status: Running). I had the same issue a few weeks ago but managed to get back to the previous build and everything worked fine. Any idea?

I had the same problem for 2 days and then it suddenly worked again.
Now it’s been working for a couple of days.

I do not know what happened.

Hi @Marco_Cuomo,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Would you also please use the directions found here and send us over a set of logs using a shared Dropbox link?


Here are more details to my setup:
QNAP TVS-871 with QTS 4.4.1

  • Roonserver 1.7 Build 511
  • Music Lib on QNAP: /share/Music…
  • UniFi Switch 48: QNAP directly connect to it
  • UniFi AP-HD: directly connected to the switch
  • IPad / Pixel 2 as remote connect via AP-HD
  • OPPO BDP-103
  • Bluesound Pulse Flex 2i

As I don’t have a DropBox account, can I send you the log files (only 330KB).

Thanks for the support.

Hi @Marco_Cuomo,

I just sent you a private message with alternate upload instructions, thanks!

I uploaded the logs: Filename is “Marco Cuomo”

Hi @Marco_Cuomo,

Thank you for sending those logs over, I can confirm our servers received them properly. I have created an internal ticket regarding your report and I have requested feedback from QA.

In the meantime, can you please confirm if you have any backups of your exiting database? Have you tried setting Roon to run as a new database (by changing the database folder location via the QNAP WebUI) and then re-importing your backup? It might be worth a try until I have feedback from QA.

I changed the database location and after picking the new RoonServer and entering the user/password on the remote (iPad) I got the network error. Same as before. Is there a problem with my user account?

Before I login, I can pick my RoonServer, so it looks like that the remote can find the RoonServer and open the login screen. But after login, I get the network error, and then I see in the RoonServer log file that the RoonServer starts a loop of Error, Initializing, Started, Error and so on.

Hi @Marco_Cuomo,

Can you confirm you changed the database location properly and rebooted the QNAP after changing the location? It sounds like you could still be referencing the old database if the symptoms are still the same. Can you share a new set of logs for this issue?

Yes, I can confirm that I changed the location of the database, but same effect as before. I also removed the RoonSever package and made a fresh installation, but always same result. Therefore I thought, maybe something is wrong with my Roon account. Do you have a test-account?

Separate question: do you have instruction how to remove completely everything from RoonServer installation on a QNAP. Especially which directory and files (config files) to delete manually.

Hi @Marco_Cuomo,

No, we don’t have any test accounts we can provide to users but I don’t believe your issue is account-related.

Everything Roon-related should be in the RoonServer folder you specified for the database location. Setting a new database location and uninstalling the Roon app via the QNAP interface should remove the Roon install from your QNAP. @crieke might be able to provide some more info as to if there are any additional config files, but as far as I’m aware there are not.

Have you tried to connect via another Roon Remote/Client yet? This might be worth a try. You can install Roon on a PC and when asked on the “Choose your Core” screen, you can select the QNAP.

I tried to connect via PC/Windows 10, IPad Pro and Android 10 Roon Remotes and on all the same effect. That means I have first to create/connect to a new database, then login (doesn’t matter which device) which gives me a network error message and after that the Roon Sever on QNAP ques in the Initialization, Starting, Error loop (which is also visible on the Choose your Roon Core screen).

Hi @Marco_Cuomo,

Thanks for clarifying that error state. In the previous logs you sent over, I am just noticing the crash loop and there doesn’t appear to be any login errors.

Can I please ask that you reproduce this login issue, note the exact timestamp it occurs at and then immediately following the error send me a copy of your QNAP logs?

The window to grab these logs is a bit tight since I see that all 20 logs are automatically overwritten in the course of 2 minutes, if we can capture the start of the behavior that would provide the most useful context.

Will reproduce it tomorrow… I assume you mean with the QNAP Logs the RoonServer Logs on the QNAP, right?

Hi @Marco_Cuomo,

That is correct, please use the same procedure to send the log files as you did before, but the only difference now would be that they will be right after the issue starts occurring and will hopefully provide some more information.

Log-File is uploaded

Forgot to mention: the Login was done at: Sun Jan 12 19:41:37 CET 2020

Hi @Marco_Cuomo,

Thanks for sending those logs over. I have spoke to QA further regarding this behavior and since this issue appears with a fresh database, we would like to determine if the network is playing a part in tthis behavior. Can you please use the instructions below so that we can determine this?

  1. Stop RoonServer from running on the QNAP
  2. Configure a new database location to start fresh
  3. Reboot the QNAP
  4. Launch RoonServer
  5. Verify if the crash loops have started (without being logged in)
  6. Login to the QNAP
  7. Only navigate to the Overview screen, without opening any other album details
  8. Verify if it is still in a crash loop
  9. Reboot your networking gear and verify if the behavior continues

Step 1 and 2: To my knowledge, I can only change the the database while RoonServer is running. After changing the database, RoonServer restarts. So did that.
Executed Step 3 and 4.
Step 5: To see the log files I needed to open a SSH session on QNAP. In the logs no crash loops.
Step 6: logged in
Step 7: I have only installed the RoonServer on QNAP. There is no way to open an album or so.
Step 8: No crash loop. --> as long as I am not trying to connect a remote, all is fine…
Step 9: restarted my networking gear

I don’t think that the network is a problem. I installed a RoonServer (Core) on a Windows PC. I connected the my music directory from the QNAP with the Roon Core on the Windows PC. To do that I needed to disable the Roon Core on QNAP. I could connect to the Windows Roon Core via IPad and Android and everything worked fine.

After that I re-started the RoonServer on QNAP. I got no question whether I wanted to change my account to Roon Core on the QNAP. The RoonServer went directly into the crash loop.

How can I activate resp. change my account from the Windows PC Roon Core to the QNAP Roon Core?