ROCK - Database Issue

@support My database will not load and no audio device is found. I’ve tried closing the program, restarting my NUC/ROCK and nothing is working. I saw an error page (for the first time ever) “There was an issue loading your database”. Halp!

I feel like this should be an unrelated issue, but I bought a new Macbook and dowloaded Roon on it. This problem started when I tried to open Roon on that new device. Now none of my devices are working.

Hi @Brice_Lang ----- Thank you for the report and sorry to hear of the troubles.

I have went ahead and moved your posts to their own unlisted thread so we can address this issue with you directly. Moving forward, would you kindly please send us over a set of your logs from the NUC hosting ROCK, using the instructions found here and our techs will have a closer look into what is going on with your setup.

Looking forward to your feedback!

Here is a link to my logs on DropBox. I feel accomplished just from having figured out how to do that without causing a disaster. :slight_smile:

Thanks Brice – we’ve got the logs :slight_smile:

We’re going to take a look at them and we’ll be in touch soon with feedback and next steps. Sorry for the trouble here!

I feel like I’m waiting for a loved one in the lobby outside the operating room. What’s the good word, doc? I hope this is a simple issue and not, “Sorry your 2 month old music server is dead and so is your music collection”.

Hey @Brice_Lang – we took a look at the logs, and there does appear to be an issue. We are analyzing the logs to see if there’s anything further that can be done here, but in the mean time I wanted to gather a bit more information.

First, I want to note that database corruption is extremely rare, and basically means that when Roon is reading the database we’re reading something different from what was originally written to the hard drive. Generally speaking, that only be caused by a few factors:

  • The system is unable to consistently store data, meaning that the SSD, RAM, or CPU has failed or is in the process is failing
  • Something interrupted Roon as data was being written to the SSD – the Linux filesystem is specifically built to protect against this but a power cut or crash at the exact wrong moment could theoretically cause database corruption if there is a bug, of if your SSD firmware is not perfectly implementing all of the required guarantees.
  • There’s a bug in our software, or in leveldb (the 3rd party database component that use) that can trigger database corruption, but for some reason it’s not affecting many people

To be clear, the 2nd and 3nd case are more theoretical, and not something we really ever see. In most cases, corruption is related to hardware or system that Roon is running on.

So Brice, I know you had a few issues getting started with ROCK and getting your database restored, and I’m wondering if you can take us through the hardware and the database you’re experiencing this issue with. Are you running this on an SSD? Is all the hardware new? Any power cuts? Was the database ultimately restored? Do you have other backups? What do you have in this database that you’re hoping to preserve (meaning playlists created in Roon, play history, edits, etc). Has everything been working until this issue?

I know that’s a lot of questions :slight_smile: but I do want to just reiterate that we’re going to work with you on this until everything is working 100%. There are no bad questions, so let me know if you’re unsure about any of the above and we’ll make sure we get this resolved for you.

I’m biking home from work now and will try to provide a full response early this evening. Long story short is that all my equipment is pretty new and has been working well. I have not experienced any power instability or outages that would raise my suspicion. I’ll try to dig deeper in a bit.

Oh, my number one question for right now is whether I can detach my USB harddrive from the NUC, plug into my MacBook Pro to check and see if the music stored there is still good. Obviously, my main concern is that my hard rive has failed and my music is gone. I have all my MP3s saved on my laptop as well, but there are around 20 lossless and high res albums that were only on that USB drive. Okay for me to check that?

Go ahead and turn off the NUC and do that, but let me reassure you – this is about the hard drive and database stored in the NUC, and this error doesn’t have anything to do with the media or content in your library.

I wouldn’t worry too much, but go ahead and check, and let us know how this is all going.

Looking forward to getting this working for you Brice!

I really appreciate your support. It’s a big reason why I pay for Roon and why I chose ROCK as my music server.

Okay I turned off my NUC and detached my USB hard drive. The good news is that the hard drive appears to be working just fine. Also, I was smarted than I thought I was by not keeping my lossless albums ONLY on that USB drive. I had them on my laptop too just in case. Okay so I haven’t lost any of my music, that’s a good start.

take us through the hardware and the database you’re experiencing this issue with. Are you running this on an SSD? Is all the hardware new? Any power cuts?
Here’s some info about my equipment. Really everything is new, especially the NUC, it’s SSD, and RAM. I got them all 3 months ago, brand new from Amazon. I have never noticed a power “cut” as you called it. What are the symptoms of a power cut? Does it happen super fast and might not be notable? As far as I know, nothing in my house has ever shut off all of a sudden…not within the last three months when I’ve had all this hardware running Roon. I keep all my electronics plugged into a Furhman power strip that has surge protection.

• Info on my NUC
o Running ROCK on internal SSD: ZTC 128GB Armor 42mm M.2 NGFF 6G SSD Solid State Drive. Model ZTC-SM201-128G
o RAM: Crucial 8GB Single DDR4 2133 MT/s (PC4-17000) DR x8 SODIMM 260-Pin - CT8G4SFD8213
• Router is Netgear nighthawk r7000
o Interestingly, I just got an email today from Netgear saying “NETGEAR values the security of your network and data, so we released new firmware for your WiFi router to address security issues.” I don’t know if there was some relevant problem, but I’ve never received an email like that before.

Was the database ultimately restored?
As for my database, my experiencing of transferring my database from my MacBook pro to the NUC didn’t keep my Tidal and stored files arranged exactly the way I wanted, but I wouldn’t say the database failed or anything like that. It was most likely user error in that I created a new watched folder instead of editing the existing one. Something like that. I’m not too worried about it.

Now, I did make some changed on Saturday September 30. I wanted to go back and fix the aforementioned library kerfuffle by reverting back to my June 10 database (last backup before I transitioned to ROCK). I had that backup on my USB drive and but I thought I needed to find it on Dropbox to implement it in Roon to I tried copying the backup to DropBox. On my mid-2010 MacBook Pro which is not the greatest performer, copying that backup took nearly two hours. Near the end of the transfer, I was browsing the internet and I feel like my laptop couldn’t keep up with the processing demands. Some of the files were corrupted in the transfer so I was unable to use that backup in Dropbox. Roon told me it wouldn’t work. So I gave up and simply worked from my current Roon database and simply did some file cleanup where I edited my watched folder to no longer point to all my old MP3s but instead to a new folder just containing lossless files. So…ultimately I don’t think there’s much reason for the database to be corrupted because I’m still working off the same database I’ve been using since June 10. I haven’t reverted to anything else.

Do you have other backups?
I have a June 10 backup and a June 13 backup. I thought I had Roon setup to do automatic backups to Dropbox, but I don’t see anything more recent….ugh! I have egg on my face for that one. If I have to restore from a backup, will I have to choose one of those?

What do you have in this database that you’re hoping to preserve (meaning playlists created in Roon, play history, edits, etc).
I know some people do extensive tagging and metadata tomfoolery, but I don’t. Worst case scenario here is probably not that bad for me. 90% of my music library is Tidal albums and I don’t really change the metadata for that at all. I do sometimes “favorite” certain tracks on albums I’m less familiar with so I can play them down the road. I have created playlists in the past, but if I lose them, it’s fine. I mostly make playlists to just surface my recent favorite albums in the past month. I make new ones all the time. I do like to know which albums I have played the most and are thus my most dependable spins.

Has everything been working until this issue?
Yes, everything has been working normally until all of a sudden, I couldn’t open Roon the day I submitted the ticket. Notably, the only new thing I did that day was get a new Macbook in the mail and try to download Roon to it so I could use it as a shiny new remote to control playback from my NUC which was still handling core duty. It was when I was going through the process of trying to launch Roon on that computer that Roon stopped working everywhere. Now, the simple explanation is that new Macbook is the biggest variable so it must have something to do with this problem. But how? Is it coincidence? How is that process supposed to work? Does the new Macbook need to be set up from a Roon backup on Dropbox or does it just launch and shake hands with my network connected NUC and show me my library automatically?

The worst symptoms I’ve experienced were music occasionally dropping out for no reason, so I’d relaunch Roon remote and all would be fine. This didn’t happen too often. In trying to brainstorm other possible reasons for a hard drive problem, I posted these questions earlier today: Long term care for my NUC/ROCK Any worries there?

Lastly, I’ve had this annoying DIVX popup on my Macbook Pro for the last two years. Here is a screenshot image of it from Google Images. I think this is called Malware? I’ve tried to root it out multiple times, but even the articles I’ve read talk about how difficult it is to get rid of. Little pieces of it are found in kind of nooks and crannies of my computer files. I’m not sure I’ve ever seen any of it in my music files though. The USB drive I store my music on also has a separate folder containing a TimeMachine backup of my whole computer. Is it possible that DIVX malware infected my NUC? Thing is, that’s been a constant the entire year+ I’ve had Roon and I’ve been using this USB drive with that data on it for months without issue.

It finally occurred to me to contact the company DIVX and their support team promptly responded by acknowledging the popup as their legitimate software and instructed me how to remove it. So, it’s not Malware and I’m no longer concerned that it did any harm to my NUC. So unless you feel differently about it, we can strike that from the list of potential issues.

Hi @Brice_Lang ---- Thank you for your patience and the feedback! Having such detailed insight into the history of your Roon setup will definitely aide in our techs evaluation of your logs.

Moving forward, I would kindly like yo have you please perform the following:

  • Please access the NUC via the Web UI and stop RoonServer from running. 57 PM
    07 PM

  • Once RoonServer has been stopped, please access the Roon OS data directory.

  • Next re-name the “RoonServer” folder to “RoonServer_Old”.
    51 PM

  • Once the “RoonServer” folder has been re-named, please go back to Web UI and “start” the server again.

  • Connect to ROCK via one of your remote devices, log back in, and configure a new install.

  • Please let us know if you run into the same issue.


How do I access the web UI?

And when you say configure a new install, do you mean going through the entire process I did when I first got my NUC? That took me hours and I needed to connect my NUC to a monitor and use usb keyboard and mouse which I’d have to grab from my office.

No, you won’t need to do any of that again. And actually, you can probably just follow @Eric’s instructions from this point forward:

You can find the URL for the web interface from Roon’s “Choose Your Core” screen, or from Settings > Setup. You just need to click “Configure RoonOS devices” and then click on the IP address of ROCK ( in the screenshot below)


Let us know how it goes once you’ve followed Eric’s instructions above Brice!

1 Like

In short, it worked. I’m back up and running. I’ll respond later tonight or tomorrow with some thoughts and questions. Thank you for helping me out.

Well I got Roon working again. My tidal albums appeared, then I created a watched path to my usb drive. No previous path was not there to edit. Creating a new one caused the stored music to appear as new music in my Roon library, which is not ideal, but fine.

My favorite tracks (the heart symbol) are gone. That’s a bummer, but not the end of the world. It just helped me to know which tracks on less familiar albums were the ones I preferred playing.

Playback is working normally to me PS Audio Directstream Junior and I’ve got things going on my original MacBook Pro and iPhone which I’ve always used. I created a backup of this state on Dropbox last night. Today, I’ll try setting up Roon on ym brand spankin’ new Macbook. Remember, that’s when this whole problem ocurred in the first place so I’m a bit nervous that something will go awry again. Should I be worried about setting up Roon on my new Macbook? I’m just using it as a remote but I belive all laptop or desktop computers require the full Roon software not just Remote like iOS devices.

If I really wanted to restore my favorite tracks, should I restore my database from a recent backup? Turns out I do have recent backups, but I was just looking for them in the wrong place. My last one before today was 9/29/17. Would restoring to a previous backup run the risk of causing the same database error that caused all this or was that purely due to a harddrive issue? By the way, did you ever diagnose the harddrive issue by looking at my logs? Is it likely to happen again? If so, should I prepare to replace my NUC or its SSD drive?

Maybe all these backups have been slowing my laptop performance and I haven’t realized the cause. Seems lame that I cannot run backups when my laptop isn’t in use or it’s asleep. Why can’t the NUC do this directly to Dropbox instead of my laptop doing the work? If I don’t want to slow my laptop’s performance, I guess the other option is to have the NUC run backups to my connected usb drive, but isn’t that less secure than Dropbox (in the case of hardrive failure)?

Thanks again for your assistance!

I have actually been waiting on setting up Roon on my new Macbook until you give me the go-ahead. Is it safe to try it?