ROCK - Database Issue

Okay, I tried setting up Roon on my new Macbook. I started by deleting the software I had before and downloading it again from scratch. Everything worked just fine. Connected to ROCK, my USB drive, and DSJ endpoint. I’m up and running! Any final word on the health of my NUC baed on the logs?

Hi @Brice_Lang ----- Thank you for touching base and my apologies for the slow response here. I am pleased to hear that things have remained stable since the “reinstall” process :clap:

Moving forward, a few things based off the most recent PMs you’ve sent us:

“If I really wanted to restore my favorite tracks, should I restore my database from a recent backup? Turns out I do have recent backups, but I was just looking for them in the wrong place. My last one before today was 9/29/17. Would restoring to a previous backup run the risk of causing the same database error that caused all this or was that purely due to a harddrive issue?”

  • Restoring from a back up should have no adverse affects, but it is important to remember that this is contingent on the “health” of the backup. You can indeed give the restore a go if you’d like, but being as you are in a healthy/working state currently, I would recommend generating a backup of the current DB, first. This will ensure that have a fall back in case there is something wrong with the “9/29/17 backup”.

“Any final word on the health of my NUC baed on the logs?”

  • I left a note with our tech team today, requesting an update on their analysis. I expect to get some feedback either later today or early tomorrow. As soon I get the word I will be sure to reach out asap. Thanks for the patience, Brice!


1 Like

Hi @Brice_Lang ---- Thank you again for your patience, it has been very appreciated. How have things been holding up?

In regard to the health of your NUC. I spoke to our techs who have completed their analysis of your logs. They’ve informed me that they are not seeing any traces that indicate issues in relation to the health of your NUC, but I want to be clear that our logging is going to focus on the relationship between our application and how it behaves on the given device.

In short, if an element of the NUC (i.e SSD, RAM, or CPU) is starting to fail we will not be able to pinpoint this exactly. If anything our logging is going to pick up the subsequent results of this “failure”. If everything is up to date and you aren’t experiencing any power hits, my assumption is that this was not related to some external factor or hardware failure. I would recommend keeping an eye on things and making use of our backup functionality to ensure that your Roon elements are kept safe.

"Really everything is new, especially the NUC, it’s SSD, and RAM. I got them all 3 months ago, brand new from Amazon. "


Thanks, Eric. I have been listening to music a lot lately and everything has been rock solid (see what I did there?). I am making full use of Backups via DropBox just in case. Apparently the NUC has a 3 year warranty. I’m surprised the warranty period is that long. Okay well I guess I’ll just proceed as usual unless symptoms return.

1 Like

@Eric I’m wondering if this problem with my database is rearing its head again. Today I switched from a temporary modem/router combo back to my standard modem/router combo and I haven’t been able to use Roon since. The weird thing is that my network seems to be performing just fine. My internet speeds are pretty darn fast and I confirmed that the ethernet connection feeding data from my Intel NUC is to my DirectStream Junior is working as it should (hooked that ethernet cable to my laptop to run a speed test). So my internet is solid, and my NUC (ROCK) and DSJ are connected via ethernet to my router. For most of the night, I have been getting the same error (attached image #1)

The reason I wonder about my NUC (ROCK is this error I got just one time.

Hey @Brice_Lang – Eric will be along to help here, but just skimming this thread, it looks like you’ve seen your database become corrupted twice, and I just want to mention how rare that is.

Across 10s of thousands of installs, we’ve seen database errors maybe 60 times. This is actually lower than what I would expect to see just based on hard drive failure rates, which probably means there are some people running with hard drives that are starting to fail, but Roon’s database has been resilient enough to not fail.

The point is, if this has happened twice, something is very wrong here. It could be a problem with the hardware (bad hard drive; bad cable; etc), or a problem with the environment (frequent sudden power cuts, etc), but under normal operation this should never happen, nevertheless happen twice.

Eric will work with you to do whatever we can to identify the problem, and he has access to our technical team so we can advise you.

If the message only happened once and went away, it may not be as bad as I am describing, but I am going to enable some diagnostics on your account so Eric can follow up when he’s back online.

Sorry for all the trouble here @Brice_Langwe’ve spent months chasing bad hard drives in the past, and generally speaking we’re able to find the problem. It just takes time in cases like this – we appreciate your patience.

1 Like

Thanks for your reply, Mike. I can work with Eric.

Do you need me to send logs again? Should I go ahead and buy a replacement hard drive? If I end up having to do that eventually, I might as well reduce the wait time and order now.

Should I move the core over to my laptop this weekend so i can actuallybuse Roon again?

Hi @Brice_Lang ----- Thank you for your patience and continued feedback here. I am sorry to hear of the troubles.

Since Mike has went ahead and enabled diagnostics on your account, there will be no need to manually send over logs as this action will automatically generate/upload a diagnostics report to our servers containing a set of your Roon logs. I can confirm that the diagnostics report has been received and is currently with our tech team who will be conducting the log analysis. Once my report has been updated and passed back I will be sure to share the team’s thoughts/findings with you in a timely manor.


Hi @Brice_Lang ---- Following up with you as I had a chance to touch base with the team today to discuss this issue you are experiencing with ROCK on the mentioned NUC.

As Mike has mentioned in his previous, there clearly is something very strange going on here with your setup for you to encounter this issue twice (i.e “issue loading your database”). My understanding is that when you and I had worked through this issue the first time you started with a completely fresh DB in place. Meaning that after running the highlighted procedure you would have had to log back in, setup your watch folders, and reconfigure your endpoints. Is this in fact what took place, or by chance, did you restore from a backup?


You are correct that when we worked on this issue the first time, I followed your instructions exactly and started with a completely fresh database. I did not restore from a backup. As you said, I did have to log back in, set up a watched folder, and reconfigure my endpoint.

Hi @Brice_Lang Thank you for touching base with me and verifying that information, the insight is greatly appreciated! Apologies for the wait.

I must admit that this is the first time myself (and the team) has seen a DB get into this state, twice. In light of the fact this is such an unusual situation, I am going to discuss this with our CTO and senior devs to try to come up with some next steps for you so we can minimize the amount of “back and forth” while trying to troubleshoot the issue. The first guess would be that there is some kind of hardware problem but before we begin to venture down “that road”, let me see what the team says so we can offer the BEST advice possible.

If I am not mistaken (please due correct me if I am wrong :innocent:), your MacBook Pro had once hosted your Roon core, correct? Remind, were there any issues when Roon was hosted on that device?


Yes, for my first year or so of using Roon, my 7 year old Macbook Pro hosted the core. While performance was kind of slow, I never had any database crashes or any big problems I can recall. After the first year, I moved the core to my bran new NUC. Both database crashes have occurred with that device.

Hi @Brice_Lang ---- Many thanks for your patience here, and my sincerest apologies for the slow response.

Moving forward, I wanted to first check in with you to see if any progress or new observations have been made since we last spoke. Secondly, as mentioned in my previous, I did have a chance to touch base with our CTO and senior devs to discuss this issue you have been experiencing with your Roon DB.

Our CTO and devs all agree that this is certainly one of the rarest cases we’ve run into (i.e a DB becoming corrupted twice) and the team is concerned that these issues you’ve encountered are in fact due to a hardware problem in the NUC (i.e SSD or RAM). In light of this the team has proposed the following:

  • If the NUC is currently “on” please power it down and leave it offline.

    • The NUC should remain in this state during this test.
  • Next, the team would like you to take restore a recent back up (preferably one just before you ran into this issue) on the MacBook Pro that had been originally hosting your Roon core.

  • With the restored backup in place please monitor how the DB behaves. If things remain stable, then this would support the team’s theory that there is a hardware issue occurring on the NUC. If you run into the same problem, then this would suggest an issue with the the install and not the hardware.


Okay I restored my Roon database from Dropbox on my MacBook Pro, which is the device I used as Core before moving to the currently suspect Intel NUC. The database seems to be from early October. I didn’t really notice the most recent rash of bugs until Thanksgiving so this state should be a good test. So far so good. I’m playing tracks from Tidal and my laptop’s hard drive successfully. The MacBook Pro takes a couple seconds to start a song just because it’s not the best computer these days, but tracks have been playing as they should.

I have only encountered one hiccup. On just one occasion tonight, a Tidal track failed to play; I got this error message: "This track is not currently available" TIDAL error message (at 10:28pm Eastern). That is a known issue that us being worked on separately.

Since my last post, I have only once encountered the error “Tidal: This track is not currently available”. Besides that, everything is performing well and seems stable. I’ve been playing music for hours each day. Shall we give it more time, or is this enough to tell us there is a hardware issue occurring on the NUC? My NUC, SSD hard drive, and memory card should all still be under warranty.

Hi @Brice_Lang ---- I hope the holiday season has been good to you and your loved ones. All the best in 2018!

Moving forward, based on your most recent observations with the DB being hosted on the previous device (i.e the MacBook Pro) I would say that this does appear to be some kind of hardware issue with the NUC. Before proceeding forward, I have placed a feedback request with our tech team just to be 100% certain that there are no other variables here for us to explore before we begin to looking into replacing the NUC (SSD, memory card, etc). As soon as I hear back from the team I will be sure to follow up with you immediately.


1 Like

Hey Brice – sorry for the slow response here. I just want to first reiterate again how uncommon this kind of corruption is, and how unlikely it is that you’ve experienced this twice.

The tricky part going forward is that we don’t really have a clear way to determine why this has happened. It could be bad luck, but more likely it’s something related to the hardware or environment. I assume if you were experiencing frequent power cuts, you would have mentioned that by now, but that’s the kind of thing I’d be looking for if this was triggered by environmental factors.

If this is a hardware issue, my guess would be the hard drive or memory. At this point, I think it’s probably best to move forward on one of two tracks:

  • Set up a new database and configure regular daily backups with the maximum number of backups kept (99). With a fresh database, you can run until something goes wrong, and hopefully that never happens again.

  • Replace one piece of hardware (such as the hard drive) and then follow the instructions above – new database, regular backups, see how it goes.

In either case, if something goes wrong again, we know something is still off in your hardware or environment.

I know this sounds like a lot of trial and error, but again, this is extremely uncommon, and not something we can make guarantees about. What we can guarantee is that we’ll be working with you on this until things are completely stable, even if this issue crops up again months or years from now.

Let me know how that sounds, or if you have any questions, and we’ll go from there. And thanks again for your patience here Brice!

I breathed a long sigh just now. Yes, this is a real bummer to deal with all this stuff, but you all have tried your best to help me fix this. Thank you for your effort.

On the topic of “environmental” factors, I don’t believe we have anything like “power cuts” going on. I’ve never noticed anything like that in our home. As I’ve mentioned before, I do keep my NUC inside an IKEA drawer while it runs continuously. The drawer is slightly cracked open about half an inch and also has an opening out the back. I considered this carefully and even submitted a ticket here: Long term care for my NUC/ROCK. Ultimately, I decided that wasn’t a factor that would lead to a database corruption. Should I not do that anymore? I could just decide to be ultra safe and keep the NUC out in the open.

The first of two tracks you proposed…do you mean set up a new database on my existing NUC without changing any of the hardware? I’m not sure that’s even worth doing since my database on that NUC has already failed twice. I feel like it will just happen again unless something changes. So I think I’ll go down track number two, especially since my NUC, hard drive, and memory stick, are all still under warranty. I might as well replace while I can still do it for free.

Say I replace the hard drive in my NUC with a brand new one, do I have to go through that whole process I did when I first got the NUC of updating the bios and hooking up the NUC to a mouse and monitor and keyboard? I can’t remember what all that was for but it took me so long and had to borrow a bunch of stuff like mouse, keyboard, monitor. It took hours! Or do I just snap a new hard drive in and my network will recognize the NUC and I can use a Mac laptop to set up a new database on the NUC?

Hi @Brice_Lang ---- Thank you for touching base with us.

Moving forward, we agree that “track number two” is the most logical approach for you (i.e replacing the NUC “hardware”). In regard to your question about replacing the HD and then re-setting up ROCK. When the HD is replaced you will not need to setup BIOS again, however you will need to go through the process of flashing a jump drive with the Roon OS image and installing the necessary codecs as well.