ROCK Installation - NUC Legacy Boot Has No Boot Drives

Core Machine


Network Details

Ethernet connected to router

Audio Devices

Network DAC

Library Size

1000 tracks

Description of Issue

I have a NUC 7i7BNH that I want to convert to a ROCK core machine. I followed the instructions to set up the Legacy Boot as shown below. Staring from Image 1,

which was set to (Image 2)

As you can see, the Legacy boot doesn’t show any available boot drive. At this point, I’ve already created the USB flash image and the memory stick is already plugged into the USB slot of the NUC. I also changed other settings as Images 3 and 4.

I saved the changes and restart with F10 into the boot option, I see no boot drive options (even the SSD) (See Image 5).

So what is going on here? Please help.

So I tried an alternative way at my will. I went back to the Bios boot option, turned on UEFI Boot, and in the “Boot Configuration” checked “Boot USB Devices First”. Restarting the machine properly picked up the USB drive, and the screen guided me through installation of ROCK. It says successfully installed ROCK. I unplugged USB and hit enter, then upon restart the black screen shows “A bootable device has not been detected.”

I’m completely lost now.

Roon does not support UEFI boot. Enter the BIOS again and enable Legacy boot.

1 Like

It looks like the problem is that my Legacy boot doesn’t find the SSD drive as a boot drive. The following images show that the PCI configuration properly sees M.2 slot, but on Legacy boot there is no boot drive.

By now I have successfully installed Roon OS on SSD (by UEFI boot with “Boot USB Devices First” option), but after restart the Legacy boot can’t find the ROCK installed on SSD. Can this be a hardware problem with the SSD drive itself?

Still very confused…

It’s been a week but no response from the support team. @dylan ?

As you can see from the image above, the PCI configuration shows that m.2 slot is enabled and the Bios sees the SSD. Actually I just bought another SSD and replaced the original but the problem persists. I can’t find any other troubleshooting tips on this case from google search.

Many entries in the community.roonlabs with the google search ‘roon nuc displays no boot drive’…

1 Like

Hey @hgim82,

I’m sorry that our team didn’t get a chance to take a look at your thread yet. It’s been a while…:pensive:

We appreciate all of your efforts in trying to figure out what isn’t quite right when trying to get you ROCK set up.

I’ve looped in our technical team, so they can make some suggestions. In the meantime, maybe some piece of information from our article might help:

I got hold of a staff at Intel distributor and he was certain to state that the legacy boot does NOT support an SSD as a boot drive. It can only support SATA disk as a boot disk. This completely threw me off as it conflicts with Roon’s instructions.

I was able to successfully install Windows 10 on the SSD and now I am using it as the Roon server with Roon app installed. So it was confirmed that there was no hardware issue on my NUC.

In any case, Intel moved away from the legacy boot long ago. In fact the current versions even disabled the legacy boot mode by default. Why does Roon stick with such an archaic platform for ROCK OS?

ROCK installation guide should be updated and more importantly, you guys need to work on newer version of ROCK that works smoothly on newest NUC without having to deal with manual turning back the clock…

1 Like

Roon OS needs to be installed in the M.2 drive slot and that’s what the Roon ROCK installation guide clearly says. I put a NUC 10i7FNHN with ROCK just 10 days ago and the installation took me less than 20 mins.

If you want to help, please read before you respond.

As I said clearly above, I successfully installed ROCK on the m.2 slot SSD. The problem is that the legacy boot on my NUC 7i7 does not recognize the SSD as a bootable drive. And as I said above, the Intel technician confirmed that it is not possible to use an SSD as a boot drive in the legacy mode. So I am completely at a loss how others made it work.

Now, if you boot your ROCK machine and push F2 to enter the Bios, do you see the SSD on the boot disk list under the Legacy Boot mode? As you can see from my photo, it shows “no boot drive” in my case. But it boots with the Windows 10 installed on the SSD now. So the Bios properly recognizes the Windows on the SSD, but not the ROCK (when I had it on the same SSD).

1 Like

Perhaps your staff member is mistaken? I’ve been running ROCK on my 7i5BNH for years, and this boots from the m.2 SSD quite happily. And I’m clearly not the only one.

I suppose it’s possible that Intel has now released a BIOS that prevents this, but it is certainly not made explicit in the BIOS release notes.

Indeed, I didn’t want to confuse the support team so I didn’t bring it up, but I do have a 7i5BNH transplanted into a fanless case that runs ROCK smoothly. It was 3 years ago. I’m currently traveling and I’m helping my friend set up a ROCK server using this 7i7 and I ran into this issue.

I also suspected that the Bios updates might have to do with this, but I can’t check my other ROCK machine at the moment. Could you check your version of bios in the ROCK server? I still doubt it was the case though because I started this with 7i7 with an older bios, and upgraded to 0083 (July 2020).

And my point still stands: Roon should update the ROCK to move away from the archaic Legacy Boot mode which is not really supposed to be used anymore.

Difficult to check the BIOS version without physical rearrangement and attaching keyboard and monitor, but I doubt that it’s anything later than 0054.

BTW, did you see this comment in the release notes for 0060:

Fixed the “no boot device found” issue when Intel® Optane™ Memory is enabled in the BIOS and a SATA device is being used.

You haven’t got the Optane option enabled, have you? (clutching at straws here…)

@danny is working on a Roon OS version 2 that should move away from the need for Legacy boot, but as usual, he won’t commit to a timescale for release - he’s learned his lesson.

Good to know. Thanks. I will check later tonight.

In the meantime, I hope that someone at Roon can confirm that Bios 0083 is able to see m.2 SSD in the Legacy Boot mode. If it is not the case, then the ROCK installation guide must be revised to note this.

My NUC 10i7FNHN, released 06/2021 is running the latest BIOS V0052 from 04/09/2021 and I had to disable Intel Optane Memory option in order to enable Legacy Boot from the M.2 SSD as explained in the ROCK BIOS installation guide.

None of these apply to my case. I have Bios v0083 which is dated in July 2020. I don’t understand v0052 was released April 9, 2021. Is this Visual Bios?

In any case, I suspect that all the Roon’s instructions are being obsolete, only based on Bios 0060 or older. I hope that Roon support could confirm this.

I followed Roon ROCK installation guide and also watched Darko’s ROCK video installation. You should check that video in case you missed something else. If your NUC support Optane Memory then you have to disable it for Legacy Boot to see the M.2 SSD.

Regarding the BIOS, my NUC 10 does have Visual BIOS.

@Enrico_Castagnetti By now it should have been clear that what you have and what I have are different, and your instructions are irrelevant. Please do not clutter my support request page with unrelated information. Thank you.

My NUC is 7i7.
My NUC DOES NOT support or have Optane memory.
My NUC DOES NOT have the Legacy Boot mode greyed out.
Roon’s ROCK Bios installation for NUC10 DOES NOT apply to my case.

@dylan, where are the Roon technical support team?

Hi @hgim82

Apologies, I’ve been out of the office for a little bit. I took a look at your report, and it definitely seems strange — Your configuration seems to be correct. I’m checking with our QA team on what might be happening here. Just to check — do you have any other SSD’s you can temporarily try? Do they show up here? It’s okay if not, but it would be helpful to confirm. I’ll follow up once I’ve heard back from the team.