Rock update 1357 not installing

Running Rock on a NUC for the past 3 years without issues.
Controlling from a mac M1 mini with Room Remote and also an iPad.

Can’t update to 1357 in the app or on the webpage, per below.
Everything else work fine - no issues
Can you provide assistance.

Screenshot 2024-01-05 at 13.37.34

Screenshot 2024-01-05 at 13.34.42

Exitcode 10 typically seems to indicate some kind of network error

In some cases, rebooting the router and ROCK helped

In others, changing DNS on the router to a known-good one helped

Forum search also finds other instances but it always seems to come down to some kind of network problem


I tried re-booting the routers and the Rock but no joy.

Regarding changing the DNS, I presume that would be on the Rock settings. I looked on the Rock web interface and the DNS seems fixed. My Rock is on a fixed IP from the router.

Both my Roon Remote on the mac mini and the iPad updated OK, but not the core.


No, it would be a setting on your router.

Hi @ColinL,

In addition to exploring your DNS settings, it would be good to get a more clear picture of your network setup, and how your server is connected to your network:

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet


Thanks for responding. I was waiting for an IT friend to visit this coming weekend to try to implement a fix (for the reasons below).

I live in a rural area so internet over copper cable using a standard Plusnet (Internet provider) router directly connects to a Draytek wireless router by cable from which the rest of the system is connected. Rock is connected to the Draytek by ethernet cable as is the M1 mini which runs Roon Remote. The Draytek sets static IP’s for all the Hifi components (Rock, Rossini, NAS and M1 mini). iPad runs Roon Remote and connects to the Draytek via wireless.

Rossini DAC is connected to the Draytek using ethernet using two Cisco 2960 routers with SFP’s and optical jump.

Everything works as nature intended except Rock can’t update. The M1 mini and iPad both updated without issues.

I tried to access the Plusnet router using the IP address to check the DNS, but, for whatever reason, the M1 reports server not responding.

Happy to accept any suggestions.


That is very odd. Are you sure that your Draytek router is in Bridge mode so that it is using the same IP address range as the Plusnet router?

It sounds as though you have two different IP subnets set up in your network?


First things first… I am no IT / networking expert (understatement).

This is what the Draytek reports

and this is what Rock reports

Does this help?


I think that looks OK, but I confess that I am unfamiliar with the Vigor2830 modem/router and its 400-page manual(!).

Best to wait until @benjamin is able to comment.


Thanks for your help but with the help of a friend we got it sorted. Changed the Rock settings to static and made the gateway the same as the IP address.

Downloaded and updated.

Networks eh!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.