rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial

Two Dial means two Raspberrys and then the answer is YES.
You also can run Surface Dial and SpaceMouse in parallel on ONE Raspberry controlling ONE zone.

1 Like

Hi,

Has anyone got it all working on. Raspberry pi 3b ?

I have got the pi running - its licensed and visible in roon - but the new surface dial just blinks and does not seem to pair with the Pi - is there anything I can check to see if the BT is active in the pi ?

Cheers

Matt

So the dial works with windows - just trying a usb bt dongle in case that works better !

Thanks

Matt

Update - connected straight away with the usb bt dongle plugged in the Pi - awesome i have it controlling the goldnote streamer!

Pi 3B had been reported to work even without BT dongle. I wonder why you got trouble :thinking:

Not sure as the wifi is connected and working… I have a digital output hat attached in a perspex case…. I am sure I had a reason to pick up usb wifi and bt dongles when I bought the pi……

Fantastic solution - good excuse to use the pi again and having a physical volume to hand is great…

Many thanks

Matt

2 Likes

I like to announce that rooExtens v2.0.0 is out now.

We have a lot of improvements.

  • There is a License Manager that eases license handling. More on that you will find here: rooExtend – The easy start with Roon Extensions
  • We also integrated Roon Bridge for those wholike to use rooExtend as a Roon streaming client together with a USB DAC.
  • The Highlight is for sure our new rooNuimo Roon Extension that finally enables the use of the Senic Nuimo with Roon. More on that on my homepage https://rooExtend.com. Here you find all links you need.

A lot has changed in the underlying system so hopefully everything still works as expected.

Please also read the quick installation guide for v2.0.0 (rooExtend - Google Drive) to understand all changes and improvements we made.

There are two SD-card images available now, one for the Raspberry and one for the Nuimo-Hub. If you upgrade be sure to copy the right image on your SD-Card.

Best DrCWO

3 Likes

rooExtend V 2.0.0 is up and running. :+1:

The license manager is understandable and clear. And rooPlay (Roon Bridge) works right away with my Audioquest DAC. Thumbs up!

rooPlay

The best feature for me is “Zone Follows Playback”. Works great.

settings

But: It does exactly what the name says. The zone follows playback. If two different zones are in operation (e.g. kitchen and living room), rooDial or roo6D always works with the zone that was played first. In terms of technology, this may be logical, but it does not correspond to my intellectual logic. I (for myself) would wish that the extension would not follow the playback selected first, but the zone currently selected in Roon. Is that possible?

Thank you for the great job :+1: :grinning:

Hi,

So upgrade to 2.0 - very quick and seamless process (i think having it connected by ethernet made a big difference)

I have noticed a oddity :slight_smile:

The zone follows playback seems to work in that I don’t need a Zone set in the extension. But if I stop playback with the Surface dial I cannot restart it. Now if I pick a zone it will control whichever zone is actively playing - but if I stop it this time and then hit play again on the dial - it starts the zone the extension is set to !

I dont btw get a “yes and changes” option like above just yes/no

I think most of the time this would not be an issue - and its great that it will follow what playing as my goldnotes are in standby alot of the time so are not seen in ROON until they are turned on.

Cheers

Matt

Can confirm this behaviour. Love the feature but It’d be awesome if dial basically carries on controlling the zone that’s currently selected in Roon Now playing tab.

Maybe users can be given the option to set one of the dial gestures to “Revert to Default Zone” for someone to revert to the default zone if needed, without having to access to the interface through phone, tablet, pc etc… :slight_smile:

I also tested that again and can confirm it. It is not clear which of the two running streams will be paused and started. But it should definitely be the case that the selected zone is always controlled.

On Saturday I will have a session with @Klaus_Engel where we try to make the solution work better for you all :+1: So stay tuned…

Best DrCWO

5 Likes

Hi @DrCWO,

I’ve been using rooDial (and rooUPnP) without any issues for a while now, but with the upgrade to 2.0 I’m encountering some problems running rooExtend on a Pi4b. First of all my Surface Dial refused to pair, even after removing and replacing the batteries and restarting both my Roon Core server and the Pi several times.

Even stranger, I’m now seeing multiple mentions of rooDial and rooUPnP with their own Enable-buttons appearing in the Extensions screen. When I checked the Authorizations list, there were indeed multiple authorizations visible - a lot of duplicates, all of rooDial 1.4.0 and rooUPnP 1.10 (so not the old ones for the previous versions). Any thoughts?

Jamie,
you are right, this is really very curious! I also have a Pi4 running and never saw that before :thinking:

Are you running wired Ethernet (hope so)?

Please do as follows:

  • Power down the Pi.
  • Remove authorization for all Roon Extensions. You have an empty list then.
  • Restart Roon and go to Settings->Extensions. The list shall be empty now.
  • Burn a fresh SD-Card with a fresh the v2.0.0 SD-Card image.
  • reboot the Pi.
  • If it comes up you should see the rooExtend license Manager and nothing else.
  • Enable it in Settings–>Extensions and enter the license key for rooDial.
  • Send me the screenshot you get of Settings–>Extensions.

Thanks’ DrCWO

2 Likes

I have similar Problems.

Please try the steps above. I have no idea why the rooDial process gets started twice :thinking:

I now changed from roodial to roonuimo. Now it is working. I didn’t change anything inside the raspberry W, except the license.

Cheers - that solved the problem. The only difference in terms of procedure I can think of is that the first time I initially entered the wrong license number for rooUPnP, but I rectified that mistake immediately. Thank you!

I had the same problem too - 8 instances of RooDial running.
A simple reboot of the Pi W seems to have fixed it for me though.

2 Likes

Just set up RooDial with my Roon-based system and a RPi 0. Works flawlessly so far.

2 Likes

@DrCWO Hello, I just upgrade to the latest firmware 2.0. I was able to load the image, extension load in Roon. Licenses have been added. However, my SurfaceDial has not been able to pair.

Any troubleshooting tips? Thanks in advance. Love this solution.