Roon 1.7 killed all my flac radio stations

As above. Not a single one of my flac radio streams works anymore. Same error message on all of them: something like “this station cant be played…it may be temporarily unavailable or its address may have changed”.

Yep, or roon 1.7 killed them all. All the radio paradise flac streams (mellow, eclectic, rock, normal), jb radio 2 flac stream, intense radio flac stream, all dead. Kaput. Thanks roon 1.7!!!

Sounds like an error in the update as the stations are still there, Radio Paradise at least.

A post was split to a new topic: Roon 1.7 Live Radio seems to be very hit and miss

Hi, @john_smith3, sorry to hear about your troubles! Could use, please, send me URLs of the station which you are having issues with after the update?




Unfortunately i can’t tell you all.of them. I’ve just tried, and got an error message that only two links may be included in these forum replies, which is helpful…but, as a reference, try using all the flac addresses on this page in roon 1.7:

For what it’s worth, I also went to jb radio 2 website to ensure the flac stream was the correct one, and deleted the old station in roon, and set the radio station up again from scratch, using the flac link from their website, all to no avail. my internet connection is not good enough to cope with 192khz, so I’m using normal.flac stream.

And, for the radio paradise streams, try using this link, then use similarly phrased links for the eclectic, rock, and mellow RP radio streams.


After update to 1.7, they worked for about 10 seconds each, then I got the error message, above, and I cant get them to work again at all. Press play, nothing happens. These same addresses still work on everything else other than roon 1.7, mind you…

Have you tried rebooting your room server ?

Hi @john_smith3,

This stream is working okay on our end.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since running into this have you tried rebooting you Core and endpoints?

Yeah thanks, its resolved now. For anyone else struggling with this issue, it required deleting all saved radio station links, then adding exactly the same links as new stations. This worked, after reboot. Reason it didnt work before when I tried these exact same steps, is that when I re-added jb radio 2 as a new station, roon defaulted to the 192khz stream for some reason, and you have to manually select the lower bitrate flac stream as the default in roon…