Roon 1.8 (build 778) Feedback

The latest android app skips songs all the time running on the FiiO M15. Thanks Roon! This is exactly what I was looking for. I restarted everything, the core, the player and nothing.

Yeah - but how does it work with tags? Please don’t tell me it doesn’t.

I mean the match all / match any functionality.

Actually I don’t remember from which version it began, but why sometimes Roon shows me disc numbers in track list on the album screen, but sometimes it doesn’t? It’s really inconvenient and confusing to have no idea at what disc I’m looking at now.

After updating to the last roon app on the IPad no crash anymore when scrolling through genre…
thanks for the fix

I don’t think the Library Settings options for Album Versions is functioning. I spent a lot of time trying to use the parentheses options to no avail. I posted a plea for help and info here.

Has that Duran Duran album been added to your library, or are you viewing it on Tidal or Qobuz via Roon?

I ask because I’ve just looked at this album on Qobuz, and saw the same as you - no disc numbers. However, once I added it into my library, the disc numbers showed up…

1 Like

Hi Geoff,
It’s funny because I opened the forum right now to write exactly the same, that I discovered that Roon doesn’t show disc numbers for non-library albums.

it actually depends on metadata from the streaming service: Roon is using those for albums not added to your library :wink:

No. It’s still brutal on a 12.9" iPad.

Unfortunately, my respite was temporary. It’s back for me; I spoke to soon. I’m back to my 10” Fire tablet, which is surprisingly good with Roon.

A post was merged into an existing topic: Roon 1.8 sound quality change?

Album display is broken after update, anyone else have that problem?

1 Like

Yes - people with certain types of graphics hardware. See this thread:


Thanks a lot, very helpful!

1 Like

I’m in love again with Roon, 1,8 build 778

Huge improvement


I am still having a hard time trying to find an efficient way to add tags to tracks in my library though. If anyone can give me advice… that would be much appreciated. For more info, see: Almost impossible to "Add to tag" more than 99% of the Tracks that are in "My Library"

I just tried all the different cases that you described, not having any issues at all.
Have you tried to add let’s say 3 albums, and create a playlist of 2 tracks of each album.
Then check if behaviour remains the same.
I am afraid that somewhere in the Soundiz transition process, some ‘hidden’ information has not been taking into account.
If the results are still showing the same issue, can you please post some screenshots,

1 Like

Can we add a heart to the now playing screen?


Hi Dirk! Thx for taking the time to help me. Here are the results of the test. There is good news, bad news and worse news. First some good news.
(1) When I start by adding an album to my library and afterward I add a track of that album to a playlist, everything works just fine from every possible screen (playlist, now playing, history). No problem at all.
(2) When I choose an album and add just one track of that album to my library: no problem either. I can subsequently tag the track from anywhere I want.
Now some bad news (at least for me and the way I enjoy music).
(3) When, while playing (e.g. from a genre on my home page), I add a track to my library (without first going to the album): same problem as before. I can not tag the track while playing, nore in the playlist or in the history screen.
OK, so I guess I would need to add all the albums of all the tracks in my collection to my library (joy!), and after that I can enjoy the full functionality of tagging. However…
Here comes the worst news:
(4) I go to a track in my library. A track that is on an album that is not yet in my library. I decide to add that album to my library… because that will unlock the full possibilities of tagging. Unfortunately: this does not work as (I think) it should. The wheel next to the “play now” button keeps on spinning (I waited twenty minutes). And the situation stays more or less as before: I can not tag the track from the now playing or the playlist screen. However, when I go to my history screen, even when the wheel is still turning, I can add the track to a tag from there (the track I just played and that was already in my library and of which the album is still ‘being added’ to my library), The album with the spinning wheel also appears under My Library > Albums while the wheel is still spinning. (Are you still with me?) More than eight hours later, I check again in the album screen the album I was trying to add to my library. The wheel has stopped spinning (and is replaced by the contours of a heart). But: the track on that album can still not be added to a tag from the now playing or the playlist screen.

The test playlist I made contains now 68 tracks. None of the tracks were in my library before. Eight of the tracks have been added to my library ‘in the right way’, i.e. first to the album screen, and adding the complete album or the track to my library from there. Sixty have been added to my library in ‘the wrong way’, i.e. without first going to the album screen. I add the entire test playlist to a tag (‘Test’). I go to My Library > Tracks and focus on the ‘Test’ tag. Only the eight that were added ‘in the right way’ appear.

It is possible to recognize the tracks that have been added to my library in ‘the wrong way’: the column ‘Date added’ (in whatever screen) is empty. The tracks that have been added in ‘the right way’, have a date in the ‘Date added’ column.

Conclusion so far? You certainly helped me in further narrowing down what the problem seems to be. I am afraid it is not Soundiiz (for the test I used tracks that have never been transfered using Soundiiz). It’s more likely that it follows from the basic architecture of the Roon database which is built around albums. Or is this just a bug that can be fixed? If you have further suggestions, please feel free! It would certainly be interesting to see if you (or anyone else) run(s) into the same problems when you conduct a similar test.

Yup A lot of the older Intel processors running integrated graphics got kicked in the teeth by B778. Roon is aware, and I’m sure will provide another build to fix the issue, but for now…

1 Like