Roon App Crashing with iPhone 12

Roon Core setup: Mac mini (2018)
Operating system: MacOS Big Sur, version 11.2.3
Processor: 3.2 GHz 6-Core Intel Core i7
Memory: 16 GB 2667 MHz DDR4
Roon version: 1.8 (build 790) stable

Network router: Verizon Fios - G1 100
Internet: Ethernet

iPhone 12, via WiFi

The Roon app crashes frequently when I’m using my iPhone 12. First, the iPhone 12 disappears from the list of audio zones and then the app starts to crash constantly. I close out the app and reopen with negative results. I’ve done a hard reboot in the iPhone, deleted and reinstalled the Roon app and was met with negative results. I don’t have any problems when using my iPad Pro.

Hi @DBT, I’m not Roon support and I’m not about to offer a solution. Your problem does sound similar to this issue reported elsewhere:

I’m not sure but if it’s a reproducible/shared issue it might help resolve it.

Hey @DBT,

I’m so sorry we missed your post for this long :pleading_face: . Please, accept my deepest apologies. We’ve been overwhelmed by the number of threads we were working on and we’ve missed a few - things are looking up though and our response times are substantially shorter.

I’m so sorry to hear about the behavior you’re experiencing with the Roon Remote app on iOS. I was wondering if this is still the case?

I have just upgraded to iPhone12 and experience the same problem. I run latest iOS (14.6) as well as macOS (11.4). It all worked fine with iPhone7 same iOS. Talked with Apple today and we found nothing to do. Then I start to look at your page. The iPhone12 has been around for about 9 months and problems not addressed… Would appreciate some clear statement from you. After all I am a paying subscriber. This is not open sources etc… / Jan Peter Axelsson

I see that Roon has a list of compatible Apple iOS products

For some reason is not updated for a year… and the last entry is about iPhone 11 etc.

Best / Jan Peter Axelsson

Hello @Jan_Peter_Axelsson,

I’m so sorry to hear you’re experiencing a similar issue. A great starting point would be to:

  • uninstall the Roon Remote app
  • restart your iPhone
  • reinstall the Roon Remote app

Does that help?

If it doesn’t, it is very likely that a known issue might affect your device. It would be a tremendous help if you could fill out the form here:

Thanks in advance :pray:

P.S. The list in our help center is not exhaustive at this time. We’re working on bringing it up to date