Roon appears confused about two similar devices (again)

Hi all, I am running again into a problem that I’ve had (and fixed) a year ago:

I am running the following 2 similar endpoint devices:

  1. Raspberry Pi 4 Model B with HiFiBerry Digi2 Pro Hat
  2. Raspberry Pi 4 Model B with HiFiBerry Digi+ Pro Hat

Both are running Ropieee Version 2023.07.1 (1069) [stable]

When I try to name and set up the devices and zones, Roon behaves erratically:

  • Sometimes it renames both when I rename one
  • Sometimes when I try to rename one it renames the other one instead
  • Sometimes when I try to rename then the name doesn’t stick (it snaps back to previous name), or it appears only after reloading
  • I have not been able to get both zones to show up in the zones menu

Here is what I checked/tried so far (in part following suggestions from last year’s thread)

  1. Do the two Ropiee instances have different names? Yes
  2. Do the two devices have separate unique IDs under “About” > “Roon Bridge”? Yes
  3. Re-flashed both devices with current Ropiee image. Did not fix it
  4. Turn one device off, then rename the other. This fixed it last year, and sometimes it appeared to help with renaming, but still only one of the devices shows up in the zones menu.

I ready something about a possible RAAT DB problem. Would it make sense to try re-build it? How?

Any help is greatly appreciated!

I think this on the Roon server side. Have you considered a complete rebuild from your server setup?

Hmm, very strange, as I am running four (4) ROPIEEE P3/4 on my ROON network w/o such issues. Had also renamed them (when replacing one) and only that one was correctly renamed. No side effects on my other ROPIEEEs.

Which ROON version are you running? Current CORE build is Version 2.0 (1311) production

Yes I am running core Version 2.0 (1311) production

Ok I’ll try that. Would I use the steps described here?

Just curious if you’ve set static IPs for them

I did not - is it recommended to set static IPs?

I was wondering if you had and by mistake gave them the same IP address

If you delete the database and (for whatever reason) you can’t do a restore from a backup, then you will lose any edits you have done over the years, i.e. tags, playlists, etc…

Not sure how deleting a database and doing a restore is going to change anything. Presumably, the restored database will have the same characteristics as the one you deleted.

Just a heads up.

The devices definitely have distinct IP addresses and distinct "Unique ID"s

1 Like

Well, I was under the assumption that you restore your database wrt your collection, but that anything related to endpoints is lost. So it means you need to configure your endpoints as they were fresh, hoping to resolve the current situation.


Although we did this exercise before, can you still send me feedback of both units so I can do a final check that this is not a client-side issue?


@spockfish When you say ‘feedback’ is that the output of some command, or something that I can look up on Roon? What information would you like to see?

Do you mean this?

Hmm, you could be right about not restoring the endpoints. Hope that solves the recurring problem.

Thankfully, it’s been a long time since I had to do a Restore.

Edit: OTOH, I just discovered this -

I renamed the db folder, re-installed Roon and sadly I am having the exact same issues when trying to set up those 2 Ropieee devices :sob:

Satisfy my curiosity, please.

When you did a Restore were your endpoints automatically restored also?

It had me set them up from scratch, or more specifically I had to enable and name them


Thanks for the reply.

Not that, “feedback” is when you go to the “ADVANCED” tab in each ROPIEEE device and click on the green button SEND FEEDBACK on the bottom right , which generates after a bit of wait a unique identifier which you should copy/paste here for each device in question, so Harry will have a chance to look into those generated internal reports on his system and figure out if this is on his (ROPIEEE) side or on the ROON side…(ehemm, sorry for this German KANT-style long sentence LOL)