Roon + Bluesound problems [fixed by BluOS update]

Hi there,
I have a few issues.

  1. My Bluesound devices stop playing, seemingly random. They just stop. Sometimes you can just press Play again, sometimes. you need to switch songs/playlist for it to start.
    This is both from Tidal and local files.
    It works just fine from the Bluesound app.

  2. Every time my computer restarts and also Roon, it can not find the Bluesound players without me rebooting them.

@support might get you some additional attention.

1 Like

Hi @Andreas_Lindmark ----- Thank you for the report and sharing your feedback with us. Both are very appreciated, sorry to hear of the troubles.

Moving forward, to help aide in our evaluation of these issues you are reporting with your Bluesound endpoints may I very kindly ask you for the following:

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your Bluesound devices are communicating with your network/the application.

  • Please provide a brief but accurate description of your setup, as seen here.

  • When playback stops does Roon ever generate a warning or error message?


There are no error message(s) whrn playback stops.

Windows 10 x64
Intel i7 7700k
32gb DDR4

Local music is stored on a NAS device (Synology DS415play)

Broadband is 500/50 mbit cable

WAN comes in via the cable modem, then to a Ubiquiti Unifi USG router, and then a Unifi switch.
The wireless AP is a Unifi AP AC PRO.
There’s another switch at the bottom level, an HP 8port / 16gig switch.
all cabling is cat least cat6a.

Node2 is connected via ethernet and the Mini is on wi-fi.

Please lmk if you need any more info.

Hi @Andreas_Lindmark ----- Thank you for touching base with me and taking the time to answer my questions. The insight is appreciated!

Moving forward, based on the symptoms described in your report I’d like to see if we can try to isolate some variables to help understand where the problem(s) could be occurring. With this in mind I would like you to please try the following (in this order):

  • Please create a “test watch folder” on the internal drive of the core machine containing a handful of music. Try to playback to your endpoint via this locally stored "test watch folder and verify if playback continues to stop.

  • While it is a touch unclear me to as to “where” the Node 2 and Mini are located in your setup, please try testing with the Mini taken off Wifi (temporarily).


Just removed the NAS share and added a local share on SSD. But now I can’t play anything since Roon has lost the Bluesound devices, again.
This is silly.

The pulse mini popped up after ungropuing it in Bluesound, but the node2 remains “lost”.
I’ll just have to reboot it, Again. :expressionless:

And now it stopped, no error message, no nothing, in the middle of a song.

“While it is a touch unclear me to as to “where” the Node 2 and Mini are located in your setup, please try testing with the Mini taken off Wifi (temporarily).”


Node2 is on the top floor connected via ethernet, the Pulse Mini is on the middle floor connected via wi-fi.

Hi @Andreas_Lindmark ----- Thank you for the follow up and more importantly, thank you for your patience while I have been discussing this issue you are experiencing with our tech team.

As per my conversation with the team this morning, based on the symptoms in your report, everything would seem to point to the way Roon is discovering the mentioned endpoints on your network. In light of this theory our techs would like you to please confirm the following:

  • When Roon is in “this state” and contact is dropped with the Bluesound endpoints, are you able to successfully see/use the devices via the Bluesound application?

  • We understand that you been having to reboot the units themselves when the error occurs, but does rebooting your core machine ever return things to a stable state?

Looking forward to your feedback, thanks again Andreas!

Yeah the devices always works via Bluesound, I can even see the Roon logo in there, that Roon is using them.

The reboots I have to do is for Roon to discover the Bluesound devices, and I reboot the devices, not the Roon machine.
Rebooting the Roon machine does nothing, the only way is to have Roon core up and restart the Bluesoun nodes.

Thank you for the update @Andreas_Lindmark, the information is very appreciated!

Moving forward, can you confirm for me if you have “open vSwitch” enabled on the NAS and if you do would you kindly disable this function and let me know if this actin triggers a change in performance with the Bluesound devices.


There are no such option in my NAS, so I can’t disable and/or enable this.

And also, since this is not isolated to the NAS, seem a bit irrelevant?
It’s the same with the files on a local disk, in the Roon core server, and the same with Tidal.
Bluesound not really compatible with Roon?


My setup is as follows:
MacMini running High Sierra wired to a gigabit switch which connects directly to my router (Netgear Nighthawk X8). The switch goes to a wired Bluesound Node 2, for which I’ve never had any issues.

Previously upstairs from my router I’ve had Sonos Connect Amps, for which I’ve had only extremely rare connectivity issues. These were used over Wi-Fi with no Sonos device wired (ie. not using SonosNet). I would often get issues when grouping multiple Sonos Zones in Roon, which worked completely fine when using Sonos rather than Roon.

I’ve since bought new amps for upstairs (Peachtree Nova 150 and Nuprime IDA-8) and instead of using Sonos, upgraded to Bluesound Node 2 at both locations in hopes of playing high res files upstairs as well. In one room I previously used a Sonos connect with the Peachtree with no issues.

Since upgrading to Bluesound, I’ve had very frequent drop outs and issues. There are times where it works completely fine and plays both hi res and regular files without issue and other times where I can’t even stream mp3 quality.

I’ve tried limiting output in Roon to CD quality and it doesn’t seem to make a difference. When I check my connection status in blue sound under diagnostics it typically always says Good to Excellent, although there are rare times when I go to blue sound app and all wireless node 2 have dropped from network.

Issues include:

  1. Dropouts during the song that skips to the next track, but then have inability to play next song until I either: group the blue sound to another blue sound zone or unplug and replug the power to the blue sound. Grouping to another zone instantly fixes issue (and then I just ungroup them).
  2. Dropouts and then skipping through entire album and saying nothing in que.
  3. Player disappearing from roon, requiring either waiting a while for it to come back or unplugging and replugging power.

I never had these issues using Sonos. I also use Plex on my phone and have never had issues ever streaming hi-res files to my phone when using a usb dac and headphones (literally zero dropouts no matter where I am in the home, although I’m guessing my phone more often connects to the 5ghz band while blue sound is limited to 2.4 ghz).

My Mac, Router and Bluesound are all updated to most recent software/firmware.

My guess is that Bluesound is far less reliable over Wi-Fi than Sonos, but that there may also be an issue with Roon being unable to just restart playback after a drop out. When I would get the rare Sonos hiccup it would just stutter and then pop back to playing.

Any help suggestions would be greatly appreciated.


Exactly the same problem here with my Imac-Roon-Bluesound Node 2.

1 Like

I’m not sure whether my experience is helpful to share or not but I had similar issues over a long period with a Bluesound Flex and previously worked round them with a powerline device. I finally resolved them recently by installing a Ubiquiti AC Pro access point. My conclusion was that there seemed to be something about the interaction between BS and my previous Wi-Fi (a Billlion AP) that just didn’t work well, even though no other device had issues.

That said, the Bluesound logs suggest there are dropouts, though I can never hear any evidence of this. I do still have issues with syncing between Bluesound and other devices, so it may be that this isn’t the solution it first appeared to be, or this could be unrelated.

I’m curious if this only happens with RoonBridge, profit also drops out using AirPlay with the same devices.

This has happened to me as well. Vault 2 to Bluesound speakers. It happens not because of the network but the way the Bluesound devices comm w one another and the way the app registers there r addresses. It’s a well rd way to do so. As a result I got rid of the speakers. Now I just use the vault 2 to preamp and to the dac.

The issues I’m having is with bluesound even with downsampled feed. I previously had Sonos and only ran into issues when grouping multiple zones although without roon, using Sonos it was fine grouping zones