Roon causing refresh rate to drop in Windows 10

Core Machine

Roon Nucleus

Network Details

AT&T Fiber
Eero Pro (five nodes)

Audio Devices

KEF LS50 Wireless via wifi

Description Of Issue

On my Windows 10 desktop, anytime I select Roon as the active window, my refresh rate plummets from 144hz to below 30hz, sometimes down to single digits. I don’t even have to play anything. Just selecting Roon as the active window causes the problem. Anyone else ever experienced this?



Hi @Robert_Burkes,

Can you provide some details on the Windows 10 machine you’re using?

Are your graphics drivers fully up to date?

Yep. Drivers are fully up to date, and Windows is fully up to date.

Computer specs:
Intel i9 9900K
NZXT N7 Z390 motherboard
ASUS PG35VQ G-Sync monitor

I also tried it with a Samsung CRG90 monitor, thinking it might be a monitor problem, but it behaves the same way.

I’ve just started using Roon in Windows, as I was previously using a Mac in my home office.

Thanks for any help!


Hi @Robert_Burkes,

How is the refresh rate being tracked? Are you noticing this issue outside of a FPS counter (i.e. can you feel the impact of this besides the counter)? While Roon is running is this affecting other apps that are running too?

If you disable G-Sync does the same behavior occur?

I had not tried turning off G-Sync. The problem goes away when G-Sync is disabled.

The monitor has an FPS counter that shows the rate plummeting, but I can also feel it. Whenever Roon is the active window, the cursor stutters when you move the mouse. When another window is active, the cursor is as smooth as you’d expect at 144hz.

If Roon is running but minimized, the refresh rate stays at 144hz.

Hi @Robert_Burkes,

Apologies for the delay here. The team is looking into this and we are hoping that you can do the following:

Please use the directions found here and send us over a set of logs using a shared Dropbox link.


Sorry for the delay. I’ve been traveling. Here’s the link to the logs:


These are from a Nucleus, not from the PC that’s connected to the monitor. Thanks for your help!


Thanks, @Robert_Burkes!

Can you also send logs from the PC? They can be found using the same instructions I linked above.

Sorry, @dylan. I misunderstood. I thought the logs would only exist where my library is managed. Here you go:

PC Logs



It’s not a perfect solution, but I’ve just realized that if you choose to enable G-Sync only for full screen apps in the Nvidia Control Panel, rather than both full screen and windowed mode, the issue is resolved. I don’t know why Roon trips up G-Sync when no other apps in windowed mode cause the same issues, but at least this works for now.

Thanks for the update and for sending the logs over, @Robert_Burkes! I’ll get this to the team.

A post was split to a new topic: Refresh rate drops when using GSync

Hi Robert,

In case you’re still dealing with this issue and want G-Sync enabled on the windowed programs as well have a look at this community post, it worked for me!

You basically disable G-Sync for Roon specifically so all your other applications still use it.

Hi All!

A better solution for this is to go to the Nvidia control panel, then to “Manage 3D Settings”, “Program Settings”.

Now just add Roon into the list by hitting add, selecting Roon and then “Add selected Program”, then now scroll down to “Monitor Technology” and select “Fixed Refresh”.

Finally, just restart the Roon app and you should be good to go.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.