Roon connection to library /core

roon nucleus + firmware 1.0(build 174)stable/ ver 1.6

upstairs in coming cable broadband router netgear vmdg485
ethernet cable goes to netgear switch gs108.

sonology 713+ is connected to this switch by ethernet
gs108 upstairs ethernet cable another gs108 downstairs.
downstairs gs108 connects to nucleus+

msi laptop running win 10 connected by ethernet to downstairs gs108
ipad pro 12 using ios 12.3 via wifi

huawei phone android connected via wifi

usually problem starts fromnot finding roon core. reboot of nucleus+ fixes the connection to core but the following problem happens.
the last few days I keep getting the connection to library dropping out and then reconnecting for a minute or so,before losing connection again…

this simultaniously with all 3 devices.

audio devices do not make any difference, when connected all and any will play ok…
The problem is that roon keeps missing the library.

If I go to setting , click on disconnect core, then click to reconnect,the library re appears for a minute or so, then it loses it again.

sorry, pics seem to have inserted themselves in the text.

Hi @RodS,

Thanks for reaching out to us and for posting those screenshots.

When this issue occurs, can you please check Roon Settings -> Storage and post a screenshot of that page? I wonder if perhaps the storage location is temporarily inaccessible and that is why you are seeing no items in your library.

Has anything regarding your setup changed in the last few days? New firmware on your router? Ethernet cable replaced? Nucleus moved to another switch?

Before you reboot the Nucleus, next time you are in this state, can you please check to see if the Nucleus is still accessible via the Web UI? Can you also note the exact local time + date in your country of the next time this behavior occurs (e.g. 4:29PM on 5/21/19)? This will be useful in case we need to look at logs later on.


The library was showing as available where tracks could be seen, then not available when tracks were not seen. This kept flipping between these two states…
At this minute it is not available… time is 18.24. British summer time

Also getting trying to connect to Roon core when opening Roon.

There have been no changes at all in my system for several months, other than Roon itself updating versions.

1 Like

Date is may 22nd at 18.29. BST.
Roon. … lost connection trying to connect to core.

stillsame. screen print fromlaptop,but getting the sameon ipad pro and mobile phone.

18.50…22may rebooted roon nucleus+ and get this.

Hi @RodS,

Thanks for letting me know those timestamps. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

After these logs have arrived, I will ask QA to review them to see if there are any indication as to why this kind of behavior occurs. While this happens on our end, can you please confirm the last part of my post?

Just to clarify… that is the option to “configure Roon os devices on your network” then click on I.P. address, and that shows system status, operating system ,software etc with a red button top right to reboot or power off.
If that is what you mean then yes can see that.

At approx 1430 bst Roon was showing all tracks etc, as of now. 20.32. It will not connect to Roon core.

Rebooting at 20.34

20.39 and still looking for Roon core…

I can ping i.p. address of Roon core but still Roon not connecting .

Tried 2nd reboot at 20.45. and connected and showing all tracks etc.

20.55. At the moment tracks playing ok.
Very fustrating.

1st attempt today to get into Roon again, “waiting for remote core- roon is still trying to connect etc". Time 17.44 bst

Reboot at 19.34 bst… tracks showing.
1 minute later and they have disappeared.

Hi @RodS,

Thank you for letting me know those timestamps.

I can confirm that the newest diagnostics package from your Nucleus has reached our servers and I have started a case for your with our QA team who will be taking a closer look into this behavior.

I will be sure to reach out to you once I have more information to share and thanks in advance your patience here.

– Noris

Having trouble getting roon to find core,usually reboot gets it working for a short time but now also reboot via UI stopped working. screenshot attached.

Hi @RodS,

Thanks for sharing that screenshot and for your patience while I discussed your case with the QA team.

At this time, we believe this issue to be related to your network, so it would be best to start simplifying things a bit to see if it will help.

Can I please ask you to connect your Nucleus directly to the primary router and also have your Roon remotes connected to the same router via WiFi?

Do you experience any issues when running in this kind of configuration?

– Noris

Connected to main router/ and wifi and rebooted nucleus at 20.26

Still not showing music library.

I am able to play music using jriver from nas drive but roon is not finding it.

rebooted nas and library appears on roon for about 1 minute before disappearing again.
Jriver and can see and play music as well as video. at all times.

had roon open and started playing track in JR. at the same time looking at roon,the library appeared and disappeared at approx 21.08 bst

Here is screen print showing library showing in Jr but not in Roon