Roon connection to library /core

Logged on to roon Ui as cannot connect, it says roon server software not running, clicked restart then a couple of minutes later, get the same. Roon server server not running.

Hi @RodS,

Thanks for sharing that additional screenshots.

When I last spoke to QA regarding your case they noted that the network appeared to be unstable according to the diagnostics, and possibly the library is empty because the Nucleus is unable to communicate properly with the NAS when this issue occurs.

I have added your recent findings to the case notes, but can you please try connecting the NAS to the router as well to see if that helps?

– Noris

The nas is 10inches away from router, already plugged into it.

Hi @RodS,

Thanks for confirming that aspect. QA would like to activate a deeper diagnostics mode for your Nucleus to check system-level logs, but it appears that the Nucleus does not have a valid IP address at this time. Can you please try rebooting the Nucleus once more and confirm that it is accessible from the WebUI?

Also, can you please share a screenshot of your SMB settings from the Synology NAS? You can access this menu on the Synology:

And then press the “Advanced Settings” to see the minimum SMB version in use:


– Noris

Hi Noris
At the time of sending UI is accessible. 14.43 bst
Have attached the screen shots as requested. sent 2 shots as the left hand window has a scroll bar so 1st shot is top half and 2nd screen shot is 2nd half…

I just thought I would mention that the NAS drive is set to swith on at around 14.20 and off at 21.45 week days if that makes any difference…
Ironically the connection the last day has been pretty stable…

the IP is set to dhcp not static on tab in UI
hope this helps

Can you check these screen shots…
Is the nucleus grabbing the same IP address as the NAS ?

Hi @RodS,

Yes, this does indeed look like what is happening. If both the Synology and the Nucleus have the same IP address this can cause a conflict. Are you by any chance using a Static IP address for the Synology or have set up the same “Reserved IP” for both the Nucleus and the Synology in your router settings?

I am still waiting to hear back from QA regarding your newest diagnostics but I would check the above aspect in the meantime, and you may also want to set the “Maximum SMB protocol” to SMB 3 in the Advanced Settings tab because of a compatibility issues with SMB2 with Large MTU as mentioned in our NAS Troubleshooting Guide:

Use SMBv3 when possible. Failing that, SMBv2 should also be ok, but do not use smb2 with large mtu as it has known compatibility issues with Roon. If you’re using a Synology NAS and running your Roon Core on OSX, you can find some more information about fine tuning your setup here

– Noris

the roon core is on the nucleus, the NAS has the music library.

Synology is static but not the nucleus

Hi @RodS,

Thanks for that confirmation. I would go ahead and set the Synology on DHCP and if you wish to have the Synology always have the IP address it is better practice to use Address Reservation in the router instead of setting it to static IP.

For specific instructions on this you can use these instructions from Netgear but if the router is assigning the same IP address to both the Nucleus and the Synology this can cause issues. I would also make the SMB setting changes I suggested and see if that helps.

– Noris


Changed to dchp and re-imported library. Seems to be working fine so far.

Will see how it goes for the next few days…

Fingers crossed😀

Thank you for your help Noris, very much appreciated.:+1:

1 Like

Hi @RodS,

Glad to hear that things are more stable after making those changes :+1: .
Do let me know if things are still stable moving forward and if they are after a few days we can go ahead and mark this thread as [Solved]. Thanks!

– Noris

It is finding the library great now, but since the re-scanning of the library it seems there is a slight problem .
1)When 1st turning sytem on, the music starts playing but there is no sound at all.
The only way round it is to turn the ![03_15h16m01s_001_|592x500] nucleus off and restart…
I have a T+A PDP3000 HV and it has two inputs, one for pcm and another for dsd…
when playing one or the other it used to switch to the correct input for which ever format I was playing automatically, this seems to have stopped. This dac is not listed in T+A dac lsit in roon, which didn’t seem to make a difference previously…
Is it possible to delete the DAC and then plug back into roon and it willl pick it up again to see if that fixes the problem?

Hi @RodS,

Just to make sure I understand you correctly here, both the DSD and the PCM inputs are via the same USB cable? If this is the case, can you please reproduce the issue once more and let me know the exact local time + date in your country (e.g. 11:08PM) when the behavior of no sound occurs?

You can give disabling and re-enabling the DAC a try. To do this you would need to open up Roon Settings -> Audio -> Click on cogwheel next to T+A zone -> Disable -> Enable. I would also try a different USB port on the Nucleus and perhaps a different USB cable to see if that changes anything.

– Noris

Hi Noris

yes it is one usb cable to dac… it is the balanced inputs from dac to amp that there are two of, one pair for pcm and another pair for usb.
Ok at 15.30 BST turned on and started playing , no sound.
15.31 disabled dac and re-enabled dac. played and no sound
then changed USB cable and plugged into different port on nucleus.
there is only one usb port on amp.
15.41 playing and no sound
reboot nucleus
start playing at 15.43 no sound
turn off dac and back on again
start playing at 15.45 and now got sound.

link to dac if this helps

english starts at page 39

Hi @RodS,

Thanks for those timestamps and for the DAC manual. I can confirm that the diagnostics have been received and I have asked QA to review them. Once I hear back with any additional info I will be sure to let you know.

– Noris

Just another check… today.

17.15 turn on dac. and no sound. Switch dac off and on again, start music 17.16 and have sound.

Seems initial turn on and have no sound but after turning off and back on it is playing with sound. Times all BST

Hi @RodS,

Thank you for those additional timestamps. We have reached out to T+A for assistance in this matter and we expect them to contact you by personal message in the next few days.

– Noris

Dear Noris,

this is Lothar Wiemann from T+A.
We have done some testing today with PDP3000HV and roonserver and sent our findings to roon.

We hope that the issue can be solved in short time.



Any news on my problem. not heard anything from T+A but I see they have sent something to you.

Hello @RodS,

We are working with T+A on this issue and hope to have some next steps for you shortly. Thanks for your patience!