Roon Controller constant crashing on Windows 11 Desktop: render area size changed unhandled selection type

Roon Core Machine


Networking Gear & Setup Details


Connected Audio Devices


Number of Tracks in Library


Description of Issue

I get constant crashes on my Windows 11 Roon client. If I leave the client running in the background for more than about 30 minutes, then when I go back to it it either crashes immediately or does not respond for a few seconds and then crashes. Sometimes it won’t respond for 10/20 seconds and then it springs back to life. After the client restarts, everything seems to be fine.

I’m not playing music through my Windows 11 PC Soundcard - I’m only using the Roon client to control playback on other devices.

The last couple of lines in the logs when the application crashes are almost always this:

05/30 14:59:50 Debug: render area size changed value: 1537x1077
05/30 14:59:50 Debug: unhandled selection type:

All other clients are running fine - this seems localised to Windows 11.

Any ideas what might be causing this?

Similar problem:

Roon Client: Windows 11 i7 11 generation
Roon Server: Windows 11 i7 10 generation
Tracks: 20000
Network: Linksys 1900AC router, ethernet to core, wifi to Roon Client

Issue: client app constantly freezes since latest update, doesn’t crash, but freezes. About every 5 minutes.
close and restart solves problem till next time.

Not just me then - good :slight_smile:

In your Roon logs (usually C:\Users<your user name>\AppData\Local\Roon\Logs do you see anything logged in there when the app crashes? If you see anything like the error I get than that would narrow things down a little.

I don’t see just that, but I don’t understand what I’m looking at.
The @support people should come on the thread and give us somewhere to upload our logs.

Yep that would be nice. hopefully @support will be along in a while…

Remember today is a holiday in the US.

1 Like

Hey @Jamie_Tudor and @danny2,

We’re sorry to hear that you’re having issues with your Windows remote, we’d be happy to help. Does any particular action in Roon cause the behavior you’re seeing or does the program just seem to crash?

Have you tried my installing your graphics drivers? We’ve seen Windows updates cause issues with graphics drivers which results in this behavior.

Windows’ automatic driver updates can sometimes be a bit unreliable, and we’ve seen direct downloads from the manufacturer help in cases where Windows installations did not, so it’s worth a try if you haven’t gone that route.

Please follow these steps:

  • quit Roon
  • reboot the Windows machine
    • Turn off your Roon Core
    • Unplug your Core for a few minutes
    • Plug the Core back in
    • Turn on the Core
  • uninstall your graphics drivers
  • navigate to the manufacturer’s website for your Graphics Card (for example, a popular one is NVIDIA) and download the graphics drivers directly from there
  • install the graphics drivers (this link provides more details on the process)
  • relaunch Roon and check your audio devices page.

Please let me know if this helps. I’ll be watching for your reply and get back to you as soon as I can.

Hi there

It’s when Roon is sleeping or inactive that the crash happens. If I use it continuously it works fine. It’s only after I leave it in the background and come back to it after, say, 30 minutes that it stops working. Sometimes the screen has frozen so the song time isn’t advancing. Sometimes the screen hasn’t frozen but the transport icons won’t work, but the other navigation to “albums”, “artists” etc works. Sometimes the application will crash immediately, sometimes it will go grey for 10 seconds and then come back to life, or crash.

I’m using the latest studio Nvidia Drivers on this machine, with an Nvidia GFX card. I rely on the Nvidia GeForce software to keep me up to date, not Windows Update.

I’ve already re-installed the drivers a number of times with updates but this problem still remains, and I’ve restarted the Roon Core a number of times also, mainly because it leaks memory on the QNAP so I have to.

I do follow your logic that this may be something to do with graphics though.

1 Like

I haven’t found any consistent pattern to the problem. Sometimes after it’s idle, but also sometimes when I do a search it seems to hang on the search and then the app gets “stuck”. And it seems there have been other instances.

I did the video drive re-install, acc’d to NVidia software (even though I don’t have a discrete graphics card). Windows also just told me to do a Windows update, so I will do that also and see what happens.

1 Like

Since I installed a new video driver the situation is better, but: the app just doesn’t respond to clicks sometimes, and I have to close it and reopen it to get it working.

Also today I clicked on “play” for a Qobuz album, and got no response. Clicked again. Again no response. As if the app was frozen.
Then after quite a long pause the album I’d previously clicked to play, just started playing on it’s own.

Another instance: Just finished playing an album and Roon Radio started playing when the album ended - that’s fine, that’s how I setup Roon to behave.
But the main screen on my display didn’t update. Just “froze” with the display (including the “now playing” section at the bottom of the screen and the “queue” display not updating. They continued to appear as if the last song on the previously played album was what was playing.

I am going to try a different Windows PC as my playback device and see if makes a difference.

It sounds like yours is behaving exactly the same as mine is now Danny.

Hey @Jamie_Tudor & @danny2

Does what you’re experiencing seem consistent with the issues we’re investigating in this thread?

If so, we’ll add your posts to that thread so we can collect your system details and attempt the troubleshooting steps that have worked for other customers. Thanks!

What thread? There’s no link.

Hey @danny2,

Sorry about that, I’m not sure what happened there. Link added again. :pray:t2:

It does seem similar, but mine is on a Windows machine, if that make a difference. That thread seemed mostly MAC guys.

Yes it does seem similar, although I am also seeing crashes with a slightly different profile as well as the type of crashes reported on that thread. For example, sometimes I get the greyed out application that Windows displays when the app has crashes.

And indeed, many of the reporters on that thread (although not all) do seem to be using a Mac.


No update here? It’s been a few days.
Do you want our logs?
Or maybe just do the fix to the Roon core that you did for the people in the other thread:

I see and read similar behavior patterns in the Windows, macOS and Linux worlds. Sometimes with and sometimes without memory leak.

Debian derivatives with memory leak, Arch derivatives without (but same remote control problems).

I suspect like few others not to an exclusive causality Release 952, because some was to be observed/read already before. Without question it is much more widespread with the last release and there the usual suspects like graphics card drivers, .Net further development, operating system update…come into the research game. We should give the team time for this and show patience. The solution will come for sure.

…and while I’m writing this I’m just thinking about not burdening the limited resources with reading…I’ll take a step back now.

Still have the freeze/crash after PC wakes up from sleep.