Roon core unstable after an update. HARD DOWN

I meant to reply here but it posted above… see above. And thanks again

Update drive tests fine and plays on other systems

Hey @Ben_Katz,

Thanks for testing that. We’ll need some more information about the drive:

  • Does your core still crash if the drive is disconnected?
  • What system did the Seagate drive function properly on?
  • Is it a single drive or multiple drives? Roon kernel logs show different Seagate drives may be having the same issue.
  • How did you prepare/format/partition this drive?

If the crashing does not occur when the drive (or drives) are disconnected, I’d consider looking into re-formatting / partitioning the drive.

Let me know :pray:

Im not sure everyone is getting the issue. Roon works when the one drive is disabled. That drive tests fine and i can play music off of it on another system. I can also see the file structure on /rock when its not disabled. THIS DRIVE IS NOT THE
ONE YOU ARE SEEING ERRORS ON. That drive (the seagate) works fine. I also want to reiterate that i have run ROON for years flawlessly until the latest update. All of my drives worked perfectly up to the minute i upraded and it hasnt been working perfectly since.

I woke up this morning to find that Roon was running markedly faster. I will try and enable the 16 bit drive before i leave to see if it loads. I have now taken that drive to anothers Roon and it works perfectly there. So i think that eliminates the notion that it is errors on the drive.

Enabled the 16 bit drive. The scanning was qualitatively faster but it still lost connection with the Core

This is the error i get

The core will come back up in maybe 5-10 mins and if i disable the drive Roon will work.

Is this a drive that has its own power supply or one that derives power from usb ie 2.5”?

Are you using it directly to the usb port on the computer or via a USB hub?

It has its own power supply and it is connected directly into the NUC which runs the core. All of my drives plug into a hub that plugs into the NUC i7 core

Also. I enabled the drive about 40 mins ago. Unlike in past times ROON has not as of yet come back up.

I rebooted the core after i unplugged the offending drive and it now says a new vesion requires a database update. And came back up.

Hubs are not really designed for high data rates like disk drives hdd/ssd plug direct to the usb on the computer. They are fine for a mouse or keyboard or a printer at a pinch

I hear you but it worked perfectly for years. The hub is not the issue

You really can’t know that for a fact until you try it without.
Plenty of examples in this world of things that used to work just fine for years and now don’t.
Just saying it might not hurt to test it.

1 Like

Ok. Went direct same issue. We can eliminate the Hub as the issue

Just replace the damned drives! :imp:

1 Like

Ive taken this drive to other ROON instances and it works fine. I have friends who are also having these funny issues. Are we saying that magically the very moment people upgraded that a bunch of folks just happened to experience failing hubs and drives that work perfectly eveywhere else??? Can i get an enginner who actually works for ROON to help here

Now eliminate the drive itself ?

1 Like

THAT DRIVE TESTS PERFECTLY AND WORKS ON ALL OTHER SYSTEMS. Even on other Roon sytems. I hope there is a Roon tech that will look at the logs and diagnose anything that doesnt involve a bad drive which seems impossible since it tests fine and works everywhere else and which was not the drive that Roon thought had errors.

It also cannot be the hub as the drive, When plugged in, causes the error even when plugged in directly and all other drives work perfectly though the hub.

I LOVE Roon. I am a huge fan. But i need real help…please.

Not sure why you are shouting at me.

@benjamin asked you a series of questions that I don’t think you have answered yet. But it’s hard to tell with all the yelling in your posts.

I cant find at any point that you have said what OS you are installed on. Linux, ROCK, Windows? which is it… perhaps its a bug that is being manifested buy the kernel of your Linus if you are running non ROCK/Windows