Roon Core Will Not Update to 1193 (Repeat Issue)

Core Machine
• ROCK 2.0 build 1148
• NUC8i5BEH (256GB SSD; 8GB RAM)

Networking
• Nokia BGW320-505 gateway (AT&T)
• Netgear switch (GS305) to NUC and bridge
• Ethernet to NUC (music files and database BU folder on WD Passport HDD connected to NUC)
• Ethernet to Roon Bridge on Raspberry Pi
Remotes
• Windows 10 on i7 laptop
• Kindle Fire HD10 (modified with APK files for Play Store) with Roon app
• Samsung Galaxy S20 with Roon app

Library Details
• ~45K tracks (stored on 2T external HDD connected via usb to NUC)
• ~14K tracks in Qobuz library

Description of Issue

ROCK will not update to 1193. Hangs for 30 minutes or so displaying empty download bar then displays message: “There was an error checking for an update.” (Remote on my laptop updated without issue.)

This also occurred on the 1182 update. At that time I followed guidance helpfully offered by @Geoff_Coupe to use the Web Administration page to reinstall RoonOS. This worked but I have since been informed that reinstalling the OS can create other problems. I don’t know if this is a concern, but I would rather resolve whatever issue is preventing the sucessful download of Roon updates in the usual manner.

I outlined this issue on the recent Roon Downloads Page discussion (Roon Downloads Page) where @danny suggested that there may be an issue with my DNS setup.

Unfortunately, diagnosing let alone correcting my DNS setup (or any other networking issue) is at the outer fringe of my troglodyte competencies without assistance. (I’m not even 100% certain in know what DNS is beyond knowing what the letters stand for…)

I should note that other than being stuck on the last build, Roon is operating flawlessly but before I try another OS reinstall I’d deeply appreciate some guidance (especially from @support) on how to correct this update issue. TIA

And what, precisely, have you been informed of?

Thanks for the response, Geoff. Here’s what a fellow user said to me in a Roon group: “You can try reinstalling Core again, but there are risks of backups and drive mapping erroring when you do this.”

As I said, it worked like a charm when the last update failed (thanks!), but I am hesitant to try it again unless folks are pretty sure I won’t accidentally make matters worse. Are you pretty confident that I need not worry about reinstalling the OS from the web UI?

And what, if anything, do you make of the suggestion that my DNS is set up wrong or not working?

I interpret “reinstalling the Core” as being different from “reinstalling Roon OS”.

If the Core is reinstalled from scratch (using a USB stick with the ROCK installer), then indeed you should have a valid backup to hand, and if you have moved your storage media to a new computer, there may well be a requirement to edit the storage settings.

However, “reinstalling Roon OS” does NOT affect your existing database or settings on your ROCK/NUC system.

I notice from the screenshot in your reply here, that you seem to have a static address set up for your Roon Core. Why did you do this? Unless you are familiar with networking, you should always choose the DHCP setting to let your router assign an IP address to your Core.

1 Like

If I recall properly, I set it to static as part of a series of attempts to get the core to pass the ARC test (per “Manual Configuration” instructions here https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Manual_Configuration). As I said, I am way out at the shaky end of my competence with networking stuff and do not recall what steps I took (if any) to configure the router/gateway provided by my ISP (ATT Nokia BGW320-505). Sorry for my poor understanding of networking; it is outside my laughably outdated technical experience. :man_shrugging:

(btw, I have zero use for Arc in my user case…)

I appreciate your taking time to help with this.

Should I try to resolve the underlying update issue or do you think reinstalling the OS from Web Admin is solution enough for the time being?

I would first switch to the DHCP setting in the Web Administration page, reboot your ROCK/NUC and then see if ROCK will update itself.

And if you don’t have a use case for ARC, then just put all that to one side and (hopefully) enjoy your music.

1 Like

I just want to document the steps I’ve taken thus far. Switched to DHCP and rebooted: No luck.

Reverted gateway/router port forwarding to pre-Arc modification setting (deleted port forwarding rule). Rebooted router. Still getting “error checking for an update” message.

Is it time to do the OS reinstall (or wait for @support to advise on resolving whatever my underlying issue is)?

Thanks again, Geoff.

Let’s try reinstalling Roon OS - shouldn’t hurt…

1 Like

Good deal. Will do. I’ll let you know what happens…

Well, once again that worked to update to 1193!

(I hope someone can advise on why the usual update procedure is not working with my network before we deem this solved.)

Meanwhile, thanks for your patient help Geoff!

try 8.8.8.8 for your DNS server

pretty sure all reinstalling will do for you is reset your network static IP settings

might get you the same result

1 Like

Thanks! On the Web UI for rock. Or somewhere in the router settings? DHCP or static?

in the screenshot from that other thread, you clearly has static IP set up with 192.168.1.254 for your DNS

I’m ok with that, but just enter 8.8.8.8 for the DNS

1 Like

Will do. I guess I’ll have to wait for the next update to see if that corrects the issue since @Geoff_Coupe’s suggestion did work to update the core to 1193. Thanks for your help @danny, I’ll let you know what happens.

you can always visit the settings → about page in roon – it will check for updates, even if there arent any, when you hit that page

if that fails, it’ll complain

1 Like

Yes. But it always saw the update, just hung on “Downloading” for up to 20 or 30 minutes before reverting to “There was an error checking for an update”

Didn’t matter if I set the update preference to “Automatically Install” or “Always ask before downloading” If I left it on “Automatic” it would stay on the error message for a couple of hours then the download bar would reappear then hang there empty until eventually returning to the error message. If on “Always ask” eventually the blue notification for a new update would pop up and if I chose update all, the same cycle would recur, 20 minutes or so of an empty non-advancing download bar followed by “There was an error…”

So it seems I won’t know if the “8.8.8.8” DNS corrects this issue until the next update is released and see if it carries through with the download. I sure hope so. I’ll let the Roon team know how it goes…

Thanks again for taking time with this. I really appreciate the care.

1 Like

@ncpl

Oh boy! Just read a tutorial on netmasks. I had to sit down to let my head stop spinning. Way WAY beyond my ken! The mask assigned under DHCP was 255.255.0.0 but when I tried entering that in the static IP tab, it just dropped the second zero.

I truly cannot get a solid grasp the consequences of any of this, even if I can sorta conceptually grasp what a mask is and a little of how the number sequences work (kinda sorta maybe a little…)

I’m not certain how to proceed from here…

There’s no need for a networking class, this is precisely why DHCP was invented :slight_smile:
I highly recommend you allow DHCP to do its thing and make these settings for you automatically.

1 Like