Roon disappeared from my desktop

Core Machine (Operating system/System info/Roon build number)

Dell XPS running Win 10 Pro 64 bit with 32 GB RAM

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

The Roon icon on my taskbar changed to a white rectangle, indicating that the shortcut is missing. The program files seem to have disappeared. I have tried reinstalling RoonInstaller64, but I get the following error message: "The application was unable to start correctly (0xc000007b).

My ROCK installation on a NUC is OK, and I can still operate it using my mobile devices, but I’d really like to be able to access it from my PC. Can you please assist?

It would be good to know what version of Roon you are trying to (re)install.

You may also want to try downloading the installer again and rerun it. While rare, files can be corrupted during a download.

I am trying to install the 64 bit Roon app on my pc using RoonInstaller64.
I downloaded a fresh copy of the installer, and had the same result.
I have tried the obvious: rebooting the PC, turning off reputation based protections in Win10, disabling auto-protect in Norton. None of these steps helped.

Go into Add/Remove Program. Does Roon show up there?

If so, Remove it?

Also, there’s this -

Yes, Roon 1.7 (Build 667) stable does appear under Apps and Features. I tried uninstalling it, and got the same result: “The application was unable to start correctly (0xc000007b)”.

I tried the steps outlined in the link that you kindly provided, other than changing OS from Windows to Google. No luck.

Hi @Robert_Hakim,

Were there any Windows updates around the time this started occurring?

If you have any pending Windows updates can you try installing them and let us know if that helps?

If there is no change, can you try updating .NET Framework and let us know if that helps?

The most recent Windows update was on 12/9/20, and I had used Roon successfully for almost a week after that.
There are no pending Windows updates that I am aware of - I always try to keep Windows up to date.
I tried installing .Net framework 4.8, but it had been previously installed, so no changes were made.
For what it’s worth, I’m using Win 10 Pro, version 20H2. The last Roon operation before the app disappeared was the addition of two albums to my library. Both albums appeared in Overview on the PC version of Roon, and still appear on the iPhone app.

I uninstalled Roon from the pc using Revo uninstaller. I then rebooted the pc and downloaded RoonInstaller64. I attempted to run the installer, but got the same result as before: “The application was unable to start correctly (0xc000007b)”.

Strange things happen on Windows 10 Pro 20H2…

Hi @Robert_Hakim,

This error can occur when you use ASLR, can you please check to see if you have this enabled?

I’m pretty confused by this message. Was it meant to go to me, or just Robert Hakim, with a reference to my older ticket/message? (I certainly don’t know all the ins and outs of forum messages.) Obviously the question asked about using ASLR doesn’t apply to me, since my use of ASLR is included in my message.

It’s not a message. Just a post in a Support thread probably directed to the OP.

That did the trick! Many thanks for your help!!

1 Like

I’m confused by your confusion. :smirk:

You were notified because when support answered the OP’s question they referenced a thread started by you. A thread where you solved the problem and told Roon about it. (Thanks.)

BTW - I do the same thing. I start a thread, forget I’ve done that and then reply to someone as if they were posting to me when they were just posting to my thread.

Thanks, that helps clear things up. Part of my confusion was caused by the fact that I was recently poking Roon a little about that still open problem, which I reported a year ago, and therefore getting messages about that from at norris also. I was also somewhat less than skillful in trying to track down what thread this message came from.

Hi @Robert_Hakim,

Thanks for letting us know that ASLR was the cause of the issue on your end as well!

@Peter_Gettinger - You saw the notification because I referenced your existing thread with the same symptoms in my reply to @Robert_Hakim.

We are still investigating to see if there are any changes we can make on our end to help with this issue, and we’ll keep the linked thread open until such a time comes.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.