Roon gave me the best new year’s present: it stopped working again!

Looks like I’ll be spending New Year’s Eve fixing Roon again for the umpteenth time this winter! It asked me to update my Rock server and control apps, now refuses to work once more! So, it’s back to square one. At this point I have zero confidence in their software engineers to get a stable release.

I’ll try to reset to the previous backup, and avoid clicking foolishly on the update button.

Hint: Roon should relabel the update button as “do you want to screw up a perfectly working system? Please proceed to click and waste a few hours of your time!”

Why not put Linux on your server machine, install the Roon Server on that, and skip the whole ROCK thing?


Meanwhile tens of thousands of users quietly work.


Been there, done that! I’ve tried to install Roon on a Mac Pro, a Windows 10 server, the ROCK server, and more… the bugs continue unabated. Each time there’s an update, it’s a rocky road. For all the years I’ve had Roon, I don’t think I ever had it run stably on my iPhone, which is the most problematic app on my iPhone in my memory!

Sad, great product potential, such poor execution…

1 Like

Lucky you! You must have the right genes!

Meanwhile, here’s my bug #N (N > 10,…). Rock is running, and the control app asks me if I want to unauthorize it, or simply hit the back button. I hit the back button, and once again, it asks me to log in. I log in, the loop repeats endlessly. Just another bug in the Roon experience…

OK, I managed to figure out how to fix the problem. Get this, I have to click on the “Unauthorize” button on my ROCK server. And, voila’, it starts working again. Wow, what a fantastic user experience. Who would have thought that unauthorizing the ROCK server is a coded signal for getting the ROCK server working again. :slight_smile:

Meanwhile, once again, the blue update button is flashing on my Roon control app on my iPad, but this time, I will not be so foolish as to click on it.

Happy new year, everyone! Sorry to waste your time on this frivolity, but I had to get this off my chest. Why, oh, why, can’t software be more reliable! (I speak as a 35+ year veteran of this industry, sadly!).


Interesting. I’ve never had an issue with an update, that I can recall. I’ve run on a Mac Pro (the trashcan model), a Macbook Pro, a Windows Home laptop, a Linux box with an AMD CPU, a Mac Mini with an old Core Duo processor running Linux, and am now running on a Synology NAS DS918+.

Yes, the iOS app is definitely broken. Keeps freezing and having to be re-started. Luckily I use an Android tablet and an Android phone.

Sorry to hear about your woes, though.


There is something very wrong with your environment.

Now that we’ve established that. Can you provide details so the community can help? What hardware are you using? Where is your library? Where is your music stored? What does your network look like? How are you installing?

Roon is stable when following the reference deployment.


iPhone App is awful. Keeps saying I haven’t any music, refresh, wait, refresh and it pops up. For years, Roon always seems like it’s almost there and that I might finally not have to think about it. But not so much. Way too much user intervention. The only app I have to screw around with.

Update process always been painless here. Used ROCK for 3 years and Linux before that all updates have updated and worked fine. Only issue I had once was the metadata improver issue that plagued many and still some have issue with, but a delete of the cache fixed that.

Current deployment is an Intel NUC i7 quad core processor with 32 gigs, and the library is an SSD array connected through a USB-C port on the NUC machine. Rock runs on it, and then I access it remotely through wifi.

Trying to guesstimate what’s wrong, I’d say the problems are both at the ROCK server end and the iOS (and for me, at least, Android) control apps. Something is broken with the way Roon updates these software modules. I suspect Here’s the info on my ROCK server. Note I have not installed the update. Learned the hard way that’s the road to ruin! Now that I’ve managed to recover my working system, I’d like to keep it that way.

When you go to the web interface ( what versions are on that output?

What are you doing to install and/or recover? What’s the internal drive on your Nuc?

“An SSD array” and “USB-C” seems weird to me since ROCK wouldn’t support this “array” configuration. What do you mean by “array”? (and I put array in quotes because that word has a real meaning when it comes to setting up multiple drives acting in an array)

What I mean by “SSD-array” is an external SSD raid device that has two 4 TB disks in a RAID-0 configuration. It’s simply an external USB disk as far as the NUC is concerned, and it reads the combined 8 TB disk just fine, so that’s not where the problem lies.

For recovery, I just put in the ROCK USB installer, reboot, and then select the option that recovers the previous installation. There’s an internal 2TB NVME disk on the NUC that stores the ROCK install. Here are the details from the ROCK web page. I’m not using the 4 TB local disk at present, this was originally intended to store my music library, but then it got bigger than the local disk size!

Thanks for the help, if someone can help fix my problems, that would be a great new year present!

Thousands of people update NUC-based Roon systems every time there is an update with no problems whatsoever. If you have problems all the time, maybe you should consider that Roon is not the problem…


Are you using the latest USB installer from the website. The Server is current but your Operating System is old. Latest release was sent out in Aug Roon OS Release Notes

I’m not sure the best path forward to fix this other than running an update and debugging from there. I guess you could try reinstalling (from the web) and see if it reinstalls the latest. If that doesn’t work pulling the latest image from Roon Labs might be the better path if you have to re-install again. This might be a good question for support.

I would move this to the @support thread so that they can see what’s what for you.

But just a comment: you were running on two strange platforms which I suspect haven’t seen Roon server much: Mac Pro (though really that’s just a Mac) and Windows Server. And then ROCK on a maxed-out NUC. My guess is that ROCK, like most boutique small-market configurations, hasn’t see all that much deployment, compared to more mainstream flavors of Linux. Small-market configurations suffer from less experience and fewer bug reports. I would try putting vanilla Linux, maybe Ubuntu server, on your NUC, then the Roon Server, and see if your problems clear up.

I just put something together you may be running into. Between OS version 1.0.186, your version, and 1.0.227, current, this happened:

If the upgrade from 186 is passing you through 221 it could cause you problems (depending on if you have an impacted NVMe drive). The solution is to recover with the latest image from Roon Labs website (which I mentioned previously). I assume you recovered with the first version you ever downloaded instead of latest and that’s your issue.

Get your Nuc on the latest OS.

I’d go follow the directions on that link which is:

Next steps for those affected


For those running ROCK, you’ll want to download the latest version here and run the recovery function . Note that if you install instead of recover, your database and settings will be lost, so it’s important you choose the correct option.

After running the recovery, everything should function properly again.

1 Like

I don’t believe the usb-c port is supported on NUC and ROCk.

Ovine this to the #support area

First point. Your ROCK installation is the latest version. The update message should be for something else in your network. The very first thing Support will say is make sure every thing is up to date.

Second point. I am pretty sure the USB C ports don’t work when using ROCK. When investigating USB RAID arrays as a possible solution for someone else with a large collection I saw there were USB C and USB A solutions. The right choice for ROCK was USB A.

Finally, why RAID 0? If you get a failure or corruption you lose everything.

1 Like

What is the NUC model number?