Roon has stopped indexing the music tracks on my iMac hard drive

Hi @dylan, When I tried to do as you instructed, I got an error message as per the attached screen shot.

Hi @dylan, I tried using the smb path as well and got the same error message. See attached.

That’s because you have not specified the new path for the watched folder - you’ve only specified the IP address. You need to give both the IP address followed by the name of the folder.

Hi @Malcolm_Gomes,

Try this:


Hi @dylan, tried smb:// and got the same error message.

Thanks, @Malcolm_Gomes,

Can you share a screenshot of the share settings for that folder on that Mac? I know we reviewed this on the previous thread, but since things stopped working here it will be good to review this once more and make sure everything is still set properly.

It may also be worth disabling any firewall temporarily that may be running on the Mac — It’s possible that a firewall or antivirus has started blocking the connection and causing the Connection Refused traces we see in the report.

Hi @dylan, I do not have any firewalls on my iMac. I have attached the screen shot as requested.

Hi @Malcolm_Gomes — Apologies, by share settings, I meant share settings on the Mac, like this from the previous thread:

Hi @dylan, could you please guide me on how I can navigate to that ‘share’ screen?

Hi @Malcolm_Gomes,

On the Mac, go into System Preferences and Select Sharing — From here you can select the folder which should already be shared. If you don’t see it shared, share a screenshot of what you see on the main Sharing screen.

Hi @dylan, I’ve attached a screen shot of the file sharing screen as requested.

Thanks, @Malcolm_Gomes.

Share settings look okay, so I’d like to enable diagnostics again and see if we get any different errors when using the IP address. Please try smb:// again, including the username and password, and make a note of the time this fails.

Additionally, I’m hoping you can use Finder from a different Mac and enter smb:// and share a screenshot of what you see.

Hi @dylan, this time it succeeded. Here is the screen shot. Do I click on “Select this Folder” now?

Well, if you do, you will be selecting an awful lot of folders on your Mac that don’t contain music files. That doesn’t sound like best practice to me. @dylan - what do you think?

Hi @Malcolm_Gomes — It looks like all of them are now accessible now, correct? If you go to the non-IP address version of the iMacHDD folder does it allow you to choose that?

Hi @dylan, yes it now does allow me to go to the non-IP address version of the iMacHDD folders and choose them.

Thanks for confirming, @Malcolm_Gomes.

It looks like whatever was blocking the connection has now stopped blocking things. When you went into the share settings did you change anything? Did anything else about your setup change?

I would go with the non-IP version unless you have a static IP set up on the mac. Things should be working for you after that.

Hi @dylan, I did not change anything when I went into share settings and nothing about my set up has changed. However, things seem to be working like they ought to now. Thanks for your help.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.