Roon Network Share

I have a 10th generation Intel I7 Rock. I used to have a network share on my desktop Windows PC and I just upgraded my PC and want to reset up the same network share. I have done that but I get the following message. BTW, I have windows 11 with a Ryzen 7950x and 64 gigabytes of memory and the latest updates of Roon.

Do you want to access the Rock’s internal storage as a network share from your Windows PC?

By default, the network name of the Rock is “ROCK”, so you would use \\rock. \\DESKTOP-AG19BTL does not look like a share that is exported by Rock.

Does DESKTOP-AG19BTL exist on your network? Can you successfully ping it? On the Windows PC, open a command prompt and run


Do you get a list of ping responses or “host not found”?

You will need a username and password for windows shares, I also think MS ditched guest access. I found the only way I could setup a share up a share was to create a new user and password and set the permissions for that user to access and used that to connect on my ROCK. Windows has made it harder for some reason with later versions to achieve this.

I did solve the problem with this video - German but maybe it can help.

This is my desktop computer. I clearly misspoke on this; it was late last night when I wrote this. I have an Intel NUC device with and I7 which runs the Rock software. I also have an extra SSD on this NUC device which stores my music. I want to backup from roon on the NUC computer to my desktop computer which is named DESKTOP-AG19BTL. That is when I got the message that I cannot connect to the share: Host not found.

Thanks, this explains some things that confused me :slight_smile:

But not completely. You would connect from the Windows machine like in your screenshot, but to the share that is exported by the Rock, i.e., \\rock. Then you would see the Rock storage in your Windows File Explorer, and can access/backup it from the Windows machine.

I.e., like here, except that this shows an older Windows version and talks about importing to the Rock storage, but import to or copy from makes no difference:

Method #2: Importing To Network Folder

I suspect that you’re still confused :slightly_smiling_face:

I read @Gary_Cardinale as saying that he wants to backup from roon on the NUC to his desktop computer which is named DESKTOP-AG19BTL.

That means that he needs to ensure that he has shared the folder used to hold the backups in Windows first, then add the Network Share in Roon, using the name of the Windows account and password used for the Windows share.

Indeed!! Please disregard what I said, sorry for adding confusion! It seems that I have lost it completely, please call my guardians.

1 Like

Did you set the new pc to public rather than private on network settings?
Also open explorer and click network does it pop up to say discovery is turned off?
Also try connecting to it with its IP address see if that works.

Yes that is correct. That is exactly what I have done except I am not sure what account and password Roon is looking for…is it my Roon account?

Tried my Roon user id and password and that did not work.

No, you want to connect to your Windows machine, so you have to provide your Windows login credentials (usually).

I tried my microsoft account user id and password to no avail.

Probably why you can’t connect. Please read:

I am so glad it worked for him. I did the same thing but not such luck. I still get the unexpected error message. Not sure why this has to be this frustrating. I have shared the drive, so it is unclear why I would have a different result. Thank you for providing the link; at least it worked for someone.

Where exactly is your Roon backup folder located.
Something may have changed in a recent windows update because…
I literally just had to redo mine this afternoon for unrelated reasons and it gave same unexpected error message until I did this for the path.
I had to enter the full file path.
So in my case it was computer name\Users\Owner\Documents\RoonBackup.
You may have to experiment here.

Yes I tried to identify the computer name\users\userid but was unsuccessful with that. Thanks for the suggestion however.

Here is where it is located. The computer name is DESKTOP-AG91BTL

One more thing is that my user name is f8thf

I also found my share did not like any spaces in the folder name.
So I made it RoonBackup.
Worth changing folder name to eliminate the spaces.