Roon not recognizing external SSD after Mac OS Ventura Update

So, after updating to Ventura today, Roon isn’t recognizing my external SSD. Everything was working smoothly prior to the update, but nothing that I do will resolve this.

The drive is definitely mounted (I see it in Finder) and other apps are able to access the files on it.

Please advise.

Try going to System Preferences → Privacy & Security → Files and Folders, and then check that Roon and/or RoonServer have access to your removable volumes. If they don’t, turn it on. If they do, try toggling the setting to off, then on again. Then restart Roon and/or RoonServer.

Hopefully that will work. If not, then you’ll need to wait for support to get back to you.

1 Like

Thanks, unfortunately that didn’t help.

Sorry to hear that. Hopefully support will be able to help out.

No worries. Thank you for giving it a try.

I’m almost sure it has something to do with the update to Ventura. This morning everything was working very smoothly and I didn’t make any changes to any settings.


1 Like

Daniel it’s wort checking all previous Mac settings/configuration as Apple have a nasty habit of restoring some settings to “default.” (a recent case is restoring wifi private addressing to ON).

Yeah, in that case, I’m not sure what it could be, because I checked what DaveN suggested and Roon does have access to removable volumes. So, I’m totally at a loss as to what’s going on.

Hopefully, tech support will be able to resolve this soon.

As amazing a piece of software as Roon is, it sure has a ton of bugs. Sometimes, I think I’d give up a few conveniences for something that just works reliably.

What format is the drive that Roon does not see?

Per Disk Utility, it’s ExFAT.

I just checked and Roon is recognizing a different external drive that I have, which is a 5 TB Lacie Drive.

However, it’s still not recognizing my Sandisk 2TB SSD that I’ve been using with Roon (and purchased specifically to use with) for about a month.

One morning everything’s working. You update to Ventura and all of sudden inexplicable things like Roon not recognizing a specific external drive happens. :frowning:

I also tried the same way, still not work

This might be related:

1 Like

Idk, I tried plugging in another external drive that’s also formatted in exFAT and it was fine. Very strange. I went back to Monterey for the time being. Maybe I’ll wait till the first update to Ventura before I upgrade.

Hi @Daniel_Bykhovsky. Everyone,

Re-mapping the drive in Roon>settings>storage should correct the issue.



In my case, the problem is that I don’t see my external drive (the Sandisk SSD) in the list of available drives. I have a Lacie (regular external HD) that is being picked up by Roon, but not the SSD external Sandisk drive.

This only happened after updating to Ventura. Prior to that everything was fine.

I downgraded back to Monterey because my entire music collection is on my external drive.

I’d like to be able to upgrade Ventura and use Roon.

Hi Daniel,

I understand your issue completely. The drive Roon is not seeing is likely formatted XFAT. Changes in Ventura require that the drive be remapped via Roon.

You may also need to add Roon under Privacy in MacOS to have full access.

Until you do these things, the drive in question will not work with Roon and Ventura. These steps are confirmed by both myself and others who work for Roon and have encountered the same issues.


1 Like

Same issue. External SSD drive is undiscoverable via Roon yet readily available on my Mac with Ventura. Allowed full access under settings. Please assist. Thank you.

Hi @Mark_Seidel,

Here’s Roon’s knowledge base article on how to correct this. Please let me know if you need further assistance.


1 Like

Thank you. Rather non intuitive but it works. Appreciate it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.