Roon Nucleus - cannot update to 1.8

I am having the same issue – I have re-installed the OS on my nucleus, re-started, and tried downloading and installing 1.8 several times. It got further the first time after I re-installed the OS, but still eventually stalled and terminated the download.

  1. Have reinstalled Nuclues OS
  2. Tried multiple times to update Nucleus Core to v1.8

Same update failures. See Screen Shots

Add images

![Screen Shot 2021-02-11 at 9.22.27 am|690x406](upload://eO1hca7p9Uit9yU6tVTNXZkA52X.png) ![Screen Shot 2021-02-11 at 8.38.55 am|690x477](upload://yCNQYbrFeDqHvehhOFc1yHw6Lmp.png) ![Screen Shot 2021-02-11 at 8.35.52 am|690x427](upload://wJH195TroAs7eeJq29wPfO42DWc.png)

Roon support just not listening or investigating. They keep asking try reinstall Nucleus OS (done that many times), try updating again (done that many times)

Need to get them to look why we can’t update…

Lot of their servers are overloaded right now. I would bet that’s the main reason. By retrying at a different time, you may have a better shot at getting this to work.

Is that the ultimate solution? No, but fixing overloaded servers while there’s an overload? That’s maybe less trivial than we all think. Future improvements on the update mechanism to retry an update without having to restart the server would also be a welcome addition.

I have been trying to give them the benefit of the doubt, but am getting pretty irritated. My phone auto-updated to the new Roon Remote software, which won’t recognize 1.7 and wants to force an update. Fortunately, my iPads didn’t auto-update, so I can still use 1.7 with them. But I am looking at alternatives – this rollout is a train wreck.

@david_whitaker Have you actually updated your core to 1.8? When you say ‘this rollout is a train wreck’ is that your impression or your experience, can you be more specific?
I and many others had no issues with the update although I acknowledge some users did.

There have been multiple reports across the Web of downloading issues and immediate operational bugs. It is particularly annoying to discover, as the owner of Roon’s own equipment, that they mucked up the downloading to their own hardware. I was referring to trying to update my Core to 1.8 - that’s what won’t work. I have been using, updating, and troubleshooting my own computers and network connections since 1984, so I’m fairly confident that I know what a good and lousy update rollout looks like, and how to handle minor update glitches (I’ve dealt with hundreds, if not thousands), and this is definitely a screwup.

So you have a Roon Nucleus? I guess you have already tried reinstalling the os? Power cycling, taking the setup back to basics etc, all things I have used since 1983 as a commercial network engineer.
I have an Intel NUC running Rock, iPad, iPhone and MacBook Pro, all updated first time with no issues.

Yep, did all of the above, plus checking network security settings, firewalls, etc. Roon Remote loads just fine – it’s just updating the Core on Nucleus that’s the issue. And, I would still think it was just me screwing up, were it not for the multiple reports by others. Oh, well — I’m sure it will shake out in the next few days…

I hope it gets sorted out for you quickly.

Thanks. Not good that Roon’s own gear doesn’t update correctly…

Exactly. Updated my Mac Mini Core first time. BUT cannot update to Roon’s own hardware. Amazing

Update Roon’s own hardware - Nucleus is the problem. Just doesn’t want to update to 1.8 and now cannot play via the Nucleus. I have to login my Mac Mini Core.

Hi, I have the nucleus+, did the update on remote device as well.
I got nothing at all, my ipad mini is my remote, both updated
ipad Roon display says "Choose your Roon Core
That’s it.
Have you had any success?

Yes, it finally loaded. Don’t know why – I didn’t do anything beyond what I already described in this thread. But, this afternoon, I tried again, and it worked. My assumption is that Roon figured out whatever the glitch was and corrected it.

Hi. Great for you. Will try when I get home. Hopefully it will work…

Hi @Corey_Tai

I just wanted to check in and confirm that you were able to get updated. If you’re seeing any issues still let me know!

Yes thanks.
The 2nd problem after Nucleus update success was Tidal went missing. After a day or so, it can back.

This 1.8 update has been a disaster for me and it seems to many others.

New problem, on my Android phone Roon App doesn’t want to open. Opens on my Mac and iPad.

Any suggestions?

Really Mr Roon, much much better and longer Beta testing next time.

And an announcement on the issues would be nice ???

I have the same problem. I want to try and download Roon 1.8 to my Nucleus, but when I try I get the same user message as shown above “Software update needed. Roon is trying to connect, but it looks like one or more of your devises on your network need a software update”. I have checked all the devises on my network and none of them need an update accept the Nucleus, which I can not connect to. My Roon Nucleus use to work so well and I was so happy with it, but now it is dead in the water and no longer works. Very frustrating.

A post was split to a new topic: Roon Nucleus - Cannot Update