Roon/Nucleus doesn't recognize DAC after latest update

Roon Core Machine


Networking Gear & Setup Details


Connected Audio Devices

USB DAC connected to Nucleus running to integrated amp and to main speakers
Also KEF LSX speakers connected wireless (I can connect and play to KEF speakers, no problem)

Number of Tracks in Library

4,000 tracks

Description of Issue

Everything was working just fine. I completed the last prompted update and now Roon doesn’t recognize the DAC connected directly via USB to Nucleus.

The DAC works fine when using spdif input from other source. Also I can connect my phone via USB to the DAC and it works fine, no issues.

I completed a reboot of Nucleus via the web interface and connected the USB DAC to the other USB port on Nucleus, but neither solved the issue.

I’d appreciate any help, thanks.

more info will be needed on what DAC - make/model … assume you have pulled USB out and power from the DAC and restarted it again

Bordor Patrol DAC SE with USB and SPDIF input.

Yes, completed power cycle of DAC. No change

did you reboot the Network as well ?

May do the trick

I just restarted the network but no change. thanks for the suggestion.

Hi @Joe_Spivey,

The technical support team is looking into your case. We’ll respond in more detail once we have more information available.

An initial pass through some automated diagnostic information from your account suggests this might in fact be the cause of a faulty USB cable. In the meantime, I recommend you try swapping out a different cable (any USB cable will do). Even if this cable has worked in other settings or with other devices, it’s worth removing it as a variable, just in case. We’ll keep an eye out for your response.

Thanks for your patience and stay tuned!

Hi Connor, thanks for your assistance. I swapped out the USB cable to another I have around. Same issue, no change.

@Connor Is this looking like a software issue? Especially given the problem occurred right after the latest update. I noticed others with issues plug in a monitor. I completed this step… seems fine.

Should I try reinstalling the Roon OS via the web interface? Any other suggestions?


Hi @Joe_Spivey,

Thank you for the update. We continue to investigate diagnostics internally, but it may be helpful to try these steps just to stabilize conditions in the meantime:

  • If you don’t have a recent backup already, first create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folders named “RoonServer” and “RAATServer”
  • Rename the “Roon” folder to “RoonServer_old” and “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer and RoonServer database

Next, power cycle all the hardware involved (network gear, Core, Remotes, and DAC). While tedious, it may resolve the issue, and if the issue is indeed at the hardware/kernel level, this step will clean noise from logs to streamline our investigation.

@Connor Ok, I was able to complete all the requested steps above. After a power cycle of all the equipment, trying to connect via remote and now all I’m seeing is this…

Thanks, @Joe_Spivey. We’re pulling diagnostics now and will have at least a next step before the weekend. I appreciate your patience here.

Thanks @connor

I deleted the Roon app from my phone and from my MBP. After reinstalling I was at least able to connect to Nucleus again, however, the initial issue still remains. Roon is not recognizing the Border Patrol DAC that was working prior to the latest update.

I was able to connect an Audioquest DAC directly to the Nucleus on a USB port with no issues. Roon recognizes it and I’m able to play music to a pair of headphones. Conversely, I’m able to connect another source via USB to the BP DAC and it works fine and plays music to my main system. So it seems both units are working but not together??

I wonder if the change of Linux kernel has perhaps lost support for the DAC given the Dragonfly works it would looks like the usb ports seem to be fine.

Good point, and I wonder the same. Hopefully something the can be corrected if it’s the outcome.

It does seem your not alone in this, there have been other users with similar issues. It’s been passed on to support by one of the mods.

Well what worked yesterday doesn’t today. Plugged in the AudioQuest Dragonfly to either Nucleus USB ports and Roon doesn’t recognize it. Perplexing and increasing frustrating.

hi @connor wondering if there’s a way to roll back to a previous version before the lastest update?

hi @connor

I keep troubleshooting this issue as it continues to be a problem. I was able to power cycle Nucleus and plug in the AQ DragonFly dac today. Roon recognized it as an audio source and it’s working today. I’m cautious because previously it only worked for a day and then it continued to not be recognized.

However the main issue is the BP DAC continues to not be recognized as an audio source via Roon after the last update. Also stated previously, this DAC continues to work with no issues when it’s not connected to Nucleus.

Do you have any updates that might help me in my attempts to resolve this issue?


The Border Patrol DAC connected directly to the Nucleus USB ports continue to not be recognized via Roon as an audio source. This coincides with the latest update from a week ago. The DAC and Nucleus otherwise work as intended. It has now been a week since any follow-up from Roon. Please, can someone help me troubleshoot this issue? Is there anything I try to resolve the issue moving forward?

I’ve tried daily reboots and power cycle of the DAC the past couple of days but still the issue remains.

I’ve been in contact with the manufacturer of the Border Patrol DAC regarding this issue. They were able to provide some hardware troubleshooting tips. Swap usb cable, power cycle DAC while everything is connect but these have not resolved the issue.

Can I please get @support regarding my issue. Could this possibly be a USB driver issue with the Nucleus?