Roon/Nucleus doesn't recognize DAC after latest update

@Connor Is this looking like a software issue? Especially given the problem occurred right after the latest update. I noticed others with issues plug in a monitor. I completed this step… seems fine.

Should I try reinstalling the Roon OS via the web interface? Any other suggestions?


Hi @Joe_Spivey,

Thank you for the update. We continue to investigate diagnostics internally, but it may be helpful to try these steps just to stabilize conditions in the meantime:

  • If you don’t have a recent backup already, first create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folders named “RoonServer” and “RAATServer”
  • Rename the “Roon” folder to “RoonServer_old” and “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer and RoonServer database

Next, power cycle all the hardware involved (network gear, Core, Remotes, and DAC). While tedious, it may resolve the issue, and if the issue is indeed at the hardware/kernel level, this step will clean noise from logs to streamline our investigation.

@Connor Ok, I was able to complete all the requested steps above. After a power cycle of all the equipment, trying to connect via remote and now all I’m seeing is this…

Thanks, @Joe_Spivey. We’re pulling diagnostics now and will have at least a next step before the weekend. I appreciate your patience here.

Thanks @connor

I deleted the Roon app from my phone and from my MBP. After reinstalling I was at least able to connect to Nucleus again, however, the initial issue still remains. Roon is not recognizing the Border Patrol DAC that was working prior to the latest update.

I was able to connect an Audioquest DAC directly to the Nucleus on a USB port with no issues. Roon recognizes it and I’m able to play music to a pair of headphones. Conversely, I’m able to connect another source via USB to the BP DAC and it works fine and plays music to my main system. So it seems both units are working but not together??

I wonder if the change of Linux kernel has perhaps lost support for the DAC given the Dragonfly works it would looks like the usb ports seem to be fine.

Good point, and I wonder the same. Hopefully something the can be corrected if it’s the outcome.

It does seem your not alone in this, there have been other users with similar issues. It’s been passed on to support by one of the mods.

Well what worked yesterday doesn’t today. Plugged in the AudioQuest Dragonfly to either Nucleus USB ports and Roon doesn’t recognize it. Perplexing and increasing frustrating.

hi @connor wondering if there’s a way to roll back to a previous version before the lastest update?

hi @connor

I keep troubleshooting this issue as it continues to be a problem. I was able to power cycle Nucleus and plug in the AQ DragonFly dac today. Roon recognized it as an audio source and it’s working today. I’m cautious because previously it only worked for a day and then it continued to not be recognized.

However the main issue is the BP DAC continues to not be recognized as an audio source via Roon after the last update. Also stated previously, this DAC continues to work with no issues when it’s not connected to Nucleus.

Do you have any updates that might help me in my attempts to resolve this issue?


The Border Patrol DAC connected directly to the Nucleus USB ports continue to not be recognized via Roon as an audio source. This coincides with the latest update from a week ago. The DAC and Nucleus otherwise work as intended. It has now been a week since any follow-up from Roon. Please, can someone help me troubleshoot this issue? Is there anything I try to resolve the issue moving forward?

I’ve tried daily reboots and power cycle of the DAC the past couple of days but still the issue remains.

I’ve been in contact with the manufacturer of the Border Patrol DAC regarding this issue. They were able to provide some hardware troubleshooting tips. Swap usb cable, power cycle DAC while everything is connect but these have not resolved the issue.

Can I please get @support regarding my issue. Could this possibly be a USB driver issue with the Nucleus?

In a word YES. certainly if it was was working in the precious Roon Nucleus build.

@wizardofoz appreciate the response. It was 100% working prior to the last update. Any ideas how to fix it?

@connor @Wes @support Please, can someone at Roon assist me?

Is it possible to revert back to the previous build?

A few thoughts below if anyone can provide feedback, it would be appreciated.

1.) Curious to know if the USB ports should be listed in the audio section with the ability to “enable” like the HDMI ports are in the photo. Nothing currently attached to the HDMI ports. I haven’t noticed how this was in the past so curious to know.

2.) I ordered a HDMI to USB adapter to try in one of HDMI ports. Not really sure if that’s something that would work but thought I’d give it a shot. Does anyone have experience with an adapter of this kind?

3.) The DAC manufacturer doesn’t know what the issue is and hasn’t heard from other Roon client’s using this specific DAC of any issues. He offered to replace the USB input circuit board if I ship it back to them for a fee. Wonder if I should give that a shot?

4.) As for the potential of a USB driver issue with the Nucleus, wouldn’t there be many others with the issue after the latest update to build 1148? I’ve read here of issues with Nucleus constantly restarting, core not findable, and issues with internal SSD. I haven’t had any of those issues and my internal ssd has been fine and continues to be connected. So not sure my issue is the same as others after moving to build 1148… IS THERE ANYONE ELSE HAVING ISSUES WITH A DAC CONNECTED DIRECTLY TO NUCLEUS VIA USB AFTER THE UPDATED TO BUILD 1148??


Hi @Joe_Spivey,

Please accept our apologies for the lapse. We’ve confirmed you’re encountering an issue with external USB devices on Build 1148.

We have a high-priority ticket with senior developers to resolve this issue, and there should be improvements if you update to the latest build of Roon on your Core and all devices in the meantime. Roon 2.0.5 and ARC 1.0.5 are live!

This workaround may work; the issue is with the mounting process for USB drives in RoonOS, so any other output shouldn’t manifest this issue. The team doesn’t have direct experience with these digital converters, but you could peruse the #audio-gear-talk section.

I recommend waiting for a status update from the Roon team if you still experience this issue on the latest build rather than taking any hardware replacement steps. Proper unmounting commands can resolve the issue, so let us know if you still experience the problem, and the team will proceed from there.

We’ll be watching for your response.

Hello there,
I am using Nucleus with build 1169 and experience similar (but intermittent) problems. Sometimes during listening sessions (and only when I frequently change tracks and/or stop tracks the during playback) Roon looses the USB connection to my Melco N10 Roon ready device.

In earlier instances of this problem a restart of the Melco N10 would resolve the issue, but the last time thispoblem occured a Melco restart would not resolve the problem.

To try and get my Nucleus to recognize the usb connection I restarted the complete chain, reset the Melco Roon ready settings, and fired all up in sequence. First a network component restart, followed by a nucleus restart, and Melco restart. To no avail.

In the meantime I was running out of time and chose to switch off all components in the chain and left the issue for the following day. After switching all gear on the next day I was supprised to see that Nucleus recognised the Melco USB connection.

It appears to me this issue is not yet resolved in build 1169.

@ Joe_Spivey. You are not alone…

1 Like

Why so long to respond to my repeated request for help?

This topic was automatically closed after 45 days. New replies are no longer allowed.