Roon on DSM 7: Backup fails

Today I updated to DSM 7.0-41890. Before that I uninstalled RoonServer (Version for Synology 6.x by Christopher Rieke). Then I installed RoonServer_Synology_DSM7_x86-64_20211030.spk, this is the current version by C. Rieke for DSM 7 (many thanks to Christopher!). So everything worked spontaneously without any problems, with one exception: When I start the backup, the message “Backup directory not available” appears.

The path is the same as before under DSM 6. As an experiment, I added the share again and also re-entered the username and password. But it doesn’t work:

What am I doing wrong? Thanks for all the tips!

The issue here is probably, that apps on DSM7 can’t establish network connections (to strengthen security of your Diskstation).

What you can do is establish the network mount in FileStation.
You can create a new folder (e.g. “RoonServer-Backup-Mount”) in your database
Then click on “Tools” → “Mount remote Folder” → “CIFS Shared Folder”

Enter your credentials and info for the remote shared folder and select the just created folder as a mounting point.

After successful mount, adjust the backup folder in Roon’s backup settings.

1 Like

Hi Christopher, thanks for the quick response. Just tried it, your idea works great. Again thank you very much!

Hello, my name is Richard from Berlin. I am having the same issue, but can’t follow your suggestion to the end:
what is the difference between “Folder” and “Mount to”? My question is: Is xxx\ “Share” the folder in which I would like to establish my roon back up folder (RoonServer-Backups-Mount)? Or what does “Share” mean? Thank you very much for any help. regards, Richard

Hello fellow Berliner, :wink:
If you take a look at the screenshot in the previous post, the “Folder” field specifies the remote folder you’d like to mount on your diskstation (so it has the IP and address and the name of the folder on the remote device in the syntax \\192.168.1.\FolderToMount ).
The “Mount to:” field specifies where this remote folder should be mounted to.
If you stick to the example in the screenshot, the remote folder Share will be available and mounted in the directory /RoonServer/RoonServer-Backups-Mount.

From a filesystem perspective, if you navigate to the RoonServer shared folder and open the RoonServer-Backups-Mount folder, you should see the content of remote shared folder you specified in the “Folder” field.

Dear Christian, thanks for your quick reply. I am a little bit closer now, but receives the following message “Fehler bei Verbindung mit Remote-Ordner. Bitte stellen Sie sicher, dass der Remote
Server über das CIFS Protokoll erreichbar ist.” I am sorry, but this is really challenging me :(. uff

Maybe you have another idea, but I will fiddle around until works, thanks a lot
regards
Richard

Hmm. I See you have a folder called “Roon Sicherung” with several folders already in it.
I am wondering if you really want to establish a connection to a remote server (that’s what the post above was about) or if you only want to make your “Roon Sicherung” folder available to Roon?

If this is the case and the desired folder for your backups is a local share (= also ein Ordner, der unter dem Punkt “Freigegebener Ordner” in der Systemsteuerung deiner Diskstation erstellt wurde…), you simply need to give RoonServer read and write access.

You can do this by selecting the “Roon Sicherung” share and press the “Edit” button in the “Shared Folder” Section of the Control Panel utility.
Go to the permissions tab and switch to “internal Users”. Now you see RoonServer in the list and should be able to give Roon Server read and write access to your folder.

You’re right. It seemed that I had the same problem mentioned above. I was looking for a solution, because Roon tells me since 3 days that it isn’t able to make BackUps anymore. This happened after I reinstalled Roon Server on Monday, because since beta, Roon was’n table to show new albums automatically. I always had togo to do this manually, since I’ve updated my Synology to 7 with your Beta. Now in addition to not showing new albums by itself, it also tells me, that issue with the BackUp failure…

Hallo Christopher,

war gerade kurz auf deiner Homepage. Nice one! Ich bin geb aus Warendorf, nahe deiner Heimatstadt. Vielleicht komme ich besser klar, wenn ich dir weiterhin auf deutsch schreiben darf :wink:
Nach dem DSM7 Update hatte ich zunächst die Beta von dir installiert. Montag sah ich das es eine neue Version zum download gab. Diese 20211105 habe ich neu auf die Synology installiert, weil seit der Beta der automatische Album upload in Roon nicht mehr funktioniert hatte und ich immer über “erneutes einlesen erzwingen” gehen musste. Ich hoffte mit der neuen Version das erneute Einlesen wieder automatisch zu haben, aber statt dessen bekomm ich jetzt noch die besagte Info bzgl. des Updates. Vielleicht macht es so etwas mehr Sinn für dich? Dank & Gruß, Richard

Back Ups meinte ich natürlich, nicht Update…

Justs an update: This issue has been resolved by private mails and was caused by a NTFS formatted disk, which has been used as Roon’s database storage. It seems permissions can not be set for specific subfolders on NTFS filesystems on Synology devices. After a reformat of the drive with ext4 filesystem, the issue was resolved.

1 Like