Roon Ready Device - Arcam not showing up on Settings/Audio

Roon Core Machine

Roon Nucleus+ 2.0 Roon Server Software (build 1128)

Networking Gear & Setup Details

Unify Switches/UDM Pro. HardWired Ethernet

Connected Audio Devices

Arcam AV40, HDMI from Nucleus+

Number of Tracks in Library


Description of Issue

a network based connection to the AV40 was working well after I installed Nucleus+. I tried also with HDMI and that worked well. I can no longer see the Arcam AV40 as a Roon Ready device under the Settings/Audio section of Roon interface. There is no refresh option in the Roon Ready section.

How do I reset/get back the Arcam AV40 in the Roon Ready secion. I can confirm the Arcam AV40 is hardwired and working on the network.

Have you restarted everything including the networking router/switches etc

1 Like

yes. no change. sometimes it show up, but a few seconds after I select the .NET (network interface on Arcam AV40) it stops playing and dissapears from Roon…

Hi @Mauro_Cappuccio,

Thank you for your patience in awaiting a response from support.

I am having someone look at this one with me. When I enabled diagnostics, I saw a constant stream of connection errors to your Arcam. Thousands of references in one log alone.

Can you elaborate on what you are speaking of when you say “I select the .net network interface”? Is this just another input channel for the device?


Just to verify. The connected via Ethernet. And it is not connected via HDMI to the Nucleus.

If it is, try removing HDMI cable from between the arcam.and the Nucleus and just leave the Ethernet.

I’ve tried that already. I will try to set the Arcam/Nucleus to 1Gbps Full duplex to see if that helps, then also change both cables… it could be a ethernet speed negotiation issue… hmmm. I will report back once I’ve done that.

the .NET interface is via the Ethernet port or WIFI. But, I have it hard-wired with Cat6 patch cable.

HDMI works fine… but I need to get it working over Ethernet… It works better and auto turns on the ARCAM receiver via CEC (when I had it working previously with Roon core running of my Windows PC over WIFI… it worked flawlessly…) Windows PC-Wifi, Arcam has always been hardwired.

Hi @Mauro_Cappuccio,

Can you tell me more about your modem/router setup and whether or not these are managed switches? I had an expert look at the totality of things for me and it was concluded that doubleNAT or multiple subnets might be at play.

Please let me know.


Ubiquiti switched network with a udm pro in from for wan and internal network to a Starlink router.

Single subnet.

Double nat for sure…… but don’t see what that would have to do with the internal network ( network. Most carriers use CGNAT and this is why my Roon Arc has no hope in hell of running outside the local network…… I wish roon had a solution for double nat for Roon arc. Port forwarding doesn’t work….

This worked flawlessly when roon core was running off my windows 10 PC….

So, when I run the Roon Core off my PC… it works like a charm!.. My pc is WIFI connected, and thru the .NET interface (this is the ethernet interface on the Arcam AV40), it works… as it used to before I purchased the Nucleus+.

Therefore, I would think the Ethernet connection on the Arcam AV40 is fine… Do I have a defective Nucleus+???

Please advise.

Tried setting network switch to full duplex and changed cables… still exhibiting the same behaviour. i don’t see any port errors on the network switch. You mentioned/noted many errors on the nucleus ethernet port?.. I also tried changing to 100M Full Duplex, no change, same issue.

Hi @Mauro_Cappuccio,

It might help to do what we call refreshing RAAT. Let me list the steps below. It should be a pretty quick change to implement and hopefully, it’s what we need. If not, I will have some next steps lined up for you.


  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Hi Wes, after a bit more digging around, I believe I’ve resolved the issue.

It seems that one of the WIFI Access Points that my computer was connecting to wirelessly was having issues… once I turned it off, and connected to an alternate WIFI Access Point, it’s working as expected now thru the Arcam .NET input (Which is the Ethernet port on the Arcam.).

I suspected this may be the cause, so I hardwired my laptop and Nucleus+ is working flawlessly… which led me to suspect that the closest WIFI AP to my wireless desktop (where i was having the dropout issues) was the culprit.

Setup summary:

  • Arcam AV40 and Nucleus+ are both hardwired ethernet
  • HP Desktop is wirelessly connect via 5.0 Ghz. and running Roon on the desktop
  • Wired/Wireless network is Ubiquiti based, with Starlink Gen2 Modem in bypass mode

So… case resolved, and thank you very much for all your assistance here.


  • Roon Arc will never work in this configuration, as Starlink and MOST ISP’s use CGNAT
    (Carrier Grade NAT) which causes a double NAT… and port forwarding does not resolve this issue.

Are you aware of any solution for this setup for Roon ARC?, or should I raise a different ticket for this?


1 Like

Hi @Mauro_Cappuccio,
I’ve marked this support topic as solved so it will close shortly.

As for GC-NAT check out these topics …

For reference, this is output from roon Arc setup:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“129.ddd.eee.fff”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

Setup: Starlink Modem → Ubiquiti UDM Pro WAN Port → Internet Network
Default Gateway is UDM PRo Internet Network Ethernet port