Roon Remote Not Working With IOS16 (SOLVED)

Roon Core Machine

Intel NUC 8th gen i7

Networking Gear & Setup Details

Fibre optic modem/router, D-Link switch, Silent Angel switch, Netgear wireless router configured as an Access Point

Connected Audio Devices

Rock > Mac mini M1 HQPlayer > SOtM SMS-200 Ultra (NAA) > USB to DAC

Number of Tracks in Library


Description of Issue

I use iPads and my iPhone as Roon remotes with no issues until I did an IOS16 update on my iPhone and it will no longer connect to the Roon Core.
Updated the remote on my phone to 2.0 and still cannot connect to the core. My iPads did not qualify for the IOS16 update and are running 15.X and both of them have no issues connecting to the core before and after the 2.0 remote update.

I tried my wife’s iPhone which is still on IOS15.X and it will also connect to the core.

Seems to be an issue with IOS16.0

You can’t use 2.0 remote without upgrading the core to 2.0. So double check this. If this is the case, you’ll need to upgrade all devices to 1.8 (Legacy) which is a new version of 1.8.

All devices are 2.0
My iPhone IOS16 cannot connect to the core - the phone and core were 1.8 and now 2.0, the phone connected fine until the IOS16 upgrade

Is your Roon Remote app frozen? My app is no longer working either. Running iOS 16.0.1, Roon Core (Nucleus) is running 2.0 and I’m using the latest 2.0 app from the Apple App Store. App freezes on the Home Screen and crashes. Tried reseting the app, and it finds the Core, allows me to connect, then freezes again on Home Screen. Also tried deleting and re-installing the app, still broken.

An iPad running iOS 15 works fine.

No, the app is not frozen, I deleted it and reinstalled it but still no luck.
Also rebooted modem and router and still no success.
The ARC app will not connect to the core as well.
As I said in my earlier post, all IOS devices that are running 15.X have no issue connecting to the core.

Just to clarify my situation, my iPhone always connected to my Roon core until I did the IOS16 update last week.
After the IOS update tried to connect to the core and it failed - rebooted my router/modem and also deleted the Roon app on my phone and reinstalled but still no success connecting to the core.

I did the Roon 2.0 update on all devices hoping that would fix my iPhone issue but it still will not connect to the core.
What is interesting is that my other devices, 2 iPads and my wife’s iPhone will connect to the core with no issues - they are all running IOS 15.X

I’ve been using iOS 16 since beta 1 and I’ve had no issues.

If you’ve got some free time. Are you able to run a backup, and reset the phone with a fresh install of iOS16 and only install Roon to see if it works?

Failing that, with it being too much of a hassle. Delete Roon again, and then go to settings and reset the network connections. The phone should restart, re-add your wifi, and then try again.

Thanks for the advice.

I do not have the time to do a full reset and fresh install of IOS but I did try your second suggestion.
Deleted Roon, reset network connections and reinstalled Roon - it still will not connect to the core.

upgraded to IOS 16.0.1 and my iPhone still will not connect to the core - any help from Roon support would be appreciated.

I’ve been on iOS 16 beta for a couple of months. Roon has always worked perfectly for me.

What exactly are you seeing when you launch it?

How much free storage capacity does your iPhone have?

91 Gb of 256 GB used

I am on iOS 16 no issues. Have you restarted the core and maybe your network gear to rule out any issues there?

Hi, yes all devices, (modem/router, access point, phone, Roon NUC), have been restarted.
Very strange that my wife’s iPhone on IOS 15.X has no issues.
Also, I could not connect to the core even before the Roon 2.0 update

1 Like

You are using a SOtM streamer, Hence, does the SOtM have Roon activated?

Question to Roonlab folks: does Roon bridge requires an update for Roon 2.0 compatibility?

The SOtM is set up as a Network Audio Adapter and receives the stream from HQPlayer - no issues playing anything, just can’t connect my iPhone as a remote.

Yep! Sorry, missed that point. Can you try to disable private WLAN adress in your Wi-Fi settings on your phone? Go to settings → WLAN → active wifi connection and scroll down to private WLAN. Reboot the iPhone

1 Like
1 Like

Thanks for the suggestion, but there was one other thing I forgot to check,
I always use a VPN on my devices and do not have any issues connecting to any devices on my home network.
I decided to try disconnecting my VPN service on m iPhone and voila, connected to the Roon core immediately.
This is very odd as my iPads (both of them) on IOS 15.X and using my VPN have no issue connecting to the core.

1 Like