Roon Remote on a Kindle HD 10 not seeing Roon Core on QNAP NAS

So I’m a week into the 14 day free trial, and honestly about to just give up and cancel using this service.

I am able to get Roon Remote on my wifes Samsung Galaxy S2 9.7" tablet without issues.

When I try on my 2018 Kindle HD10 tablet ( 7th gen OS it refuses to see my NAS & Roon Core.

I side loaded Google Play store and of course Roon Remote.

Every time I try to connect to roon core I get the “Looking For Roon Core” icon but never connects

If I type in the direct link ie, 192.168.1.** it never connects.

It also wont work on my Oneplus One Android phone ( Android 6.0.1).

Tried reboots of Tablet and phone and uninstalling and re-installing Roon.

I’m running the latest vesion of QNAP Roon on QNAP TS-251+ a 2 bay Raid 01 setup.

This Is what Roon Server tells me :

Roon Server:
Status : Running
Version : 1.5 (build 363) stable
QPKG-Version : 2018-06-14
Process ID : 21694

For what it’s worth Plex works fine and so does the stock QNAP music player.

Any help would be greatly appreciated.



Are you sure that the devices that will not connect are on the same 192.168.1.* network as the core?

Yes we only have one router and one internet access. So everything is on the same network.


Not necessarily. Did you check?

Every device shows up as 192.168.1.??? as the NAS
Including my Phone and Amazon Tablet

Hello @Claus_Blem,

The Kindle HD10 tablet should work with Roon, can you please let me know what router you are using here? How is the Kindle connected to the network, is it connecting directly to the router or are you making use of any range extenders?

One other test that I would like to ask you to perform is trying a different Core to host Roon. If you temporarily use a Windows or OSX machine to host the Roon core, is the Kindle HD 10 visible then? Please let me know your findings when possible.



Thanks for responding. I’m using an ATT DSL modem/router.

The kindle shows up on the same network via WiFi as everything else including the QNAP NAS.

I’m not using any range extenders.

I will try to download windows Roon Core and see if my Kindle will see it.



So I installed Roon to Windows and the Kindle sees it and plays through my laptop.

So hopefully that’s good and not bad?



ANYONE?!?! No ?? Yes???

Hello @Claus_Blem,

Thanks for confirming that the Kindle works as expected when using Windows.

We have seen a similar issue pop up before in this thread (Android app having trouble finding Linux Core) but unfortunately we have not been able to reproduce this in-house with any of our staff member’s setups or in a QA environment, even though we have collected quite a lot of information from affected customers and spent a considerable amount of time trying to reproduce in-house.

One way to verify if this is the same issue that you are experiencing is to perform this test:
• Open your Kindle Roon App and leave it open, having the QNAP as the Core
• Restart your QNAP
• See if you are able to connect after restarting

If you are able to reproduce this issue with those steps, some users have reported that they have been able to resolve this issue by turning off IGMP snooping on their Router.

I have found the manual for your router here and it does indeed appear to have the IGMP snooping option (page 139), although you will need to make this setting as a CONFIG command to the router (AT&T may be able to assist here with making that setting).

Please let me know if disabling IGMP Proxying improves the communication between your Android devices and helps resolve the issue with the Android devices connecting.


I’ve been through this on my Fire and participated in the thread noris linked to. You can reboot the Fire and it will usually find the Core. I run my Core on Linux and found I could bounce the Core service and the Fire would immediately find it. I gave up…I got tired of other issues on the cheap Fire, gave the thing to my son and went back to an iPad and I’m much happier.


Tried resetting my kindle, did nothing.

My android phone won’t find it either!

Thanks for your suggestion.

Hi Noris,

I restarted QNAP while running Roon on the kindle, and it did in fact find the job core!

I’m currently able to play and use all functions.
So I assume that this won’t stay this way if I turn anything off?!?

I’ll try to get into my modem/router.

Thanks for your help.

Hello @Claus_Blem,

What I gathered from the thread was that the issue resurfaces once the Android device enters sleep mode and the only way to re-establish connectivity would be to restart the Core as you did.

The IGMP snooping setting has had good results for several users on that thread so I would give that a go and see if it allows stable communication from your QNAP to Kindle. Please keep me posted on your findings.


Finally heard back from ATT rep (rude SOB)!

It can’t be disabled!

I did get it working when rebooting the QNAP NAS unfortunately the second I switch to any other tab on the kindle the Roon disconnects!

I wonder if I root my kindle, if that would change things?

Oh well, I might just pick up a cheap used tablet from ebay to use for Roon.

Thanks for all the help.

Are you saying that ATT told you you can’t disable IGMP snooping?

Yep that’s what I was so rudely told.

Did you try Googling your model number and how to disable IGMP snooping? I can tell you that I bought a Netgear 24 port smart switch last year and immediately started having issues with connection problems with my TiVo system. I asked for help on a TiVo forum and discovered it was IGMP snooping that was causing the problem. I Googled how to disable it and that fixed all my issues. I bet there is a solution online somewhere.

Idid, I got no matches for “Disabling IGMP Arris NVG589”

I’m open to suggestions!



I Googled your Arris router and there is an extensive section on IGMP snooping in the manual which you should be able to find. There are configuration parameters in the manual that you could try. Specifically on page 139.

This should link you to the router manual: Motorola® NVG589 VDSL2 Gateway