Roon repeatedly crashes on launch, and then is fine for a while

Roon Core Machine

i5 NUC (one of the officially supported ones - I can’t remember details!)

Networking Gear & Setup Details

Unifi network. Rock is on wired ethernet.

Connected Audio Devices

Chord Mojo (USB to Rock)

Number of Tracks in Library


Description of Issue

This relates to Roon Remote on my M1 Max Mac (1.8 build 923).

  1. everything is fine.
  2. Roon crashes and quits unexpectedly (when in background - I wasn’t interacting with it)
  3. I go to open Roon, the app launches, but after about 5 seconds (before library shows) it quits.
  4. Launch/crash repeats multiple times.
  5. Eventually after either enough relaunch attempts or a long enough time, Roon launches again and all is well.

This has only happened twice - just now and a week(ish) ago. That time I gave up, but Roon launched fine the next day. Today, it launched after maybe 5 or so attempts.

Diagnostic reports:


Hey @markauk,

Sorry to hear about your troubles with crashing on your Mac Remote. Have you tried a restart of your Core and the Remote when this has happened? Please start with that if you experience this again.

You may also want to try uninstalling Roon on that machine, then restart, and reinstall the program.

Thanks for getting back to me. It’s hard to test methodically as I don’t know what triggers the issue and it’s sporadic, but it just happened again now. I launched Roon twice and it quit as before, and then rebooted the Core. Relaunching Roon on my Mac then worked fine.

So, maybe rebooting the Core fixed this, but I’ll need to try a few more times to be sure. I’ll report back as/when it happens again.

Thanks @markauk,

Our newest build (931) includes some fixes for what you’ve described. Can you please update and let us know if the new release helps? I’ll be watching for your follow-up! :+1:t2:

Thanks - I’ve update the Mac client and Core to build 931. If the crash happens again I’ll report back.

2 posts were split to a new topic: Roon 931 freezing, beachballing, on launch with MAC

I am running roon core on a PC with Euphony OS 3.2 and got the same problem. Trying to access roon core through a Mac or Android tablet doesn’t work anymore. Even if a connection is achieved, what is rare, it quits when choosing a file to play.
Any help?


I’m still on build 931 on my Mac and on Core, and just had the launch/crash experience again. I launched Roon 4 times, and it quit immediately on opening. On the fifth launch, it worked fine.

I have the crash reports for those 4 launch/crashes if that’s helpful.

I’m having the same issues and Roon hasn’t replied in 10 days to posts. Their last reply was to ask for some pro forma details about my setup. I provided that within an hour or two of the request and then they stopped responding.

Is Roon suffering management, financial, or organizational issues? The whole point of a subscription model is that there is a steady income stream for the company to better serve its customers and to continuously improve the product. Instead, all I’ve seen is a train wreck were they push out badly buggy updates that corrupt people’s databases (destroying years of their customer’s work to setup their libraries) and struggle to implement a basically competent search system. And now their Mac software is randomly crashing on launch and there is not even a commitment for it to run natively on the current processors even though developers have had the new processors for more than two years now and the architecture is identical to the iPhone processor that Roon does have a native app for.

But one thing at a time: can we get some help with the random but recurring failures on launch that were introduced in this latest version?

I can understand your frustration. I have also experienced random crashes on booting Roon (on a Mac mini M1) … it’s annoying. In my case, it now seems to have stopped, at least for the last few days, but it was annoying while it lasted.

That said, there are a couple of points you make that are incorrect.

This isn’t the case. The recent updates include a mechanism to detect latent corruption, they don’t cause it.

The latest iPhone uses the A15 Bionic chip, not the M1.

1 Like

Hey @markauk,

Are you still experiencing crashing on your M1? If so, can you please check your Private Relay settings?

On your Mac, choose Apple menu  > System Preferences, then click Apple ID. Select iCloud > Private Relay.

On your iPhone, iPad, or iPod touch, go to Settings > [your name] > iCloud > Private Relay.

Your iCloud settings might take a while to load. In order to disable it, simply untick the box and click “Turn Off Private Relay” when the prompt appears.


It appears that you’re still running an older version of Roon. Please install our latest update, Build 933, and let us know if that helps. Thanks!

The crash-on-launch issue is occasional and sporadic, the last one I reported is the last time it has happened. I haven’t ever had iCloud Private Relay enabled on my Mac, and haven’t had it enabled on my iPhone for many months (and haven’t experienced any crashes on my Roon on my iPhone or iPad).

Just updated Mac client and Core to 1.8 build 936. First launch attempt after updating, Roon client launched and quit twice, then on third launch it beachballed (requiring force quit), then it launched fine.

Just updated to build 943, and identical behaviour as before except that Roon client quit three times, then beachballed on the fourth launch. After force quitting and launching a fifth time Roon launched properly.

Same here. Just updated to 943 and everything seemed fine. However, I’ve just restarted the Roon app and it quit four times before I could get it to launch. Just tried again: it quit the first time, had to be force quit the second time, then quit by itself on the third attempt. On the fourth attempt it launched and seems fine.

Hi @markauk and @DaveN,

Thank you for letting us know, and I’m sorry to hear the issue has persisted with the latest update. While @jamie is away at the moment, I wanted to reach out and let you know that the tech support team is still on the case.

As a next step, I recommend setting the database aside and fully uninstalling/reinstalling Roon on the Mac Remote. This will help create replicable and stable conditions and clear any cached data which might be causing the crash.
To start with a fresh database on your Mac device:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Let us know if that changes the behavior at all, and we’ll keep an eye out for your response.

I did this. Roon launched fine, and presented me with the terms screen and a “I agree” button to click. I clicked “I agree”, and the app then beachballed. I force quit after about 4 minutes. On second launch, the app quit before I clicked “I agree”, on third launch I clicked “I agree”, connected to my ROCK and the app launched properly.

Whatever the issue is, it’s clearly got nothing to do with the ROCK, nor anything cached by the client.

The good news from this test is that it seems to be quite easy to reproduce - If I delete the Library/Roon folder again, I get similar behaviour on the next launch - the only variation is that sometimes the app quits, sometimes it beachballs.

1 Like

Hi @markauk,

Thank you for taking the time to try a database refresh. My team is taking a deeper look into the logs to pinpoint the problem.

I’m glad that you’re able to run the Roon Remote in the meantime, although with a circuitous startup process. Hang in there for now, and we’ll have more information shortly.

I haven’t had time to try a database refresh, but as it looks like this isn’t the issue I’ll hold off for now. In the meanwhile, if you need anything else from me please let me know.

I hope that shortly is soon :slight_smile:

This may be coincidence, but the number of times I need to launch Roon before it properly launches seems to be increasing - 13 times just now. Once Roon is launched everything works fine, though over time it does seem to quit randomly - usually after having run for days. That wouldn’t be a particularly bad problem, other than the effort required to successfully relaunch when I want to listen to music.