Roon Rock cannot find FFMPEG file on an Intel Nuc

Core Machine (Operating system/System info/Roon build number)

Intel NUC 6i5SYH

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

DD WRT software installed on a TP link AC 1750
Everything is set on a static IP: Roon at
Streamer is on a Silent Angel Bonn Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Streamer: Sonore UltraRendu

Description Of Issue

While installing Roon rock on a Nuc, it says: missing codecs
However: I copied the file FFMPEG in the DATA/Codecs folder on the Roon Rock server
File is a 75.8 MB from AMD64 download and i686 download is 48.3 MB

But sadly on the tablet Roon Server Software still indicates Missing Codecs

Did you unpack it twice? You just need the file called ffmpeg nothing more.

Another part of the ROCK instructions that needs to be made clearer

Very true. Roons docs really need attention it should not be up to forum members to have to keep this knowledge known.

I still don’t understand. I downloaded this file:


unpacked the file in linux terminal:

tar -xvf ffmpeg-git-amd64-static.tar.xz

then entered the folder. The FFMPEG file is listed there in green in the terminal. I copied this one to the desktop and from there to the Roon folder DATA/codecs.

Sadly Roon still says missing codecs while the FFMPEG file is copied.

You need to unpack the FFMPEG file that you got after the first unpack.
The FFMPEG file that results from this 2nd unpack is the codec you want to move to the ROCK folder.

Confusing, ain’t it?

No, sorry, I still dont understand. Howto unpack a green file? It is unpacked once from the tarball - results in a green file and have no idea howto unpack it further.

It’s been awhile since I ran ROCK.

See if this thread helps -

This messes with everyone. No need to be sorry.

i an still stuck, copied exactly the correct FFMPEG file which was highlighted in de previous topic and copied that one to the right folder. And still missing codecs

I don’t know it anymore. :cry:

OK, I just tried it under WIN10.

Your downloaded file should be - ffmpeg-git-amd64-static.tar.xz

Unzip that and you’ll get a folder- ffmpeg-git-amd64-static.tar

Open that folder and you’ll get a folder named - ffmpeg-git-20200909-amd64-static

Open that folder and you’ll get this -

The ‘ffmpeg’ file there is the one to move to the ROCK’s Codec folder.

Sorry, I don’t speak Linux, only Windows and a smattering of macOS.


It seems to be a permission problem.
Delete the file on ROCK and copy it again as root (or with sudo) with the commands mentioned in this post,

In my case:

  1. sudo mount -t cifs //rock/Data -o vers=1.0 /mnt/
  2. sudo cp ffmpeg /mnt/Codecs

Afrer that reboot your NUC.


Yes it is permission problem.

After reading another topic I found a solution and got the right FFMPEG file copied, the file Slim_Fishguttz mentioned

I had 2 issues:

  • In Linux copying failed, probably due those permission problems florid mentions,
  • in windows 10 the location was not shown at all,

I decided to fix the Windows issue

First SMB 1.0/CIFS Client need to be checked

to do that Run optionalfeatures check SMB 1.0/CFIS Sharing Support and check SMB 1.0/CIFS client

Second I needed to check Enable insecure guest logons in local computer policy

to enter local computer policy you need to enter gpedit.msc, but gpedit.msc is only available in windows enterprise edition, not in windows home. I downloaded the installation file from here:

And now after installation:

open gpedit.msc
computer configuration > Administrative Templates > Control Panel > Network > Lanman Workstation and there Enable insecure guest logons

Reboot the pc and Rock is visible in the file manager. Copy the Ffmpeg file to Data/Codecs

Restart the nuc and all my codecs are installed.

Tnx all for the input!


Hi aljooge. These steps have been posted in the forums for well over a year, did you find them here or did you solve it on your own. I am concerned that many solutions which are buried in these support threads are not easily seen / found by those that could use the information.

Actually, gpedit.msc is available in the Pro version as well. But, you are right not in home.

no, I did not solve it on my own, The original topic from 2017. Forgot the link, but very greatful that it. helped me

it is permission issue. copy ffmpeg file to ROCK with linux root user.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.