Roon ROCK crashes every night

Core Machine (Operating system/System info/Roon build number)
Roon ROCK v1.7 build 610)
Intel NUC8i7BEH
Transcend 128GB M.2 SSD TS128GMTE1105
Crucial 8GB DDR4 2400 CT8G4SFS824A (x2)
Samsung 860 QVO 1TB MZ-76Q1T0
Samsung GIR Plus USB 128GB Flash (MUF-128AB/AM) for backups

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

hard wired ethernet connection from Comcast business router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to Denafrips Terminator directly from Roon ROCK. Also ethernet to several Bluesound Node2i and Bryston BDP-2.

Description Of Issue

My Roon ROCK server crashes every night such that I have to do a power-off reset. It will not reboot from the web interface. Once reset, I have to re-enable the USB interface through the Roon application (running on an IPad mini - also ver 1.7 build 610).

It does not crash while streaming, only when inactive at night. It is possible it is crashing when attempting to backup, but a manual backup works fine. I have the backup schedule set for every 4 days, and since I just backed up, I will see if it makes it through the night without crashing.

Before the latest update (that initially had problems on my ROCK), Roon ROCK ran for a month with no reboot.

Hi @Jay_Torborg,

Thanks for reaching out!

How exactly do you know your ROCK has “crashed” - what are the symptoms you are seeing?

You mentioned that you cannot reboot it from the ROCK WebUI, how exactly does the WebUI look like when you are in this state? Do you see any errors listed there? Please share a screenshot if possible.

Last night, it did not crash which leads me to believe that it might be related to the automatic backups which I have scheduled for every four days. The previous night, I forgot to turn off the Roon Radio, so it was working fine in the morning.

When it does crash, the iPad control app won’t find the Roon Core. When I look at the status webpage, everything looks fine, but if I attempt to restart Roon Server Software, I will eventually get a message that says restart was unsuccessful. When I try to do a reboot using this webpage, I get a similar unsuccessful message. The NUC power light is still on. The only way to restart is to do a long push on the NUC to force it to turn off, then turn it back on.

I will post screen shots next time the error occurs.


Hi @Jay_Torborg,

Just wanted to check in with you here, is this issue still ongoing?
If you need further assistance, just let me know!

A post was split to a new topic: Nucleus Backups Not Avaliable?

Unfortunately, I’ve had a number of mains power outages (usually very brief) over the past several days - I think due to the wildfires in the area, but last night probably due to a lightning storm. So I had to power on the NUC in the mornings due to those.

But it does seem to be performing the backups now, so maybe this problem was intermittent, or was fixed when I forced a manual backup.

1 Like

Hi @Jay_Torborg,

Thanks for the update here! Do let us know if you encounter this issue again, hopefully it was resolved though.

I’ve been having more issues with my Roon ROCK crashing in the past few days. The last two mornings, it has required a power cycle reboot in the morning, then today it stopped working in the middle of playing a song with the same symptoms.

When I open the Roon app on the ipad, I get the Lost Connection screen.

When I go to the status page, initially it seems like everything is working, but if I refresh the page, I get this screen.

When I attempt a restart, I get this popup.

and attempting to reboot, I get this popup.

After a power off restart (long press on the power button to shutdown, then turn back on), I sometimes (although not every time) have to re-enable the USB port, and re-login to Tidal and/or Qobuz. Otherwise, everything seems back to normal.

  • Jay
1 Like

My Roon ROCK is getting more unstable. It has crashed several times today after playing for anywhere from 30 to 90 minutes. The last time, the status page was showing that everything was normal. When I clicked restart the Roon Server Software, it said it restarted, but the Running time did not change (and the Roon ipad app still couldn’t find the server). Likewise, when I selected reboot, the popup said the server had been rebooted, but it hadn’t. I had to power cycle the NUC again to get it to restart.

Hi Jay

Like you I had a lot of problems in particular when the ROCK was backing up the Roon database and also had to reboot every day or so

Then I got an error message indicating that the Transcend SSD (exactly the same version) was failing

So I replaced it with a more capable one

This is the current status

The transcend SSD’s seem to be the issue

I have seen other threads discussing the same issue

Best wishes

Thanks for your reply. What did you replace the Transcend with?


The more I think about it your issues reflect exactly what I had

This is the thread where I raised it

I replaced it with a XPG SX8200 Pro - which may be a bit of over kill but I bought cheap from ebay

I have also seen others being enthusiastic about Samsung SSDs

The key, obviously, is compatability

I would be interested to hear how you solve this - so I can be sure I have sorted my issue

1 Like

Have you tried the reinstall option? It may/should rewrite in areas not marked bad but the SSD. Nothing to lose by trying before replace the drive.

I haven’t tried that, but I will give it a try. I had to reinstall after the last update which caused problems on my hardware. It was very reliable before that last update having been up for more than a month, but since then, I’ve been lucky to go two days between having to do a power cycle reboot, and recently it’s gotten a lot worse.

Well, reinstalling didn’t fix the problem. Still crashed after 20 minutes.

The M2 SSDs that are Intel Validated on their compatibility tool are all pretty pricey (and WAY bigger than required). I’d be willing to make the investment if I was confident that it would fix the problem.

What does Roon recommend as a good, reliable M2 SSD for the NUC8i7?

Sounds like a hardware issue. Have you reseated RAM and the M.2 SSD?

Stick with big names like Intel, Sandisk, Samsung. Buy an ‘older’ smaller drive.

Like this one:

or Transcend is OK too for the ‘lesser’ tier

Hi @Jay_Torborg,

This does sound like a hardware issue, so it would be good to investigate this further.

We have a list on our ROCK: Getting Started Guide or you can see other user’s experiences if you search around on the forum.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.