Roon Server and NAS not connecting [Solved]

Hi Mike,
I am trying to connect synology NAS, but having similar problem. it says Host is unreachable. I’ve read through threads regarding with synology connection: SMBv3 enable, no mac file service, login id no space, both tried actual address and name. But no luck.
can you help me?

Can you ping the nas from the Roon Server host?

100% packet loss. what could be the problem? NAS is on. I can browse folders through Finder (mac) and browser.

I presume you’re not browsing from Roon Server host? Is it on same subnet? What’s the Roon Server host IP and the NAS’ IP? Do you have firewall rules blocking access?

Oh. I didn’t even know there was Roon Server host and had to install on NAS. (Sorry I am very new to this.)
Do you mind instruct me? I tired to follow this thread, Synology SPK-Package: Development
but I am not confident to follow.

Hi Richard,

I’ve extracted your post to a new thread in Support so it can get some individual attention. Can you provide details of your setup as set out In this post ?. That will help narrow down where the issue is.

You don’t. If you’re able to browse the NAS in Finder, you should be able to just add the address, log in, and password in Roon.

Can you tell us a little more about your setup?

How are you browsing the NAS in Finder? What are you entering in Roon? Does the address you’re entering in Roon work in Finder if you enter it under Go > Connect To Server?


  1. I can navigate through shared network. oh, I just found out that it only works with afp. I tried to connect my diskstation with smb, but somehow it is not working. This might be the problem right?
    to answer your other questions
  2. I was entering in Roon like this smb://rcp_NAS/music
  3. and it failed.

I thinks this is not relevant with Roon but could you help me setting smb?

@evand Thanks for helping me out.
@andybob Thanks for separating thread. I wasn’t sure where to ask.

You need to be using smb, that’s why you’re experiencing issues. I think there are a number of threads and possibly a FAQ covering SMB.

Thanks for the help
for me, somehow name of diskstation didn’t work. I had to put IP address instead. and firewall was an issue too.
now it is working

Thank you all.

1 Like