Roon skips all songs and won't play [Solved - Driver issue, solved by enabling advanced setting on device that misreport capabilities]

Hello @Roman_Pacheco1,

Can you confirm that you have tried installing the newest Realtek drivers as well? Drivers can be found here, just please make sure to select the correct drivers for your device. After you have installed the newest drivers, please give that USB device another try and if it is still failing then mark down the exact local time in your country that playback fails (ex 11:32AM). I have enabled diagnostics mode on your account and what that will do is automatically send to our servers any error/crash reports you experience, if you can let me know the exact time it fails playback I can cross-reference the times received from the logs and hopefully it can point us towards what’s going wrong here. Please let me know when you have a chance.

Thanks,
Noris

@noris: Thanks for the quick follow up.

I uninstalled and reinstalled the Realtek drivers. I used the link you provided (even though I’d already done that last night as well, but just in case) and installed the R2.82 drivers since I have 64-bit Windows 10. I rebooted after uninstalling the old drivers (just as the install wizard instructed), installed the latest drivers, and then rebooted once more. Afterwards, I reopened Roon and attempted to play via both the USB headphone device as well as my Realtek System Output device. Both fail in the same way as described above. Failure time is 11:05 AM local time.

Hello @Roman_Pacheco1,

Thanks for your reply and providing time-stamps. We have successfully received the logs from you and I will be submitting a ticket with out QA team to see if they can identify anything wrong. Please note that this process may take some time while it reaches their review queue, if you would like to try some other things to get it working for this weekend I would recommend trying to install Roon Core or Roon Bridge on another Computer (at least temporarily) to see if that solves the USB driver issue. I appreciate your patience here while we attempt to identify what could be going wrong.

Thanks,
Noris

Thanks, I eagerly await the QA team’s response.

@Roman_Pacheco1,

You can also install Roon Bridge in the meantime on another computer if you don’t want to move the entire library over just yet and see if that new computer is giving you troubles playing the songs as well. I will let you know once I have more information to share.

Thanks,
Noris

By the way, I used Roon on a Macbook Pro to test the USB headphones and they work great on it. It’s just on the original Roon Core on Windows 10 that it doesn’t work (as reported originally).

Hello @Roman_Pacheco1,

Thanks for confirming for us that the Macbook Pro works with the headphones, I have added that as a note in your case. The team over at QA has requested some more information regarding your setup. Can you please open Device Manager and take a screenshot of your Audio Zones with the Sound, video and Game controllers area expanded? It should look something very similar to this:

Please post the screenshot here when possible.

Thanks,
Noris

@Roman_Pacheco1 Are all your devices running ‘Roon 1.4, build 310 64 bit’ as per your first post? Any reason you are not running 1.5 build 323 not that I am saying that is the issue. My apologies is you are already at 1.5?

In the time since i posted this issue Roon has been updated to 1.5. build 323. The issue still persists. Here’s a screenshot as requested:

The Logitech G430 Gaming Headset is the primary unit I’m trying to get working with Roon in this case

Hello @Roman_Pacheco1,

Thanks for providing the screenshot, it is a good sign that the logitech is visible there and will make sure to forward that to the QA team, just to be a little more thorough here, can you also right click the “Logitech G430 Gaming Headset” and open the properties tab and navigate to “Driver” and post a screenshot of that as well? Should looks something like this:

Thanks,
Noris

@Roman_Pacheco1,

Thanks, I have forwarded your screenshots to the QA team reviewing your case. I will be in touch again after they look into this issue a little further.

Thanks,
Noris

1 Like

@noris hi, has there been any further progress in this? I first reported this issue over 40 days ago so I’m hoping to get to be able to enjoy Roon on my PC soon. thanks.

Hello @Roman_Pacheco1,

I do apologize regarding the delayed response here, I want to assure you we have been actively looking into your case and I wanted to make sure I have something concrete for you from our team before responding. We have reproduced the issue in-house and have identified a possible solution.

On your Windows computer you likely have the Logitech Gaming Software installed and our team has identified an incompatibility between the way that the Logitech Gaming Software communicates with the headset when Roon is active. This incompatibility is due to the way the software sends the music to the headphones and incorporates the 3D visualization technology used in that headset. Unfortunately, it is not possible to use both Roon and that Logitech software on the same machine so the simplest solution here would be to uninstall the Logitech Gaming Software, reboot the computer and try the headset again using Roon.

If it is still not working after uninstalling the software, some other users mentioned that the headset would not work when plugged into a USB3 port but work work fine when plugged into a USB2 port (https://community.logitech.com/s/feed/0D531000050zzK4CAI). Please give that a try as well but simply uninstalling the Logitech software should resolve this issue.

I realize that this headset’s main selling point is the 3D visualization technology and without that Logitech software it is not possible, so if you are really inclined to use the visualization technology a few users reported that work around was to use an older driver for that software (https://linustechtips.com/main/topic/464061-logitech-g430-and-windows-10/). As mentioned in that thread, the older driver is LGS_8.74.80_x64_Logitech Driver and I have included a download link to that specific driver below:
32-bit download link
64-bit download link

I would only try that specific driver after confirming that Roon works without the Logitech Software at all, as it is still your best bet for full compatibility with Roon in this case. Once again, to summarize the steps here:

  • Uninstall the Logitech Gaming Software
  • Reboot your computer
  • Verify that Roon works
  • If still inclined to use the Logitech 3D features, optionally try one of the older drivers listed above
  • If Roon doesn’t work with the older driver, uninstall the software again for maximum compatibility with Roon

I hope this helps, please let me know if my suggestions fix the issue at hand or if you have any other questions!

Thanks,
Noris

Thank you so much for looking into this. I don’t have any 3D visualization features turned on for the headphones, I’m not using any surround sound or enhancements from them. Unfortunately, though, the Logitech Gaming Software controls all my peripherals, not just headset. I use my computer for gaming in addition to enjoying music and all my peripherals are by Logitech (mouse, headset, keyboard, etc.). Removing this software means I will lose all my keyboard macros, my mouse DPI settings, etc. Unfortunately, it looks like Roon is not a good fit for my setup. I won’t be ruining my ability to use my mouse and keyboard just so I can listen through Roon. I have paid for a year’s subscription but I will not be renewing unless there is some other way around this that doesn’t involve having to be stuck with old drivers for my peripherals or losing their functionality altogether.

thanks nonetheless

Hello @Roman_Pacheco1,

I have some fantastic news, we believe we have a viable solution to the problem you are facing even with the Logitech Software installed, my apologies that it has required this much testing on our end but are fairly confident that this small change will allow you to enjoy Roon.

Please open Roon and navigate to Setings -> Audio -> Click the Cogwheel next to the Logitech Gaming Headset -> Device Setup. Under that opened Device Setup, press “Show Advanced”. Scroll down all the way towards the bottom and enable “Work around devices that misreport capabilities”. The page should look like this and I have highlighted the setting:

After you have enabled that setting, you may need to restart your Roon App. Try to play some music after you have done so and let me know if it’s working. If you do not see the setting there, just let me know and I can see if there is another way to access it but I just verified that it appears on our end on that page. I hope this helps and please let me know when you have had a chance to try my suggestion.

Thanks,
Noris

2 Likes

Woohoo! Indeed, that does seem to work! Thank you so much for working towards a solution that works for me, I am very impressed with the quality of support you’ve provided. I’ll let you know if anything else comes up, but for now, it’s finally time for me to enjoy some music on my computer.

Thanks, @noris!!

Hello @Roman_Pacheco1,

Glad to hear it all worked out and we have you up and running again! We hope that you enjoy Roon to it’s full potential and we are always around if you run into any additional issues, don’t hesitate to ask! I have gone ahead and set a timer for this thread to automatically close should you not run into any additional issues regarding the Logitech Headset, but if you notice anything going wrong in the meantime just let us know. Once again, thanks for your patience here while we resolved the issue!

Sincerely,
Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.