Roon Storage area states in RED that the drive is not available

Roon Server Machine

Music is stored in music fold on Win 11 computer. 12000 tracks. Roon sofware reports only 1200 tracks–those that I’ve purchased via Qobuz.

Win 11 Professional . See screenshot. Nucleus attached via ethernet. See screenshot

Networking Gear & Setup Details


Connected Audio Devices

Number of Tracks in Library


Description of Issue

In the Roon storage area (see screenshot), the software states in RED that my Win 11 computer “This disc is not available”. Whereas in Windows explorer, I can SEE the nucleus and the XPS computer. See screenshot.

I’ve totally uninstalled Roon twice and reinstalled. No help
I’ve mapped the music folder, to share it, multiple times. No help.
I see that the roon.exe is allowed through the Avast program, so I don’t believe it is a firewall problem.
I’ve checked the advanced Internet settings–Discovery is on. There is no password requirement.
The SMB settings are set as before.
Of course, I’ve rebooted multiple times.

I DO have access to a limited portion of my library --1200 tracks–the ones that I’ve purchased in Qobuz.

The system worked FINE before I turned off both the computer and the nucleus while I took a vacation.

What next? Should I rebuild/renew the database? I’ve done this before (so I have the instructions), but I’m reluctant to do this, since it seems like this is a basic networking problem.

I welcome your input!

Is the file sharing active and working for the \\XPS…\aemer\Music folder in Windows file sharing? Can you access this share from another computer (not just see the XPS computer as a whole)?

Thanks for the suggestion. I do have roommates (with computers), but I’ve never assessed whether my computer can share with theirs. I am a neophyte in networking. It would be great to have detailed instructions to test whether my XPS computer can share with other computers. Thanks so much, in advance!

This gives an overview with pictures for how to enable file sharing on Windows in general (you may have done this, but verify) and then how to share a specific folder (which you may have to do for the the \XPS…\aemer\Music folder):

It ends with how to access this shared folder from an iPad, but here is instead how to do it from another Windows computer:

Your Nucleus states that it has 4TB internal storage that can be used for music files. Is there some reason why you are using networked attached storage on the XPS2022-AWE PC rather than the Nucleus storage?

Indeed. The Nuclues has ample storage. I just tested my ability to play the one album that I placed on the Nucleus a couple of years ago and indeed it plays fine. Which pleases me!
So you are saying I could just copy my music folder from the Windows computer over to the Nucleus --seems simple enough. Off the cuff, there are two downsides to this approach.

  1. Every time I add music to my library, I will need to copy it over to the Nucleus.
  2. Intellectually (and practically) I will not have solved the root (current) network problem.
    Thanks so much for the suggestion. I will proceed forthwith.
    Also, when I have time, test the ability of my Windows computer to another computer. Note: I have an Android, not an Apple phone.

Thanks for the link.
I have an Android phone. I found this link:
Stepwise Tutorial: How to Control Windows 11 from Android.
Will try later.
Thanks for your help!

I notice that you said “there is no password requirement”. I suspect that a Windows Update has flipped the switch again that you reported back in May last year:

Microsoft really doesn’t like user credentials without passwords.

Hello Geoff,
Since a Microsoft update last spring turned on a password requirement, that is one of the first things I checked Jan 2024. The password requirement is OFF. See screenshot.

Thanks for the suggestion, though.

Update: I have copied and pasted the entire Music folder from the WinXP computer over to the Internal Storage of the Nucleus. Roon now reports my full libary of 12,000 tracks. This is indeed progress.
One downside is that I don’t have ready access to the history section. Anything played before Jan 12th of this year (prior to the problem arising is marked in RED. See screen shot.

For the history problem, I will have to solve the networking problem. I’ll work on that later, when I have more time.

Update: Using the “mapping a drive” option within this link, I mapped the Music folder from my XPS computer to a Z drive. Then I rebooted.
See screenshots
Mapping XPS as drive Z
Music folder is mapped

The XPS computer is still RED in the Storage area of Roon software.
Roon storage area in RED states in RED -this drive is not available

Recall now all my music files are on the Nucleus and Roon can access all of them–which is huge progress. The downside is that my History and Playlist access is corrupted.
However AFTER I mapped the music folder (using the link above), I do have access to many, but not all of the tracks in History, and most of the tracks in my Playlists.
So this is further progress.

Some kind of network problem remains–since, as mentioned the Storage area of Roon still tells me that my XPS. I wonder if I have the “correct” permissions.
Do I have the correct share permissions

Further help is desired.
Thanks so much

Yesterday I mapped the Music folder (to a Z drive) and rebooted. (At the time, some tracks in History and Playlists were marked in red). However, waiting overnight, the Music folder path is no longer in red in the Storage area of ROON.
So the issue is resolved.
I am unclear why I had to wait overnight. But I’ll take the solution.
Thanks everyone!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.