Roon Won't Enable Audio for Devices Connected to My PC

Hi there,

I had a computer die and installed Roon on my new PC today. It’s the latest build (1.3; build 223/Windows x64), control/core/output. I’m just using the app on this PC; no remote connections of any kind. When I go to the audio tab and try to enable a connected device, the app gets stuck on loading and won’t finish. When I attempt to refresh, the entire connected section disappears. If I close Roon and reload, the connected section reappears again. I have the same device options on this PC as the last one (dfx Audio Enhancer and the RealTek stuff that came with the computer). I’ve tried to uninstall and reinstall, restart the computer, turn the computer off and reboot. None of this helps. I know it’s a Roon-centric thing because other apps work (including Tidal). Checked the log of my firewall and no problems reported. Any ideas?


This is mostly likely related to the Windows / Driver installation.

What version of Windows is the PC running?
Are all the Microsoft updates installed?
Have you checked / updated the device drivers?

Also, just as a test … try disabling the firewall.

It’s Windows Home 64-bit, completely updated.All audio device drivers up to date. Disabling the firewall doesn’t do any good. The connected device section disappeared when I tried to enable.

Could it be related to switching to a new machine?

[quote=“Michael_Hoyle, post:3, topic:25044”]
It’s Windows Home 64-bit
[/quote]On a new machine I assume that is Windows 10, is that correct?

Almost certainly, and I’d put money on it being an audio OS device driver. However, you have confirmed you have addressed the typical trip hazards and at present I can only suggest uninstalling Roon and reinstalling.

It’s worth a go … after that I’m stumped, so I’ll leave a tag for @support to follow up with you.

One more question, did you restore the Roon database onto this new PC? It’s a slim thought but I’m just wondering if there is something that carried over from the Roon install on your other PC that is somehow affecting your new setup.

1 Like

Hi @Michael_Hoyle ----- Thank you for the feedback and my apologies for the troubles here. I would also be curious to here if you had restored the DB onto this new PC as @Carl is asking in his post. Can you verify that information for me?

Furthermore, can I ask you to please navigate to the same directory in which your Roon DB can be found and delete your RAATServer folder. I’d like to see if this triggers a change in behavior here. Example below :sunglasses:


Hi Eric,

Deletion of the RAATServer folder did it… Thank you so much!

However, the folder then reappears and stops the connection again. I can delete the new file and things start working again. At least I can use the program for now. Definitely something RAATServer-related, though…

Hi @Michael_Hoyle — Thank you for touching base with me and giving the proposed test a shot. I appreciated the feedback!

I was reviewing your posts one more time to see if I had potentially missed anything that could be influencing this behavior and just noticed that you are making use of RealTek drivers. Not long ago I had two users experience a similar situation to yours and the resolve was to uninstall the Realtek driver that was preinstalled with their Asus motherboards.

Based on your report it sounds like these drivers were pre-installed on the computer when you got it. I would recommend uninstalling the RealTek driver(s) and seeing if “functionality” returns to the device hosting your core. In the event that it does not I would suggest going onto the RealTek website and downloading the driver(s) directly from there.

Let me know how it goes!

Hi Eric,

No dice on that fix. I uninstalled the RealTek driver and Roon immediately found the system output. Unfortunately, the output no longer functioned without the driver, and the direct install from RealTek didn’t change that. For now, I can make Roon work by deleting the RAATServer folder before each startup. Not a high price to pay. Ultimately, I think the problem may be an ASUS utility on my new laptop called Sonic Studio, which has control over the system output and runs on the RealTek driver. There’s no uninstall option for it, so it looks like I’m stuck with it.

Contact Asus and tell them you want it off the PC because it interferes with Roon. They should be able to offer you a solution.

Apologies if it is not within bounds to reply to an old thread, but perhaps this might help some other user(s). I searched for several hours until I found this thread. I have an ASUS MB also with the “Sonic Suite 3”. Rather than uninstall the drivers (I do find some of the pieces useful) and the software completely, I disabled Sonic Suite 3 at startup. This solved my problem. It’s an extra step when I want to use SS3, but I expect I will be using Roon more often. I started by simply stopping the two programs / services using Task Manager, but decided it was easier to only have them run as needed. Not a Win10 expert, but I hope this was clear and helpful.

I’m having this problem on my son’s PC. I really don’t want to uninstall the Realtek drivers because my 10 year old son does make use of some of the features of the driver set and I am not interested in trying to reconfigure all his video games.

Has Roon made any progress making RAAT work reliably with Realtek drivers?

Hey @James_I,

Is the behavior the same when using the 32-bit version of Roon? I doubt it would make a difference in the Audio drivers but I have seen it impact display drivers.

We do not really have a way to bypass the Realtek drivers, I would try to verify the behavior with Sonic Suite 3 shut off as well.


Thanks Noris. I’ll try installing the 32 bit version. I also thought to try to install just Roonbridge even though that would double the number of devices showing up locally. I’m just sure what else to do, and don’t want to uninstall Realtek.

This problem even affects the non-Realtek devices (HDMI audio) on the local machine. Are we sure that is all caused by Realtek?

(Yes, turned off the firewall…)