Roon won't launch - 2019

Roon won’t lanch on Lenovo Yoga C930. I only have Windows Defender running on default settings. Turned off wireless, didn’t work. Unplugged from docking station and tried to launch on wireless, didn’t work. Tried changing graphics from 4k to 1080p, didn’t work.

Following is from Event Viewer:

Faulting application name: Roon.exe, version:, time stamp: 0x5c6d8de2
Faulting module name: ig9icd64.dll, version:, time stamp: 0x5ad7983a
Exception code: 0xc0000005
Fault offset: 0x0000000000024021
Faulting process id: 0x1570
Faulting application start time: 0x01d4efbeb9ff660e
Faulting application path: C:\Users\brent\AppData\Local\Roon\Application\Roon.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\iigd_base.inf_amd64_9c51dbd523d6a83b\ig9icd64.dll
Report Id: d7b95c82-1002-47ba-b51e-e6072e033149
Faulting package full name:
Faulting package-relative application ID:

It also throws a .NET error in Event viewer at the same time:

Application: Roon.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at Broo.Gdi.SwapBuffers(IntPtr)
at Broo.Engine.DeviceTarget.GuiMainLoop()
at Sooloos.Application.Main(System.String[])

Hi @Brent_Starnes,

Is this a remote device or your Core machine? Was Roon previously working on this device?

I was hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link.


Remote device. It has never worked reliably, I think I got it launch once in the past. I have the zip file, how do I get you the link? Just paste it here?

Hi @Brent_Starnes,

Yes, please paste the link here and I’ll pass it along to the team. Thanks!!Ar1fMroqZhNTkZBFCDMTQXaG5ikt-A

Thanks, @Brent_Starnes!

I’ve passed this along to the team, I’ll be sure to let you know as soon as I receive their feedback on this.

Hi @Brent_Starnes,

I’m going to meet with the team to discuss this today, but I was hoping you could try something in the meantime. If you temporarily disable Windows Defender is there any change in behavior?

Just to verify, there is no other antivirus or firewall on the device?

I tried it with Defender disabled, didn’t work. There are no other firewalls or antivirus apps installed. I’ve also tried running as administrator, 3 clean installs, changing the graphics settings to 1080p, install with and without secondary monitor attached.

Hi @Brent_Starnes,

I discussed the logs that you sent over with the team and wanted to follow up with their findings.

The errors that you’re seeing in Event Viewer are related to OpenGL, which is a requirement for Roon. These types of errors are frequently caused by issues related to the GPU of the machine. To start, can you verify that the graphics drivers on your machine are fully up to date?

Just running whatever drivers shipped with the Lenovo Yoga c930. I’ve got all the latest Windows patches installed.

Good news, bad news…I found the problem. I had Display Fusion installed, and it seemed to be suppressing the OpenGL drivers. I uninstalled it and Roon launches now. 2 problems remain:

  • I want to run this with Display Fusion installed, as I use it to manage my monitors

  • I have to run Roon in Maximized mode because my resolution is too high. Roon really needs to support higher resolutions in windows mode.

Hi @Brent_Starnes,

I’m not familiar with Display Fusion, but there may be settings that allow OpenGL to run properly so Roon can be used.

What are your scaling settings on Windows currently set at?

300%, it’s a 4K panel.

Hi @Brent_Starnes,

There is a post here that describes how to set scaling in Roon independently of your Windows scaling settings. Give that a try and let us know if that helps!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.