RoonServer starting, running, error, restart and so on

Core Machine (Operating system/System info/Roon build number)

MacOS Mojave 10.14.5
Mac Pro (Late 2013)
64 GB 1866 MHz DDR3
Roon 1.7, build 505

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Fritz!Box 7530 ST
core wired
nas wired
endpoint 1 wired, 2 wireless (but not relevant in this case)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

not relevant because a server issue

Description Of Issue
Last night streaming Qobuz the streaming stopped suddenly.
All controller apps were in a loop (trying to connect, a second later back to the screen last used, trying to connect again and no way to interfere …).
So I hoped it was a temporary connection issue and went to sleep.
This morning still the same issue.
I restarted router, roonserver, and the controller in all kinds of sequences and suddenly I did get the message in red that a connection to Tidal could not be established with the possibility to edit this setting. So I disabled Tidal. The same for Qobuz. At this point I was out of the loop and could use the local albums and Internet radio.
I re-enabled Qobuz and immediately the looping started again. Unfortunatily I do not get the Tidal/Qobuz messages again.

How to get out of the loop and get access to disable the Qobuz/Tidal services again?

Hi @Paul_Hermans,

If you check the Web UI is RoonServer running during this time or is it stopping and starting repeatedly?

First of all:
I managed to get access again by disconnecting the DSL cable and disabling the Qobuz service. I’m only using Tidal now and that works. However I’m not able to access the Web UI. In ‘Configure Roon OS’ it keeps saying ‘searching for devices’.

But to come back to your question. Using the server and looking at the roon menu bar icon, it indicated starting, running, error, starting, running, error …
When I changed to Roon (not server) then the app just crashed.

Hi @Paul_Hermans,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi @dylan,

I enabled Qobuz at 20:05 Brussels time and the app immediately crashed.



@dylan And another one at 20h47 adding a Tidal album to my library.

Hi @Paul_Hermans,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.

Hi @dylan

Logs at

Hi @Paul_Hermans,

These logs don’t look quite right The date they’re showing is from February. Are these directly from the Core machine or a remote device?

Thought my database was on the NAS where version Roon 1.5 did run for a while.
These are the correct ones.

I was streaming a local file when I ran into issues, but this sounds almost identical to what I’m reporting in Clients suddenly unable to connect to server. Maybe our situations are related?

A post was split to a new topic: Troubles connecting to RoonServer when logging in to TIDAL

Indeed, looks the same to me.

To clarify I experienced the issue using RoonServer. One of the things I tried out was installing Roon (core+client) on the same server but it gave the same behaviour. Hence the 2 logs.
I have a third setup since then on my MacBook, but again the same. If you need I can supply this one also.

Thanks, @Paul_Hermans — The logs are with the team now for analysis and I’ll be sure to update you as soon as I have their feedback.


I have backups from 5 to 9 december 03:00 AM
Ther behaviour started the evening of 9 december late.

Hi @Paul_Hermans,

Can you try using a fresh database and let us know if this changes things here?

  • Stop RoonServer on the Core
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

@dylan Done.

App is busy now importing my Qobuz library. No issues so far.

Now Tidal; also no issues.

Now loading local files; no issues so far.

Unfortunately I have to go now. The only thing to be checked is applying all settings again.


For the moment all is running without issues.
What to do next to get my playlists back?

Do I send you the corrupted databases?

Hi @Paul_Hermans,

The team is currently investigating this issue. You can try to restore a backup that you might prior to this issue occurring, but it’s hard to say just yet if the issue will return. For now, I recommend using the current database while we wait for feedback from the team’s investigation. Once I have their feedback I’ll be sure to reach out ASAP.