RoPieee LCD Beta stuff - tell it like it is

That’s what it’s doing Simon. It only scrolls if texts don’t fit.

1 Like

@spockfish Harry just sent you feedback…was playing tidal album nicely then paused on the remote not the lcd and selected another tidal playlist and suddenly no audio. To scared to touch the volume but it was 25. I’ll restart it later but give it time to get the logs packed off to you.

Hey Harry, both of dad’s Ropieee’s working well. The display has stayed off in the morning after the 3am reboots.

The latest 0.3.5 update seems to have fixed last week’s issue that he was having although I still have no idea what that was.

All happy again now though :slight_smile:

1 Like

I had a bit of a eureka moment today as I pondered if I would risk a play on the digiamp+ enabled lcd setup…I’m using all 4 wires for the lcd (power and i2s bus I think the other 2 are)…I might just pull those wires off and see if that improves anything…my other 2 lcds have no hats and work fine with just the 2 DC wires for 5volts. (Done and will monitor for future glitches) - I think I recall the 2 extra wires are only needed for the RPi 2B inits not the 3B

@spockfish Another thing I noticed on the web interface is that perhaps the restart roon extension should be removed if there is no LCD

I tried to power my PiLCD setup from PC USB port and that failed with lightning bolt issue. So I went back to the RPi power supply but tried it on the LCD power connection…also lightning bolt but on the Pi DC connection its fine.

Ya a couple of weeks ago I suggested that, to those powering their Pi via the Touchscreen - to instead power the Touchscreen via the Pi instead (if getting the lightning bolt). But some cases make it difficult.

Thought I would mention that my power issues I was having seem to have gone away. I took my unit apart and reconnected everything and all is ok. So I think last time I updated the SD card I must have dislodged something that was causing the power fluctuations. Nothing now for 4 days. It also has been a lot cooler in the UK recently so maybe heat took its part too. Will see if it reappears if things warm up again.

Saying this woke up to find it stuck in a boot loop so had to reflash with the latest beta so back in the program.

Interesting developments here. You can now view and search library via webui.

I’ve seen it with my own eye…its there but its not showing…Harry stop teasing me :stuck_out_tongue:

The subliminal clock saver hows as one touches the screen from black as it scrolls the main display back…I’m on the edge of my seat…did it today on all 3 units.

1 Like

Things seems reasonably quiet over here now.

Everyone must be really enjoying Ropieee and Touchscreen ! :wink:

I certainly have been and dad tells me it’s been really stable and working fantastically for him too.

1 Like

you caught me :wink:

But on a serious note: this requires some work though. I’m not entirely happy with a few things that need some rework first, but it will come.

1 Like

Greatly enjoying Ropieee and the video display. Oddly, after I flashed the latest beta release I get brief lightning bolt during bootups, but not when using Ropieee while listening to music. All seems to function despite these. I got none until this latest release.

1 Like

Hi David,

Thanks for your feedback.
What could explain the symbol with the latest version is that I’ve changed something to the startup sequence. As things are done in parallel it could very well be that for a brief period of time the RPi is running at full throttle.

I’ll put it on my list. From a user perspective there isn’t a particular need to ‘boot as fast as possible’, so maybe I can relax this a little bit.

Thanks,

1 Like

Thanks, Harry. That makes sense. I appreciate you looking into it. And thanks for all the great work on Ropieee.

1 Like

Yep I am getting at boot only too.

Hi Harry,

My display arrived today.
I installed ropieee-beta-20170712 and the endpoint works fine in Roon.

During the first attempt the display remained blanc.
After a reboot I see text and the display is upside down.

Flipped 180°:

After some time the screen turns black again. Probably the screensaver.

What did I do wrong? Wrong image?

Regards,
Wim

The new image takes a good 10 mins or more depending on the speed of your sad card and the internet to download the updates and write them to the card so how long did you wait?

Playing music on the RoPieee for about an hour now.
I rebooted a few times, but nothing is changing.
Still text screen that turn blanc after some time.
Sound is super by the way.
Meridian Explorer² and Samsung Level Over headphones.

Did you rotate it in the web interface and set the time etc? There is also a setting option in the top right corner of the screen when it’s up the right way

Also what rpi version are you using and if it’s a 2b then you need to connect 4 wires on the pi to the display